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END USER LICENSE AGREEMENT

[PANAVIEW SOFTWARE VERSION 1.6.3]

YOU MUST READ AND ACCEPT ALL TERMS AND CONDITIONS OF THIS AGREEMENT BEFORE USING THIS SOFTWARE.  GE 
INFRASTRUCTURE SENSING, LLC. (“LICENSOR”) AGREES TO LICENSE THE SOFTWARE TO YOUR COMPANY (“LICENSEE”) ONLY 

UNDER THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO THESE TERMS, PROMPTLY RETURN THE CD, DOCUMENTATION 
AND ALL OTHER COMPONENTS OF THE SOFTWARE TO THE LICENSOR AND/OR PERMANENTLY DELETE ALL ELECTRONIC FILES 

RELATED THERETO TO RECEIVE A REFUND OF LICENSE FEES PAID.

1. Definitions.

1.1 “Documentation" shall mean any Licensor user manuals and other printed materials delivered to Licensee in 
conjunction with the Programs. 

1.2 "Intellectual Property Rights" shall mean patent rights (including patent applications and disclosures), copyrights, 
moral rights, trademark/service mark rights, trade dress rights, trade secrets, know-how and any other intellectual property 
rights recognized in any country or jurisdiction in the world. 

1.3 “Monitoring Software” means Software designed for the remote, real-time performance, health, failure, tracking and/or 
up-time monitoring and management of field equipment and related systems.

1.4 “Programs" shall mean the Vitality computer software program referenced above, including all modifications, 
enhancements, and revisions thereto that are either:  (i) expressly authorized by Licensor in writing; or (ii) created by 
Licensor pursuant to a software support agreement between the parties, if any.

1.5 “Sales Documentation” means the terms and conditions and other legal documentation accompanying the Baker 
Hughes-provided products with which the Programs are intended to operate.    

2. License.

2.1 License Grant.  Subject to the terms of this Agreement, Licensor grants Licensee a non-transferable, non-exclusive 
license to install the Program on one personal computer and use the Programs and Documentation to support any number 
or combination of authentic instruments provided by Baker Hughes and/or its affiliate(s) networked on the one personal 
computer.  Licensee may make one additional copy of the Programs and Documentation solely for archival purposes.

2.2 License Restrictions. All Programs are licensed and not sold.  Except as otherwise expressly provided in this Agreement, 
Licensee shall not make any copies of the Products or Documentation, and shall not decompile, disassemble, decrypt, 
extract or otherwise reverse engineer the Products, except as permitted by applicable local law with prior written notice to 
Licensor.  Any modifications, revisions, changes or enhancements made by Licensee to the Products or Documentation, or 
any reverse engineering of the Programs without Licensor’s express prior written permission shall be deemed a material 
breach of this Agreement, and any Intellectual Property Rights created without permission shall become Licensor’s sole 
property without any additional Licensor action necessary to perfect its ownership rights and interests.  Notwithstanding 
anything to the contrary in this Agreement, all rights, title and ownership of any such modifications, revisions, changes and 
enhancements shall reside solely in Licensor.  Except as expressly provided in Section 12.1, Assignment, the Programs shall 
not be sold, leased, assigned, transferred, distributed or sublicensed, in whole or in part.  Licensee shall not delete or in any 
manner alter copyright, trademark or other proprietary rights notices of Licensor or its suppliers appearing on the Programs 
and Documentation. IF LICENSEE TRANSFERS POSSESSION OF ANY COPY OF THE SOFTWARE TO ANOTHER PARTY WITHOUT 
WRITTEN CONSENT OF LICENSOR, THIS AGREEMENT IS AUTOMATICALLY TERMINATED.

3. OTHER AGREEMENTS.  

The Programs are intended to be used only with other Baker Hughes-sourced hardware and/or software, the sale, lease, 
and/or licensing of which is governed by the Sales Documentation. Accordingly, the use of the Programs shall be governed 
first by the Sales Documentation and then this Agreement. To the extent of a conflict between the Sales Documentation and 
this Agreement, the Sales Documentation shall control. In the event that there is no applicable Sales Documentation, the 
terms of this Agreement shall control the use of the Programs.

4. TAXES.  

Licensee shall, in addition to any license payments required hereunder, pay all applicable sales, use, transfer, value-added 
or other taxes and all duties, whether international, national, state or local, however designated, which are levied or imposed 
by reason of the transaction(s) contemplated hereby, excluding only income taxes on net profits which may be levied 
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against Licensor. Licensee shall reimburse Licensor for the amount of any such taxes or duties paid or accrued directly by 
Licensor as a result of said transaction(s). If Licensee is prohibited by law from making payments hereunder free of such 
deductions or withholdings, Licensee shall immediately notify Licensor and pay Licensor any additional sum(s) equal to 
such deduction or withholding.

5. WARRANTIES.

5.1 Limited Program Warranty.  Licensor warrants that the media on which the Products are distributed shall be free from 
defects for a period of ninety (90) days after delivery. As Licensee’s sole and exclusive remedy and Licensor’s entire liability 
for any breach of this warranty, Licensor shall, at its sole option: (i) repair or replace, at no additional charge to Licensee, any 
defective media; or (ii) if, despite using its reasonable efforts, Licensor is unable replace the media, refund to Licensee the 
applicable license fees paid for the non-conforming media after Licensee returns the media to Licensor, less a reasonable 
license fee for the period during which Licensee had use of the Program, using straight-line depreciation assuming a useful 
life of the Program of three (3) years. The limited warranty set forth herein shall automatically become null and void if a 
party other than Licensor modifies the Programs in any way.

5.2 Disclaimer Of Warranties.  EXCEPT FOR THE EXPRESS MEDIA WARRANTY ABOVE, THE PROGRAMS AND DOCUMENTATION ARE 
PROVIDED “AS-IS”, WITH ALL FAULTS. LICENSOR MAKES NO OTHER WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED.  
LICENSOR EXPRESSLY DISCLAIMS ANY AND ALL OTHER WARRANTIES, INCLUDING BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF 
NON-INFRINGEMENT AND THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. LICENSOR 
DOES NOT WARRANT THAT THE PROGRAMS SHALL BE ERROR-FREE OR THAT THEY SHALL FUNCTION WITHOUT INTERRUPTION.

5.3 Additional Warranty Disclaimer for Monitoring Software. While the Monitoring Software provides advisory information 
regarding equipment condition, it is virtually impossible to guaranty that each and every fault condition can be foreseen or 
detected. THEREFORE, LICENSOR EXPRESSLY DISCLAIMS ANY WARRANTY THAT THE MONITORING SOFTWARE WILL DETECT ANY 
PARTICULAR FAILURE OR PROVIDE ANY PARTICULAR AMOUNT OF ADVANCE WARNING OF AN IMPENDING FAILURE OR CONDITION OF 
THE MONITORED EQUIPMENT.

5.4 Except as expressly authorized by Licensor in writing, all Third-Party Software shall carry only the warranties provided 
by the owners thereof and Licensor gives no warranties for such Third-Party Software.

5.5 Excluded Uses.  UNLESS EXPRESSLY PROVIDED IN A SEPARATE WRITTEN AGREEMENT, THE SOFTWARE MAY NOT BE USED AS 
ON-LINE CONTROL EQUIPMENT IN HAZARDOUS ENVIRONMENTS REQUIRING FAIL-SAFE PERFORMANCE, SUCH AS IN THE OPERATION 
OF NUCLEAR FACILITIES, AIRCRAFT NAVIGATION OR COMMUNICATION SYSTEMS, AIR TRAFFIC CONTROL, DIRECT LIFE SUPPORT 
MACHINES, OR WEAPONS SYSTEMS, IN WHICH THE FAILURE OF THE SOFTWARE COULD LEAD DIRECTLY TO DEATH, PERSONAL INJURY, 
OR SEVERE PHYSICAL OR ENVIRONMENTAL DAMAGE.

IF, IN BREACH OF THIS SECTION 5.5, ANY SUCH USE OCCURS, LICENSOR DISCLAIMS ALL LIABILITY FOR ANY NUCLEAR OR OTHER 
DAMAGES, INJURY OR CONTAMINATION, AND IN ADDITION TO ANY OTHER LEGAL OR EQUITABLE RIGHTS OF LICENSOR, LICENSEE 
SHALL INDEMNIFY AND HOLD LICENSOR HARMLESS AGAINST ANY SUCH LIABILITY. IF LICENSOR AGREES IN WRITING TO ANY SUCH 
USE, THE PARTIES SHALL AGREE UPON SPECIAL TERMS AND CONDITIONS THAT PROVIDE LICENSOR PROTECTIONS AGAINST NUCLEAR 
AND OTHER LIABILITY WHICH ARE ACCEPTABLE TO LICENSOR UNDER THE THEN CURRENT LAWS THAT APPLY.

6. Limitations of Liability.

6.1 Exclusion of Damages.  WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE OR OTHERWISE, IN NO 
EVENT SHALL LICENSOR BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL LOSS, LIABILITY OR DAMAGES OF 
ANY KIND (INCLUDING BUT NOT LIMITED TO LOSS OF USE, DATA, BUSINESS OR PROFITS) WHETHER ARISING UNDER A THEORY OF 
CONTRACT, TORT (INCLUDING NEGLIGENCE), BREACH OF WARRANTY, PRODUCT LIABILITY OR OTHERWISE, AND REGARDLESS OF 
WHETHER LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, LIABILITY OR DAMAGES.

6.2 Total Liability.  IN NO EVENT SHALL LICENSOR’S CUMULATIVE LIABILITY ARISING FROM OR RELATED TO THIS AGREEMENT, FROM 
ALL CAUSES OF ACTION OF ANY KIND, WHETHER ARISING UNDER A THEORY OF CONTRACT, TORT (INCLUDING NEGLIGENCE), 
BREACH OF WARRANTY, PRODUCT LIABILITY OR OTHERWISE, EXCEED THE TOTAL AMOUNT OF LICENSE FEES ACTUALLY RECEIVED BY 
LICENSOR FROM LICENSEE UNDER THIS AGREEMENT. SOME STATES OR JURISDICTIONS DO NOT ALLOW EXCLUSION OF IMPLIED 
WARRANTIES OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

6.3 Additional Limitation on Liability for Monitoring Software. License acknowledges that the Monitoring Software generates 
advisory information but does not perform any automated control, and Licensor has no control over decisions made or 
actions taken on the basis of any such generated information. Licensee assumes total responsibility for Licensee’s use of the 
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advisory information generated by the Monitoring Software. THEREFORE, TO THE EXTENT THE SOFTWARE INCLUDES MONITORING 
SOFTWARE, LICENSEE BEARS THE ENTIRE RISK OF ANY LIABILITY ARISING OUT OR RELATING TO THE USE OF THE SOFTWARE.

6.4 Basis of the Bargain.  All warranty disclaimers and liability limitations set in this Agreement shall apply upon delivery of 
the Programs to Licensee. Licensee acknowledges that Licensor has set its prices and entered into this Agreement in 
reliance upon such disclaimers of warranty and the limitations of liability and that the same forms an essential basis of the 
bargain between the parties.

7. INDEMNIFICATION.

Licensee shall indemnify, defend and hold Licensor harmless from and against all claims, liabilities, actions, suits, demands, 
fines, penalties and all costs and expenses incurred by Licensor in connection therewith (including reasonable attorneys’ 
fees) arising out of or related to:  (a) Licensee’s use of the Programs in combination with software or hardware not 
specifically approved by Licensor in writing; (b) Licensor’s compliance with designs or specifications provided by Licensee; 
(c) any modification, enhancement or revision made to the Programs by anyone other than Licensor; or (d) Licensee’s 
failure to use any modification, enhancement or revision provided to Licensee by Licensor for the purpose of avoiding a 
claim of infringement.

8. Termination.

8.1 Termination for Breach. Either party may terminate this Agreement with respect to one or all of the Programs in the 
event of a breach or default by the other party; provided, however, no such termination shall occur until the 
non-breaching/defaulting party shall have given written notice of the breach or default to the breaching/defaulting party 
and such breach or default shall not have been cured within five (5) days in the event of a monetary breach or default and 
thirty (30) days in the event of a non-monetary breach or default.

8.2 Automatic Termination. This Agreement shall terminate automatically if: (i) either party becomes the subject of any 
voluntary or involuntary petition in bankruptcy or any proceeding relating to insolvency, receivership, liquidation or 
composition for the benefit of creditors, and in the case of an involuntary petition or proceeding such petition or proceeding 
is not dismissed within sixty (60) days of filing; or (ii) Licensee fails to pay license fees when due or commits a material 
breach of the license provisions in paragraph 2 above.

8.3 Effect of Termination. Upon any termination of this Agreement or of any individual Program license, Licensee shall 
promptly return to Licensor or, at Licensor’s election, destroy the applicable Programs and Documentation and all copies 
and portions thereof, in all forms and types of media related thereto, and provide Licensor with an written certification 
signed by a duly authorized representative of Licensee, certifying to Licensee's compliance with the foregoing. Licensee’s 
exclusive remedy for breach shall be the return of all license fees received by Licensor related to the affected Programs.

8.4 Nonexclusive Remedy. Except as provided otherwise in this Agreement, all remedies of either party shall be 
non-exclusive and shall be without prejudice to any other right or remedy of such party.

9. SURVIVAL. 

All provisions of this Agreement relating to liability, warranties, indemnities or confidentiality, and the provisions of Sections 
7, 10 and 11 of this Agreement, shall survive the expiration or termination of this Agreement.

10. GOVERNING LAW. 

10.1 This Agreement shall be governed by and construed in accordance with the laws of: (i) the State of New York, if 
Licensee has a primary residence, or is incorporated in the USA; or (ii) England, if Licensee has a primary residence, or is 
incorporated outside the USA; excluding in any case conflict of law rules. The parties acknowledge and agree that the 
United Nations Convention on Contracts for the International Sale of Goods, and the Uniform Computer Information 
Transactions Act as enacted by any State, will not apply to this Agreement.

10.2 Any dispute arising out of or in connection with this Agreement shall be finally settled in accordance with the 
International Chamber of Commerce (ICC) Rules of Arbitration in the English language and by a single arbitrator appointed 
under said Rules. The seat, or legal place, of arbitration shall be: (i) New York, N.Y., if Licensee has a primary residence, or is 
incorporated in the USA; or (ii) Geneva, Switzerland, if Licensee has a primary residence, or is incorporated outside the USA.  
This Section shall in no way be construed to prevent or otherwise limit Licensor from seeking any relief pursuant to Section 11 
below.
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11. INJUNCTIVE RELIEF  

If Licensee breaches, or threatens breach of any part of this Agreement, Licensee acknowledges and agrees that Licensor 
will be greatly damaged, and such breach (es) will be irreparable and damages associated therewith will be difficult to 
quantify; therefore, Licensor may apply to any court of competent jurisdiction, who, notwithstanding the Governing Law 
provisions above, will apply the laws of its own jurisdiction in determining whether relief shall be granted to Licensor, for 
injunctive or other equitable relief to restrain such breach or threat of breach, without impairing, invalidating, negating or 
voiding Licensor’s other rights to relief either at law or in equity.

12. GENERAL

12.1 Assignment.  Licensee may assign this entire Agreement with the sale of any of its Baker Hughes instruments provided 
that Licensee and its assignee agree in writing to comply with all provisions of this Agreement. Otherwise, Licensee may not 
assign this Agreement without Licensor’s prior written consent. Any other attempted assignment shall be null and void and 
shall automatically terminate this Agreement.

12.2 Compliance with Laws and Export. Each party shall comply in all material respects with all laws, rules, approvals, 
registrations and regulations of the United States and other countries that may be applicable to the Programs or to each 
party’s activities under this Agreement.Licensee agrees not to re-export U.S. or EU origin software or Documentation in 
violation of the applicable export control laws. In case of software or Documentation to be exported outside the U.S. and/or 
EU that are considered or likely to be considered as “dual use”, Licensee shall (or shall cause the end user of the software or 
Documentation to) provide to Licensor, promptly upon its request, an “End User Statement” in accordance with the 
applicable legal requirements. Licensor shall not be liable to Licensee for any delay and shall not be considered in breach of 
its obligations in the event of Licensee’s failure or delay in providing such statement.

12.3 Severability.  If any or all of the covenants hereunder are determined by a court of competent jurisdiction to be invalid 
or unenforceable, by reason that the breadth of restrictions are too great, or for any other reason, these covenants shall be 
modified and interpreted to extend over the maximum geographic area, period of time, range of activities or other 
restrictions to which they may be enforceable.

12.4 Force Majeure. Licensor shall not be responsible for any failure or delay in its performance under this Agreement due to 
causes beyond its reasonable control, including but not limited to, labor disputes, strikes, lockouts, shortages of or inability 
to obtain labor, energy, raw materials or supplies, war, riot, act of God or governmental action.

12.5 Entire Agreement. This Agreement is the complete and exclusive agreement between the parties with respect to the 
subject matter hereof, superseding and replacing any and all prior or contemporaneous agreements, communications, 
and understandings (both written and oral) regarding such subject matter.  Any waiver, modification or amendment of any 
provision of this Agreement shall be effective only if in writing and signed by duly authorized representatives of the parties 
hereto.

12.6 Attorney’s Fees. In the event that either party resorts to legal action to enforce its rights under this Agreement, the 
prevailing party in such action shall be entitled to have all costs and expenses incurred in such action, including courts 
costs and reasonable attorney’s fees, paid by the other party.

12.7 3rd Party Components and Licenses. The log4net.dll component is included with the Vitality binary distribution under 
licenses and warranties of Apache License 2.0 from http://www.apache.org/licenses/LICENSE-2.0.txt. Redistribution of this 
component is compatible with the Apache License 2.0.

12.8 Except as otherwise expressly provided, nothing in this Agreement is intended to confer benefits, rights or remedies 
unto any third party other than the parties hereto under the United Kingdom Contracts (Rights of Third Parties) Act (1999), 
where applicable, or any other law. Licensee and Licensor shall be entitled to modify, vary, amend and/or extinguish such 
rights without the consent of any third parties.

13. NOTICE TO U.S. GOVERNMENT END USERS: 

13.1 This Article 13 applies only if this Agreement is for the direct or indirect sale to any agency of the U.S. government 
and/or is funded in whole or in part by any agency of the U.S. government. 

13.2 Licensee agrees that the Programs and Documentation (collectively “Products”) provided by Licensor have been 
entirely developed at private expense and meet the definition of “commercial-off-the-shelf” (“COTS”), “commercial item” 
and/or “commercial computer software” as those terms are defined in Federal Acquisition Regulation (“FAR”) or any other 
applicable authority (e.g., the Defense FAR Supplement (“DFARS”)). As such, the Products provided under this Agreement 
and under the conditions of Section 11.1 are provided to the government with “Limited Rights,” as that term is defined at FAR 
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52.227-14 and/or pursuant to the terms of the DFARS, as applicable. Use, duplication or disclosure by the government is 
subject to the restrictions set forth at FAR 52.227-14, FAR 52.227-19 and/or DFARS 252.227-7015, as applicable.

13.3 To the extent the Buy American Act, Trade Agreements Act, or any other domestic preference requirements are 
applicable to this Agreement, the country of origin of Products/Parts is unknown unless otherwise specifically stated by 
Licensor in this Agreement. Licensee agrees that any Software offered by Licensor are exempt from the Service Agreement 
Act of 1965 (FAR 52.222-41). The version of any applicable FAR clause listed in this Article 11 shall be the one in effect on the 
effective date of this Agreement.

13.4 If Licensee is an agency of the U.S. government, then as permitted by FAR 12.302, Licensee agrees that all paragraphs of 
FAR 52.212-4 (except those listed in 12.302(b)) are replaced with the terms and conditions of this Agreement. Licensee 
further agrees the subparagraphs of FAR 52.212-5 apply only to the extent applicable for sale of COTS and/or commercial 
items and as appropriate for the agreement price.

13.5 If Licensee is procuring the Products as a contractor, or subcontractor at any tier, on behalf of any agency of the U.S. 
government, then Licensee agrees that FAR 52.212-5(e) or 52.244-6 (whichever is applicable) applies only to the extent 
applicable for sale of COTS and/or commercial items and as appropriate for the agreement price. If the reasonableness of 
the price cannot be established through adequate price competition, or if cost or pricing data should be required for any 
other reason, or if any of the Products cannot be considered a “commercial item”, Licensor may terminate this Agreement 
without penalty and be reimbursed for work done before the effective date of termination.

BY CLICKING THE ACCEPTANCE BUTTON and/OR ACCESSING, USING OR INSTALLING ANY PART OF THE 
PROGRAMS OR DOCUMENTATION, YOU:  1) represent that YOU ARE authorized and have authority to bind YOUR 
company to all terms OF THIS AGREEMENT; 2) acknowledge that YOU have read AND AGREE TO BIND YOURSELF 
AND YOUR COMPANY TO all Terms of THIS AGREEMENT; and 3) agree that the act of accepting will attribute 
YOUR signature to THE AGREEMENT with intent to create a binding record of agreement with the same legal 
effect, validity and enforceability of a handwritten signature and paper document. IF YOU DO NOT 
UNDERSTAND OR AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, THE BUTTON INDICATING NON-ACCEPTANCE 
MUST BE SELECTED, AND YOU MAY NOT ACCESS, USE OR INSTALL ANY PART OF THE PROGRAMS OR 
DOCUMENTATION.
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Chapter 1. Features & Capabilities

1.1 Introduction

PanaView is a graphical user interface (GUI) that permits interactive communication between a BH instrument and a 
personal computer (PC) that is running under a 32-bit or 64-bit Windows 7, Windows 8 or higher operating system. The 
interface has been carefully designed to present the same appearance and functionality as most familiar Windows 
software applications. As a result, anyone familiar with using common Windows programs should have no difficulty using 
PanaView.

1.2 Basic Features

The following primary tasks may be performed with PanaView software:

• Save the instrument’s programmed site file data to the hard drive on the PC

• Display text output of the live measurement data on the computer monitor

• Display the live measurement data on the computer monitor in graphical format

• Create and save graph and log files to the hard drive on the computer

• Create custom templates for displaying text, graph, or log data

• Interface with multiple BH instruments

1.3 Supported Meters

Version 1.6.3 of PanaView supports the following BH meters:

• Most legacy IDM protocol BH instruments

• Most PanaLink™ protocol BH instruments

• BH Sentinel™ flow meters

• BH Safire 2 flow meters

1.4 PanaCom ActiveX Software
Although the PanaView GUI is the component of the software package that is visible to the user, it is really just one part of a 
sophisticated program. Beneath the surface, PanaCom™ is seamlessly enabling the PC to communicate with the BH 
instrument. Figure 1 below illustrates the relationship between the various components of the system.

As indicated, PanaCom not only interfaces with the standard PanaView GUI, but it can be programmed to interact directly 
with customized versions of PanaView or with OLE compliant Windows applications. In fact, PanaCom is compatible with 
any process control/automation software that supports ActiveX technology. For more information on PanaCom, contact 
your BH sales engineer.
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Figure 1: The PanaView/PanaCom System

1.5 Advanced Capabilities

In addition to the features described in “Basic Features” on page 1, PanaView offers some very useful advanced 
functionality. Users can consult the comprehensive online help files to quickly answer questions.

1.6 Windows Shortcuts

The instructions in this manual use the simple, direct approach to accomplishing the desired tasks. That is, the use of the 
standard menus on the menu bar is emphasized. However, as in any other conventional Windows program, many tasks 
may be completed by alternate methods. For example, a right mouse click or a keyboard shortcut may provide a more 
convenient route to the desired result. Since these are standard Windows procedures, they are covered in detail in the 
documentation that came with your PC’s operating system, and specific shortcut instructions are not included in this 
manual.

1.7 Electronic Documentation

As an added convenience, an electronic version of this complete manual is supplied along with .exe / installer through 
shared media. A file named “Help.pdf” is included in the “Manual” directory on the shared media. This file is an Adobe 
Portable Document Format file, and it may be opened with Adobe Acrobat Reader.

Acrobat Reader is a free application that may be downloaded from many web sites, including the Adobe web site, 
https://get.adobe.com/reader/.
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Chapter 2. Installation

2.1 Introduction

PanaView is supplied through shared media that includes the basic program, along with sample applications and 
interactive demonstrations. The underlying PanaCom ActiveX software is automatically installed during the PanaView 
installation.

Before beginning the installation, make sure the personal computer system meets the requirements listed in the next 
section.

2.2 Personal Computer Requirements

For optimum performance of the PanaView software, the personal computer must meet the following minimum 
requirements:

• 32-bit or 64-bit CPU

• 64 MB random access memory (RAM)

• 100 MB available hard drive space

• 32-bit or 64-bit Windows 7, Windows 8 or higher operating system

• Internet Explorer 7.0 or higher installed

• Display monitor and graphics card

• To begin the installation, proceed to the next section.
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2.3 Software Installation

2.3.1 The InstallShield Wizard
After verifying that the personal computer meets the minimum requirements listed in the previous section, proceed as 
follows:

1. After downloading or copying the “PanaViewSEN898Suite.exe” file, double click on it. 

2. The Install-Shield wizard, shown in Figure 2 below will launch and guide you through the installation process. Click 
[Next] button to continue.

Figure 2: Install-Shield Wizard Screen
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2.3.2 The [Back] and [Cancel] Buttons
If the [Cancel] button is chosen at any of the installation screens, the dialog box shown in Figure 3 below appears.

Figure 3: Cancel Installation Screen

At the screen shown above, the following two options are available:

• Click the [No] button to return to the installation process

• Click the [Yes] button to terminate the installation process and return to Windows

On all but the first installation screen (where the [Back] button is grayed out), you may return to the previous installation 
screen to make corrections by clicking on the [Back] button.

2.3.3 File Installation
3. Next, the End User Licence Agreement shown in Figure 4 below opens. Click the radio button for “I accept the terms in 

the licence agreement” and Click [Next] button to continue.

Figure 4: Licence Agreement Screen

Note: For a complete copy of this agreement, see “END USER LICENSE AGREEMENT” on page iii of this manual.

4. Choose [Complete] to install all program features (see Figure 5 below). The screen shown in Figure 6 appears and 
confirms the start of Panaview Installation. Refer to “The [Back] and [Cancel] Buttons” on page 5 to know the specific 
function of them.
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Figure 5: Setup Type Screen

Figure 6: Installing Panaview Screen

5. Click [Extract] button from dialog box (see the Figure 7 below) to extract and install FTDI CDM drivers. The PanaView 
may be installed by clicking on [Cancel] button if FTDI CDM drivers are already available.

IMPORTANT: The communication ports will not work if FTDI CDM drivers are unavailable in the computer.
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Figure 7: FTDI CDM drivers Screen

6. After extracting FTDI CDM drivers, the dialog box shown in Figure 8 below opens. Click [next] to install software drivers 
that some computer devices need in order to work.

Figure 8: Device Driver Installation Screen

Note: The PanaView may be installed by clicking on [Cancel] button. 

7. After Successful installation of FTDI CDM drivers, the dialog box shown in Figure 9 below opens. Click [Finish] to continue 
with PanaView installation.
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Figure 9: Successful Device Driver Installation Screen

8. After all of the PanaView files have been copied to your hard drive, the screen shown in Figure 10 below opens. Click 
[Finish] button to close the InstallShield Wizard. 

Figure 10: InstallShield Wizard Completed Screen

PanaView may be launched either by selecting PanaView in the Windows Start Menu or by double-clicking a PanaView 
Shortcut (created by the user) on the Windows desktop. 

Proceed to the next section to set up your hardware.
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2.4 Hardware Installation

2.4.1 Installation Requirements
After the PanaView software has been installed in accordance with the instructions in the previous section of this chapter, 
the system hardware must be properly set up. To complete this task, the following items are required:

• A personal computer or laptop computer with PanaView installed and with either an available Serial Port or an 

available USB Port equipped with an RS232-to-USB converter.

• A BH instrument that has been configured for use with PanaView and which has an available serial port or Ethernet 

interface.

Note: Check with BH to make sure that your instrument is equipped with the necessary hardware and software versions 
for PanaView compatibility.

• For RS232 applications, a serial cable with the proper connectors for the available serial ports (typically, this will be 

a cable with female DB-9 connectors at both ends)

• For RS485 applications, communications must be sent through an RS485-to-RS232 converter.

Note: The RS232 standard specifies a maximum cable length of 50 feet. For longer cables, consult BH for details.

2.4.2 Installation Procedure
If all of the hardware requirements have been met, proceed as follows for RS232/RS485 applications:

1. Set up the BH instrument in accordance with the instructions provided in the User’s Manual supplied with the 
instrument.

2. Power down both the personal computer and the BH instrument.

3. Using the serial cable, connect the serial port on the personal computer to the serial port on the instrument.

4. Power up the BH instrument and then power up the personal computer.

Your system is now ready to use the PanaView interface. Proceed to Chapter 3.“Initial Setup”, for instructions on using the 
PanaView software.

CAUTION! Failure to power down both devices before proceeding to the next step may cause damage 
to the personal computer and/or to the instrument.
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3.1 Introduction

Before proceeding with this chapter, make sure that the PanaView software has been installed in accordance with the 
instructions provided in Chapter 2.“Installation”. Also, be certain that the personal computer has been restarted since the 
completion of the installation procedure. Then, follow the instructions in this chapter to perform the initial PanaView 
configuration.

3.2 Starting PanaView

The PanaView program may be launched from the Windows desktop in any of the following conventional ways:

• Use “My Computer” to navigate to the PanaView directory and double-click “PanaView.exe” file

• Use “Windows Explorer” to navigate to the PanaView directory and double-click “PanaView.exe” file

• Use the “Start Menu” to navigate to the PanaView listing and click on it

• Double-click on a PanaView “Shortcut” that was created on the desktop for this purpose.

Note: If necessary, consult your Windows documentation for detailed instructions on any of the above procedures.

Proceed to the next section for instructions on completing the first-time startup of PanaView.

3.3 First-Time Startup
Launch the PanaView program by one of the methods listed in “Starting PanaView” on page 11, and proceed as follows:

1. The Version number of your PanaView software, which may not be the same as the example in Figure 11 below, is shown 
in the initial screen.

Figure 11: Initializing Screen

Note: When PanaView is launched for the first time after installation, the following directories are created:

• C:\GEData\PanaViewSEN898\Logs

• C:\GEData\PanaViewSEN898\Chart

These directories are used to store any Log or Chart (Graph) files that are generated during your PanaView 
sessions.
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2. As shown in Figure 12 below, the default initial PanaView window contains only the following basic components of the 
interface (listed from top to bottom):

Note: To make the image in Figure 12 below more readable on this page, the window was compressed both vertically 
and horizontally from its actual dimensions.

Figure 12: The Basic PanaView Window

• Title Bar - shows the PanaView name on the left side, and the standard Windows control boxes on the right side

• Menu Bar - contains the File, Edit, View, Output, Window, and Help menus on the left side

• Display Window - by default, it is blank on initial startup

• Status Bar - by default on initial startup, it shows status messages (see Figure 14 on page 13) such as: date, time, 

number of active logs, and number of communication errors (from left to right)

For instructions on customizing the default startup window to make the interface more personal, proceed to the next 
section.

3.4 The View Menu

Prior to setting up communications with a meter, the “View” menu (see Figure 13 below) provides three options for 
customizing the PanaView interface:

• Comm Status (Off by default)

• Status Bar (On by default)

• Preferences

Note: The Refresh option in the View menu is not active at this time.
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Figure 13: The View Menu

Access the “View” menu by clicking on it in the menu bar, and proceed to the appropriate section for a discussion of the 
options listed above.

3.4.1 Comm Status
This option permits the user to toggle communications status bar to ON and OFF. The default state is “Off” as indicated by 
the absence of a check mark in Figure 13 on page 13. When toggled “On”, the Comm Status bar appears just above the main 
Status bar (see Figure 14 below) and displays the following serial communications categories, from left to right:

Figure 14: The Comm Status Bar

Note: To make the image in Figure 14 more readable on this page, the window was compressed horizontally from its 
actual dimensions.

• “Comm Stats: port number” on page 14

• “Queued” on page 14

• Sent

• Rcvd

• Errs

Of course, all of the above categories will be empty, unless PanaView has actively engaged in serial communications.

Note: The Comm Status bar reverts to its default “Off” state whenever PanaView is closed.
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3.4.1.1 Comm Stats: port number

If a user wish to see command queue for different COM port numbers or TCP/IPs, use [Comm Stats] dropdown button on 
communications status bar and select appropriate COM port number or TCP/IP.

3.4.1.2 Queued
The maximum allowed queue is 1000. If user keeps continue to collect and log data, the PanaView alerts with a Warning 
Message at 80% of queues limit.
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3.4.2 Status Bar
The main Status bar shown in Figure 14 on page 13 is always visible when PanaView is first started. However, it may be 
toggled on and off at any time during a PanaView session by selecting or deselecting it in the “View” menu. Its current state 
is indicated by the absence or presence of a check mark to its left in the View menu.

The decision to turn the Status Bar “On” or “Off” is based on a balance between information and display area. Turning the 
Status Bar “Off” creates a larger display area, but the information displayed is no longer visible.

3.4.3 Preferences
To access the “Preferences” option (see Figure 13 on page 13), click on it in the “View” menu. Then, click on any of the tabs 
and proceed to the appropriate section for instructions.

Note: Within any of the tabs, click [Apply] button and then the [OK] button to accept any changes and then close the 
“Preferences” box. To abort the process, click the [Cancel] button instead.

3.4.3.1 The Database Tab
In the “Preferences” box, click the “Database” tab as shown in Figure 15 below to display the currently used database files 
(*.mdb). If alternative files are available from previous PanaView installations on the same computer or from a PanaView 
installation on a different computer, the PanaView database file or the Meter Configuration database file may be changed 
by clicking on the button to the right of the appropriate text box.

Figure 15: The Database Tab
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3.4.3.2 The Grids Tab
In the “Preferences” box, click the “Grids” tab as shown in Figure 16 below to display the current grid settings. The settings for 
either of the following grids may be revised:

• For the Log Data Grid, the [Font], [Text Color], and [Background Color] may be changed by clicking on the 

appropriate button(s). If a Default Layout File (*.grx) has been created (see Chapter 6.“Data Handling”), it may be 
loaded by clicking on the button to the right of that text box.

• For the Meter Browser Grid, the [Font], [Text Color], and [Background Color] may be changed by clicking on the 

appropriate button(s).

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 16: The Grids Tab
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3.4.3.3 The Text Display Tab
In the “Preferences” box, click the “Text Display” tab (see Figure 17 below) to display the current settings. The settings for 
either of the following displays may be revised:

• For Graphing, the Default Configuration File is initially blank. If a Default Configuration File (*.oc2) has been created, 

it may be loaded by clicking on the button to the right of that text box.

• For Text, the [Background Color] and [Text Color] may be changed by clicking on the appropriate button(s).

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 17: The Text Display Tab
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3.4.3.4 The Logging Tab
In the “Preferences” box, click the “Logging” tab as shown in Figure 18 below to display the Log File Directory. To specify a 
different directory for storing log files, click button to the right of the text box, select directory and click [Apply] button to 
save the changes. 

Figure 18: The Logging Tab
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3.4.3.5 The Status Bar Tab
In the “Preferences” box, click the “Status Bar” tab as shown in Figure 19 below to display the current settings. The settings for 
any of the following items may be revised:

• The Font may be changed by clicking on the [Select Font] button and specifying the new font, style and size.

• Check the selection box to display Status Messages or uncheck the selection box to turn off Status Messages.

• Check the selection box to display the Date or uncheck the selection box to turn off the Date. If the date is turned on, 

select the desired date format from the drop down list box.

• Check the selection box to display the Time or uncheck the selection box to turn off the Time. If the date is turned on, 

select the desired time format from the drop down list box.

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 19: The Status Bar Tab
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3.4.3.6 The Units Tab
Note: This tab applies to PT878, PM880 and PT878GC meters only.

• In the “Preferences” box, click the “Units” tab (see Figure 20 below) to display or edit the available units.

• Click the radio button to select either metric or English units.

• For the PT878GC, you can also select from four pressure units: kPa, bar, psia and MMHG. Click desired units from the 

drop-down list.

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 20: The Units Tab
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3.4.3.7 The Graphing Tab
In the “Preferences” box, click the “Graphing” tab as shown in Figure 21 below to display the current settings. The settings for 
any of the following items may be revised:

• Graph Items Limit: Click in the text box and specify the limit.

• Timeline Maximum Display (minutes): Click in the text box and specify the limit.

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 21: The Graphing Tab
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3.4.3.8 The Signal Dump Tab
In the “Preferences” box, click the “Signal Dump” tab as shown in Figure 22 below to display the current settings. The settings 
for any of the following items may be revised:

• Click the radio button to select or cancel the selection of "Include full header”.

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 22: The Signal Dump Tab
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3.4.3.9 The Errors Tab
In the “Preferences” box, click the “Errors” tab as shown in Figure 23 below to display the current settings. The settings for any 
of the following items may be revised:

• Click the radio button to select or cancel the selection of "Enable strong type checking for meter return data”.

• The default Number of errors displayed is set to 100. Click in the text box and make changes if required.

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 23: The Errors Tab
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3.4.3.10 The Diagnostic Dump Tab
Note: This tab applies to Safire, Sentinel and LCT8 meters only.

In the “Preferences” box, click the “Diagnostic Dump” tab as shown in Figure 24 below to display the current settings. The 
settings for any of the following items may be revised:

• The default Number of records per file is set to 10000. Click in the text box and make changes if required.

Click [OK] or [Apply] button to save the changes or click [Cancel] button to ignore.

Figure 24: The Diagnostic Dump Tab
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3.5 The Help Menu

The “Help” menu, as shown in Figure 25 below, is the primary source of information regarding the PanaView software and 
your PanaView installation. This menu includes the following three options:

• Contents

• Search for Help On...

• About PanaView

• Version Information

Figure 25: The Help Menu

Access the “Help” menu by clicking on it in the menu bar, and proceed to the appropriate section for a discussion of the 
options listed above.

3.5.1 Contents
The “Contents” option lists the available PanaView general information categories in the online help file in a table of 
contents format. To access this information, simply click “Contents” option and then click desired topic in the listing that 
appears.

3.5.2 Search For Help On...
The “Search For Help On...” option lists the available PanaView general information categories in the online help file in an 
index format. To access this information, simply click “Search For Help On...” option and then click desired topic in the listing 
that appears.

3.5.3 About PanaView and Version Information
The “About PanaView” option provides information on your version of the software and about your computer system. To 
access this information, simply click “About PanaView” option and a screen similar to the one on the left in Figure 26 below 
opens. To access data on the PanaView components for this version, click on “Version Info” and a screen similar to the one 
on the right in Figure 26 below opens.

• The screen shown on the left in Figure 26 below shows the version number of the currently installed copy of 

PanaView, which may differ from the example shown here.

• The screen on the right in Figure 26 below, which includes the version information, lists data on the various 

components of the PanaView software.

• To exit the “Help” menu and return to the main PanaView window, simply click [OK] button. Otherwise, to examine 

the information relating to your personal computer system, click [System Info...] button.
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Figure 26: The About PanaView and Version Information Screens

3.6 Exiting PanaView

PanaView may be closed by any of the methods that are used for any other standard Windows program. The two most 
common methods are:

• Click “File” to open the file menu and then click on “Exit” to close the program

• Click [X] control box on the right side of the title bar

Proceed to Chapter 4.“Setting Up a Meter”, to continue the setup of your PanaView software.
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Chapter 4. Setting Up a Meter

4.1 Introduction

After your hardware and software have been installed as described in Chapter 2.“Installation” and Chapter 3.“Initial Setup” 
of this manual and in the instrument’s User’s Manual, the procedure for establishing communications with a meter may be 
started. To set up a meter in PanaView, the following steps must be completed in the order described in this chapter:

• “Opening the New Meter Browser” on page 27

• “The PanaView Network Tree” on page 27

• “Adding a New Communication Port” on page 29

• “Setting up Ethernet Communications” on page 32

• “Adding a New Meter” on page 33

• “Adding an Additional Meter” on page 40

Proceed to the next section to learn how PanaView connects to a BH instrument.

4.2 Opening the New Meter Browser

The first step in setting up a meter is to open the “New Meter Browser,” which is located in the “File” menu. To accomplish 
this, click “File” menu on the menu bar, and then click “New Meter Browser” option (see Figure 27 below).

Figure 27: File Menu

Proceed to the next section to select the computer name in the PanaView network tree.

4.3 The PanaView Network Tree
The “New Meter Browser” window consists of two panes:

• PanaView network tree pane on the left

• The details pane on the right

Figure 28 below shows the initial appearance of the browser window. With the network branch highlighted in the left pane, 
the computer name that was specified during the installation procedure is listed in the right pane. Any other computers 
that were installed on the network are also listed here.
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Figure 28: Network Branch

Note: The network tree works just like the directory tree that is used in Windows Explorer. That is, if a branch has a “+” sign 
to its left, that branch contains other branches. Just click “+” sign to expand the branch and display those other 
branches. The “+” sign is then replaced by a “-” sign its left. To collapse a branch with a “-” sign.

With the “New Meter Browser” window open, complete the following steps:

1. Expand the network branch by clicking on the “+” sign to its left. Then, highlight the My Computer (Name) branch and 
the Meter Browser window will look like Figure 29 below.

Figure 29: My Computer Branch

Note: The right pane in Figure 29 above lists all of the communication ports, along with their configuration parameters, 
that are currently assigned to the named computer. If this is the initial meter setup, the list is empty.

2. Fully expand the network tree by clicking on the “+” sign next to the My Computer (Name) branch (see Figure 30 below).

Figure 30: PC Logs Branch

Note: Step 3 is just included for reference, as PanaView’s logging feature is discussed in Chapter 6.“Data Handling”.
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3. Click PC Logs branch and all available PC logs (and their parameters) that have been created on the named computer 
are listed in the details pane on the right. If no logs have yet been created, the details pane is empty.

IMPORTANT: During initialization, PanaView creates special subdirectories to store its log and chart (graph) files (see 
“First-Time Startup” on page 11). If these subdirectories are removed, attempts to access the PC logs will 
generate an error message.

4. Highlight the My Computer (Name) branch by clicking on it.

Proceed to the next section to add a communication port to the selected computer.

4.4 Adding a New Communication Port

Before a meter can be set up on the network, the serial communications port to be used by that meter must be added to 
the PanaView network and configured. To accomplish this, proceed as follows:

1. Open the “New Meter Browser” window and expand the network tree as shown in Figure 29 on page 28. Then, click and 
highlight the My Computer (Name) branch.

2. Pull down the “Edit” menu by clicking on it in the menu bar.

3. Click “New” menu option to select it, and a submenu opens with two choices on it (see Figure 31 below).

Figure 31: Edit Menu

Note: The only available option on the “Edit” menu is “New.” The other options become active during relevant 
procedures.

4. Click “Communications Port” option to select it (see Figure 32 on page 30). The dialog box shown in Figure 32 below 
opens, with “Untitled/Empty” as the default “Name.”
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Figure 32:  Setup Communications Screen

The dialog box in Figure 32 above permits the user to name the communication port (the name “Comport” is used for this 
example) and to set up all of its parameters.

IMPORTANT: During meter initialization, the baud rate specified above must be the same as the meter’s baud rate setting.

The following serial port parameters are available in the Setup Communications dialog box:

Note: The “Name” and “Timeout (ms)” parameters must be entered manually. All others are selected by clicking on the 
down arrow to the right of the list box to drop down a list of available options.

• Name - Select the type of protocol

Default: Panalink
Options: Panalink, IDM

• Port Number - select the number of the serial port on the PC

Default: Depends on the PC’s specific hardware configuration
Options: Depends on the PC’s specific hardware configuration

• Name - Enter a name for the port (optional)

Default: Untitled
Options: Enter any name that fits in the text box

CAUTION! Contact your BH representative before entering communication port settings different from 
those of your meter. Changing these settings may render your meter inoperable and require 
reloading of the meter software.
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• COM Port Type - Select the type of serial port available

Default: RS232

Options: RS485HD, RS485FD, IR232®, TCP/IP (Ethernet)

IMPORTANT: If you select TCP/IP, the menu changes. Proceed to “Setting up Ethernet Communications” on page 32.

Note:  If you select IR232, you must disable the drivers in the infrared device connected to your PC for the device to work 
with PanaView. From the Control Panel, click System icon, and then on the Hardware tab. Click on Device Manager, 
and then on the specific infrared device listed under Infrared Devices. Finally, click on Disable to disable the device 
drivers.

• Baud Rate - Select the data transfer speed to be used

Default: 115,200 Baud
Options: 4800, 9600, 19200, 38400, 57600, 115200

Note: A baud rate of 115,200 is suitable for almost all applications. If you experience periodic communication reliability 
problems, you may wish to consider lowering the baud rate on your instrument and in PanaView.

• Parity - Select the parity setting to be used

Default: None
Options: Even, Mark, None, Odd, Space

• Handshaking - Select the type of handshaking protocols used

Default: No Handshaking
Options: No Handshaking, XON/XOFF, RTS/CTS, RTS and
               XON/XOFF

• Data Bits - Select the number of data bits in a word

Default: 8 Data Bits
Options: 7 Data Bits, 8 Data Bits

• Stop Bits - Select the number of stop bits in a word

Default: 1 Bit
Options: 1 Bit, 2 Bits

• Timeout (ms) - Enter the time interval that must pass before a

communications attempt is aborted
Default: 3000 (5000 if you choose IDM as Protocol)
Options: Keep the default value unless instructed otherwise

IMPORTANT: Remember that the choices made above must match those that were made in setting up the meter’s serial 
port.

5. After all of the communications port parameters have been set, click [OK] button (see Figure 32 on page 30).

Note: To abort the addition of the communications port, click [Cancel] button instead of the [Apply] button.

6. Wait a few seconds for the information to be processed and registered (the buttons are greyed out during this period). 
The new successfully created communications port will be added to the network tree as shown in Figure 33 below.
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Figure 33: Added New Communication Port to Network Tree

Proceed to “Adding a New Meter” on page 33 to set up a new meter on the newly installed communication port.

4.5 Setting up Ethernet Communications

If user selected TCP/IP in Step 4 on page 29, a Setup Communications window similar to Figure 34 below opens.

1. Type in the desired Name and Timeout (in milliseconds).

2. In the IP Address text box, enter the IP address supplied with your documentation. In the Port Number box, enter the port 
number supplied with your documentation (The default number is 2101).

3. Click [OK] to complete data entry. If the connection is successful, a “TCPIP socket connected” screen will open.

Figure 34: Setup Communications for TCP/IP
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4.6 Adding a New Meter
A meter may be set up on any communications port that has been added to the network in accordance with the 
procedures in the “Adding a New Communication Port” on page 29. For earlier software versions, to manually add the first 
new meter to the PanaView network, proceed as follows:

1. Notice in Figure 35 below that the network tree now has the newly configured communication port listed.

Figure 35: The New Serial Port Branch

Note: In this example, the communication port has been named “Untitled” and is located on COM3 COM3 (see step 6, 
“Adding a New Communication Port” on page 29 for an example of titled communication port). Whatever name 
was entered in the setup process appears in the details pane if the communications port is highlighted.

2. Click and highlight the communication port to which the meter will be added and then open the “Edit” menu on the 
menu bar (see Figure 36 below).

OR

3. Using the right mouse button (right-click), click and highlight the communication port to which the meter will be added 
(see Figure 37 below)

4. Click “New” option in the “Edit” menu.

5. Click “Meter” menu option.

Figure 36: Add New Meter (using the Edit Menu)
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Figure 37: Add New Meter (using the Right-click option)

6. After selecting the “New” and “Meter” options, the dialog box shown in Figure 38 below opens (If Panalink selected as 
protocol while  “Adding a New Communication Port” on page 29, go to step 7 in page 34). Enter Network ID or Node ID 
and click [OK] to initialize New Meter.

Figure 38: Add IDM New Meter

After the initialization has been completed, PanaView adds the new meter to the PanaView network tree. Go to “Adding a 
New Meter” on page 33 for further instructions. 

7. After selecting the “New” and “Meter” options, the dialog box shown in Figure 39 below opens. Select the “I don’t know 
the node ID of the meter I am adding to the network” radio button and then click [OK] button.

Note: When installing the first meter on the network, even if you know the node ID assigned to the meter, it is more 
foolproof to allow PanaView to retrieve the information directly from the meter. If the “I know the node ID of the 
meter I am adding to the network.” option is selected instead, go to Step 12 on page 37.
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Figure 39: The Node ID Dialog Box

8. Select the “It is the only meter connected to the communication port” radio button from the dialog box (see Figure 40 
below) and then click [OK] button. In most instances, users connect their PC to one instrument only via a direct serial 
cable. 

Figure 40: The Only Meter Dialog Box
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9. Select the “I wish to use this Node ID” radio button on a dialog box showing the Node ID (16 in this example) of the meter 
(see Figure 41 below) and then click [OK] button.

Note: PanaView gets this Node ID directly from the meter. Do not use a different Node ID for a single-meter setup.

Figure 41: Node ID Confirmation

IMPORTANT: Ensure that the meter is not Powered-off or already Connected by other user, otherwise the PanaView will 
throw an error (see Figure 42 below).

Figure 42: Get Node ID Error

10. At the dialog box shown in Figure 43 below, click [OK] button to add the meter and configure it.

Figure 43: Confirmation Dialog Box

11. Enter a name in dialog box (see Figure 44 below) for the new meter. Click [OK] button to initialize the new meter and 
proceed from page 38.

The Node ID and Meter Communication Parameters have been entered automatically by PanaView. In addition, 
PanaView populates certain other fields, such as Model Name, Firmware Version and PCI Order Number with data 
retrieved from the BH instrument.
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Figure 44: Add Meter Dialog Box

12. Enter a Name and Node ID in dialog box (see Figure 45 below) for the new meter and Click [OK] button to initialize the 
new meter.

Note: If you don't remember or unsure about the Node ID, Click [Get Node ID] button in the dialog box and proceed from 
step 7 in page 34.

The Meter Communication Parameters have been entered automatically by PanaView. In addition, PanaView populates 
certain other fields, such as Model Name, Firmware Version and PCI Order Number and retrieves data from the BH 
instrument once the add new meter initialized. 
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Figure 45: Add Meter Dialog Box

After completing Step 11 on page 36 or Step 12 on page 37, do not make any inputs with either the mouse or the keyboard 
until the new meter initialization process is completed. While the meter is initializing, the information shown in Figure 46 
below is added to the new meter dialog box.
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Figure 46: Initialization Screen

Note: The “Clock” text box has been filled in with the current date and time, the meter data (an IGM in this example) has 
been added, and the active communications status is displayed along the bottom of the dialog box.

After the initialization has been completed, PanaView adds the new meter to the PanaView network tree and automatically 
closes the “Add New Meter” dialog box (see Figure 47 below).

Figure 47: Updated Network Tree

Note: A BH GS868 flowmeter was used for this example, as is indicated in Figure 47 above. The information shown in the 
right pane and in the branches available under the “New Meter” branch in the left pane of the window reflect the 
specific meter that was actually installed.
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This completes the set up of the new meter in PanaView. Proceed to Chapter 5.“Running PanaView” for information on using 
the PanaView interface to communicate with the attached meter. Otherwise, continue with the next section to install an 
additional meter.

4.7 Adding an Additional Meter
An additional meter may be added to the PanaView network at any time in either of the following situations:

• Replace the existing meter with a different one (see “Replace the Existing Meter” on page 40)

• Keep the existing meter and add an additional meter (see “Keep the Existing Meter” on page 40)

Proceed to the appropriate section for specific instructions.

4.7.1 Replace the Existing Meter
To replace a meter that is already installed on the PanaView network with a different meter on the same or different 
communication port, complete the following steps:

1. Remove the existing meter from the network, as described in “Removing the Meter” on page 48.

Note: Ignore the steps “1 and 2” if you want to replace existing meter on the same communication port.

2. Remove the existing communication port from the network, as described in the in “Removing the Communication Port” 
on page 44. 

3. Add the communication port back onto the network by following the instructions in “Adding a New Communication 
Port” on page 29.

4. Add the replacement meter by following the instructions in “Adding a New Meter” on page 33.

Note: Failure to remove the old meter and/or communication port first may result in some of the old meter’s properties 
(such as the name) being assigned to the new meter.

4.7.2 Keep the Existing Meter
To keep the existing meter and add an additional meter to a different communication port, complete the following steps:

1. Add the new communications port to the PanaView network by following the instructions that begin in “Adding a New 
Communication Port” on page 29.

2. Determine the Node ID of the second meter. Consult the User’s Manual for the meter for instructions on finding the 
assigned Node ID in the meter’s menu system.

3. Change the Node ID of the existing meter to any value between 16 and 99 that is different from that of the new meter. 
Refer to “Editing the Meter Settings” on page 46 for specific instructions.

IMPORTANT: The new communication port must be different from the one to which the existing meter is already attached.

4. Add the new meter to the new communication port by following the instructions that begin in “Adding a New Meter” on 
page 33, with one exception:

a. At the Node ID dialog box (see Figure 39 on page 35), select the “I know the node ID of the meter I am adding 
to the network” option and Click [OK] button.

b. When you reach the dialog box shown in Figure 45 on page 38, enter the known Node ID for the second 
meter.

c. Click [Set Node ID] button to register the entered value, and then Click [OK] button to complete the process.

The PanaView network tree will now show two attached communication ports, with one meter attached to each port.
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Chapter 5. Running PanaView

5.1 Introduction

After at least one meter has been added to the PanaView network in accordance with the instructions in Chapter 4.“Setting 
Up a Meter”, the many interactive features in the PanaView interface may be accessed. To navigate through the PanaView 
program, refer to the menu map in Figure 86 on page 70. If it is not already running, launch PanaView. A screen like the one 
shown in Figure 48 below opens (the exact PanaView version number and meter details will reflect your specific 
installation):

Figure 48: The Bootup Screen

With some meters, the bootup screen displays the meter model, serial port, and node ID during the initialization process. In 
these cases, a progress bar across the bottom of the screen indicates the percentage of the initialization that has been 
completed.

5.2 Initialization Error

Ensure the meter is turned on before launching PanaView otherwise an attempt to initialize the meter will fail as shown in 
Figure 49 below. Check all the Communication ports, Power Cable Connections, Switch-on the meter and then right-click 
[Meter - nodeXX not Initialized], select appropriate option to re-initialize the meter. 
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Figure 49: Initialization Error

Click on [Error] (as highlighted in Figure 49) to see the errors list as shown in the below figure.
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5.3 Communication Port Settings

During the initial addition of a communication port to the PanaView network, various port parameters were specified. If it 
ever becomes necessary or desirable to change any of these settings, this is easily accomplished as follows:

Note: Tasks that were described in detail in previous chapters, such as how to open a particular menu, are simply stated 
without details in this chapter.

1. Open the “New Meter Browser” from the “File” menu.

2. Fully expand the network tree and highlight the chosen communication port (see Figure 50 below).

Figure 50: The Serial Port Branch

3. With the desired communication port highlighted, open the edit menu as shown in Figure 51 below.

Figure 51: The Edit Menu

There are now three available options on the “Edit” menu:

• New - Functionality discussed in Chapter 4.“Setting Up a Meter”

• Properties - Use to edit the existing port settings

• Remove - Use to delete the port from the PanaView network
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IMPORTANT: The PC’s port parameters must be identical to those programmed into the meter’s serial port, as described in 
the meter’s User’s Manual.

Proceed to the appropriate section for a discussion of the Properties (see “Editing the Communication Port Settings” on 
page 44) and Remove (see “Removing the Communication Port” on page 44) options.

5.3.1 Editing the Communication Port Settings
To edit the existing settings for a communication port, complete the following steps:

1. From the “Edit” menu shown in Figure 51 on page 43, Click “Properties” option to open the dialog box shown in Figure 52 
below.

2. See “Adding a New Communication Port” on page 29, for instructions on choosing the communication port 
parameters.

3. When all of the desired changes have been made to the parameter settings, Click [OK] button.

Figure 52: Communication Port Settings

5.3.2 Removing the Communication Port
To remove a communication port from the PanaView network, complete the following steps:

1. From the “Edit” menu shown in Figure 51 on page 43, Click “Remove” option to open the dialog box shown in Figure 53 
below.
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Figure 53: Port Removal Confirmation

2. Click [Yes] button to remove the selected port (and all of its linked meters) from the PanaView network, or click [No] 
button to abort the operation.

After responding to the above prompt, you are returned to the “New Meter Browser” window.

5.4 Meter Configuration Settings
During the initial addition of a meter to the PanaView network, various settings were specified. If it ever becomes necessary 
or desirable to change any of these settings, this is easily accomplished as follows:

Note: Tasks that were described in detail in previous chapters, such as how to open a particular menu, are simply stated 
without details in this chapter.

1. Open the “New Meter Browser” from the “File” menu.

2. Fully expand the network tree and highlight the chosen meter (see Figure 54 below).

Figure 54: The Meter Branch

3. With the desired meter highlighted, open the “Edit” menu as shown in Figure 55 below.
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Figure 55: The Edit Menu

There are three available options on the “Edit” menu:

• New - Functionality discussed in Chapter 4, Setting Up a Meter

• Properties - Use to edit the current settings

• Remove - Use to delete the meter from the PanaView network

Proceed to the appropriate section for a discussion of the Properties (see “Editing the Meter Settings” on page 46) and 
Remove (see “Removing the Meter” on page 48) options.

5.4.1 Editing the Meter Settings
To edit the existing settings for a meter, complete the following steps:

1. From the “Edit” menu shown in Figure 55 on page 46, click “Properties” option to open the dialog box shown in Figure 56 
below.

2. The meter name may be edited directly in the text box shown.

3. Some meters have an Auto Cal Interval (the time between automatic calibration sequences), which may be edited 
directly in the text box.
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Figure 56: Meter Settings

4. The meter’s Time may be reset in three different ways:

• Manually enter the time and date in the text box

• Click [Sync to PC] button to have PanaView set the time and date to the current PC setting

• Click [Set] button to open the dialog box shown in Figure 57 below. Set the desired date and time as indicated, and 

click [OK] button.
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Figure 57: The Date/Time Dialog Box

IMPORTANT: Never change a meter’s Node ID to the same value as another meter on the same PanaView network. Also, 
Node ID values below 16 are not accepted by PanaView.

5. The Node ID may be reset in three different ways:

• Manually edit the Master ID, Node ID and (Meter) ID values in the text boxes

• Click [Set Node ID] button to have PanaView re-initialize the meter

• Click [Get Node ID] button to begin the node ID setup sequence described in “Adding a New Meter” on page 33.

6. Four of the Meter Communication Parameters may be edited by selecting one of the alternate choices in the list boxes 
shown in Figure 56 on page 47. See “Adding a New Meter” on page 33, for a discussion of these parameters and the 
available options.

IMPORTANT: The PC’s port parameters must be identical to those programmed into the meter’s serial port.

5.4.2 Removing the Meter
To remove a meter from the PanaView network, complete the following steps:

1. From the “Edit” menu shown in Figure 56 on page 47, click “Remove” option to open the dialog box shown in Figure 58 
below.
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Figure 58: Meter Removal Confirmation

2. Click the [Yes] button to remove the selected meter from the PanaView network, or click [No] button to abort the 
operation.

After responding to the above prompt, you are returned to the “New Meter Browser” window.

5.5 Multiple PanaView Windows
For convenience in monitoring outputs from multiple meters or multiple outputs from a single meter, PanaView has been 
designed to permit the simultaneous display of more than one output window. To accomplish this, proceed as follows:

Note: As an example we will open and arrange both a “Meter Browser” window and a “Text Display” window.

1. Launch PanaView and open the “File” menu.

2. Click “New Meter Browser” option (see Figure 27 on page 27) to open a screen similar to Figure 47 on page 39.

3. Open the “Output” menu and click “Text Display” option (this menu is discussed in detail in Chapter 6.“Data Handling”) 
to open a window similar to Figure 62 on page 52. By default, this window is stacked on top of the previously visible 
“Meter Browser” window.

4. To rearrange the two open windows, open the “Window” menu (see Figure 59 below).

Figure 59: The Window Menu

The PanaView “Window” menu is identical to that in any other Windows application. That is, the entries below the divider line 
represent all of the currently open windows, with the active window having a check mark next to its name. In the example 
shown in Figure 60 on page 50, notice that the “Meter Browser” and “Text Display” windows are open, with the “Text Display” 
window marked as the active window.
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[no content intended for this page]

There are four methods, which are consistent with standard Windows conventions, available for manipulating the two open 
windows (the Tile Output Displays option is discussed in Chapter 6.“Data Handling”):

Note: For a detailed discussion on using the “Window” menu, refer to any Microsoft Windows® manual.

• Make a window active and maximized in size by clicking on its Name

• Show both windows in an overlay format by clicking on Cascade

• Show both windows, with each taking up one half of the screen height, by clicking on Tile Horizontal

• Show both windows, with each taking up one half of the screen width, by clicking on Tile Vertical

As an example, the currently open “Meter Browser” and “Text Display” windows used for this discussion are shown in the “Tile 
Horizontal” format in Figure 60 on page 50, with the “Text Display” window as the active window.

Note: In any of the display modes, only one window can be active at any given time. To make another window active, 
simply click anywhere in its title bar.

Figure 60: Horizontally Tiled Windows
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Chapter 6. Data Handling

6.1 Introduction

After PanaView has been installed and configured in accordance with the instructions provided in the previous chapters of 
this manual, you are ready to begin using PanaView to view, manipulate and save data. To illustrate the complete process, 
we will assume that neither the BH instrument nor the PanaView software is currently running.

6.2 Preparing to Work with Data

To begin working with data, complete the following steps:

1. Power up the meter and wait until it has initialized and is displaying its normal default screen.

2. Launch PanaView and wait until it initializes the meter (see Figure 48 on page 41) and displays the basic PanaView 
window (see Figure 12 on page 12).

3. As described in Chapter 5.“Running PanaView”, open the “Meter Browser” window and highlight the meter to be used.

At this time, any of PanaView’s comprehensive data handling capabilities may be used. These include:

• Collecting and displaying live data in text format

• Collecting and displaying live data in graphical format

• Collecting and logging live data

• Displaying a log file in text format

• Displaying a log file in graphical format

To access PanaView’s data handling options, pull down the “Output” menu, as shown in Figure 61 below.

Figure 61: The Output Menu

IMPORTANT: This manual provides only an overview of the general data handling procedures. Since each instrument has 
its own unique user interface, see the instrument’s User’s Manual for information specific to your particular 
instrument.

Proceed directly to the appropriate section for instructions on each of the following output options:

• “The Text Display Output” on page 52

• “The Graphical Display Output” on page 54
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• “The Logging Output” on page 61

6.3 The Text Display Output
To collect data from the instrument and display it on a text screen, complete the following steps:

1. Complete Steps 1-3 in “Preparing to Work with Data” on page 51.

2. Pull down the “Output” menu and click “Text Display” option (see Figure 61 on page 51).

Note: The “Text Display” window that appears after Step 2 is actually stacked on top of any previously opened windows 
(such as the “Meter Browser” window).

3. Using the “Window” menu, as described in “Multiple PanaView Windows” on page 49, arrange the open windows in the 
desired format. For this discussion, Figure 62 below shows the “Text Display” window in its maximized (full-screen) size.

Figure 62: The Text Display Window

Note: Figure 62 above has been compressed both vertically and horizontally for improved clarity.

4. The left pane of the “Text Display” window contains the standard PanaView network tree. Expand this tree as far as 
necessary, and double-click desired process parameter to display it in the right pane of the window.

Note: Refer to your instrument’s User’s Manual for details on selecting a display parameter and the appearance of the 
“Text Display” window for your specific meter.

5. Before actual data values can be displayed in the text pane, activate one of the following data collection modes (see 
Figure 62 on page 52):

• Click [Get Once] button at the bottom of the right pane in the “Text Display” window. The current value of the 

selected process parameter, as specified in the PanaView network tree, is displayed in the right pane of the “Text 
Display” window.

• Enter an “interval” in the text box at the bottom of the right pane in the “Text Display” window. Then, click 

[Continuous] button to begin collecting data for display in the right pane of the “Text Display” window.

Note: Any value entered in the “Interval” text box is overridden if the
“Max. Comm Rate” box is checked.

6. If the [Continuous] option was selected in Step 5 above, click [Stop] button, which has replaced the original 
[Continuous] button, when you wish to terminate data collection.

The “Text Display” window may be left open while other tasks are performed, or it may be closed by clicking on the lower [X] 
control button at the far right of the menu bar.

IMPORTANT: If you click upper [X] control button at the far right of the PanaView title bar, you will exit PanaView 
completely.
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6.3.1 Displaying Multiple Process Parameters
The procedure for displaying a single process parameter in a text screen may be repeated to simultaneously display 
multiple process parameters. To do so, proceed as follows:

1. Display the first process parameter in a text screen, as described in the previous section.

2. Repeat Step 1 for any desired additional process parameters, by double clicking on them in the PanaView network tree. 
PanaView automatically tiles the multiple text screens in the right pane of the “Text Display” window.

3. As in any standard Windows application, the multiple text screens may be resized by dragging their borders. Also, the 
individual panes within a parameter’s text screen may be resized by dragging the borders within that text screen.

4. To close an open text screen, right click anywhere within that screen (except in the title bar or the error section) and 
click [Remove] option that pops up in the context menu.

Note: After resizing or removing any of the multiple text screens, the default tiled layout may be restored by opening the 
“Window” menu (see Figure 59 on page 49) and clicking on the “Tile Output Displays” option.

6.3.2 Displaying Multiple Text Windows
The procedures for displaying one or more process parameters in a single “Text Display” window may be repeated to open 
multiple “Text Display” windows. To do so, proceed as follows:

1. To open another “Text Display” window, repeat the steps in “The Text Display Output” on page 52 and “The left pane of 
the “Text Display” window contains the standard PanaView network tree. Expand this tree as far as necessary, and 
double-click desired process parameter to display it in the right pane of the window.” on page 52.

2. To display the desired process parameter(s) in the new window, repeat Steps 1-4 above.

3. Arrange the multiple “Text Display” windows as desired via the “Window” menu (see Figure 59 on page 49).
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6.4 The Graphical Display Output

To collect data from the instrument and display it graphically in a new format, complete the steps in the following sections.

6.4.1 Setting Up a Graph
1. Perform Steps 1-3 in “Preparing to Work with Data” on page 51.

2. Pull down the “Output” menu and click “Graphing - New” option (see Figure 61 on page 51).

Note: The “Graph” window is stacked on top of any previously opened windows (such as the “Meter Browser” window).

3. Using the “Window” menu, as shown in Figure 59 on page 49, arrange the open windows in the desired format. 
Figure 63 below shows the “Graph” window in its maximized (full-screen) size.

Figure 63: The Graph Window

The “Graph” window shown in Figure 63 on page 54 has three panes:

• Left pane - PanaView network tree

• Top right pane - Graph with default chart style

• Bottom right pane - Graph controls or text display

Note: The three panes of the “Graph” window may be resized by simply dragging their borders.
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6.4.2 Graphing Data
The PanaView network tree has already been described, and the display pane shows only a graph in the default style with 
no data points. Thus, we need only discuss the use of the bottom right pane. To begin graphing your data, proceed as 
follows:

1. Expand the network tree as far as necessary and double click process parameter to be graphed. The grid for the 
selected graph appears in the display pane, with “Time” as the x-axis and the parameter “Value” as the y-axis. In 
addition, a legend appears above the graph, which indicates the name, data point shape and line color for that 
parameter.

2. If desired, a second parameter may be added to the graph by repeating Step 1. In this case, the parameter “Value” is 
shown as a right y-axis (Y2).

Note: Only two parameters may be graphed for a meter channel. However, you can open another window and graph 
two parameters for any other active meter channels.

3. To begin plotting data for the selected parameter(s), enter a time “Interval” for data sampling in the text box provided 
(the default value is 5 seconds).

4. Click [Plot Continuous] control button to begin graphing the selected process parameter(s) as a function of time, at 
the interval specified in Step 3.

5. While PanaView is graphing the data, the following actions are available for the control pane:

• Change the sampling interval by entering a new value.

• Click [Zoom Out] control button to increase the size of the intervals shown on the x-axis.

• Click [Zoom In] control button to decrease the size of the intervals shown on the x-axis.

Note: The zoom buttons may be clicked multiple times to enhance the effect.

• Click “Text Display” tab to view the data being graphed in the text format described in the previous section.

6. After you have finished graphing your data, click [Stop] control button, which has replaced the original [Plot 
Continuous] control button.
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6.4.3 Setting the Graph Properties
To customize a graph display, PanaView has a comprehensive “2D Chart Control Properties” feature. To access this feature, 
right click graph to open the dialog box shown in Figure 64 below. The chart (graph) properties available using this dialog 
box are listed in Table 1 on page 56.

Figure 64: Chart Properties Dialog Box

Table 1: Chart (Graph) Properties

Main Tab Sub-Tab Comments

Control Border

Interior

Axes General X, Y, and Y2 axes may be independently 
configured.Annotation

Scale

Title

Grid

Grid Style

Font

Chart Styles Line Style Style names may be added to or 
removed from the list.Symbol Style

Titles General Header and Footer may be independently 
configured.Label

Location

Border

Interior

Font

Legend General

Location

Border

Interior

Font
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Any property change made by selecting an item from a drop-down list automatically appears on the graph. However, 
changes made to a value in a text box do not take effect until you click [Apply] button. To close the “Chart Properties” dialog 
box and return to the “Graph” window, click [OK] button.

Note: You may click [Cancel] button at any time to keep all of the original graph properties.

The options available on the eight tabs in the “Chart Properties” dialog box are easy to use. They are described in Table 1 on 
page 56.

6.4.4 Creating Chart Templates
After setting up a chart (graph), as described in the previous section, you will find that several new menu options are now 
available in the “File” menu (see Figure 65 below).

Figure 65: The File Menu for Graphs

Use the new “File” menu options as follows:

• Click “Print” menu option to open the standard Windows print dialog box to print out a copy of the current graph.

Note: For a more legible printout, make sure the graph has black text on a white background (see “Setting the Graph 
Properties” on page 56).

• Click the “Save As” option to save the graphed data as a log file. When the dialog box in Figure 66 below opens, 

enter a name for the log file and click the [OK] button to save the file as:

C:\Program Files\PanaView\Logs\Untitled.LOG

Chart Area General Set interior background color to white 
before printing graph.Location

Border

Interior

Plot Area General

Table 1: Chart (Graph) Properties

Main Tab Sub-Tab Comments
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Figure 66: The Save As Dialog Box

• Click the “Save Output Template” option to save the current graph properties and parameters as a template for 

future graphs. When the dialog box in Figure 67 below opens, enter a name for the chart (graph) template file and 
click the [Save] button to save the file as:

C:\Program Files\PanaView\Charts\Untitled.opt

Figure 67: The Save Output Template Dialog Box

Note: The following menu option only becomes active after clicking on the [Clear Data] button to delete the data points 
from the current graph.

• Click “Save Chart Style” option to save only the current graph properties (and not the parameters to be graphed) 

as a template for future graphs. When the dialog box in Figure 68 below opens, enter a name for the chart (graph) 
template file and click the [Save] button to save the file as:

C:\Program Files\PanaView\Charts\Untitled.opt.oc2
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Figure 68: The Save Chart Style Dialog Box

IMPORTANT: Remember that the “Save Chart Style” option saves only the graph properties, while the “Save Output 
Template” option saves both the graph properties and the parameters to be graphed.

6.4.5 Using Chart Templates
After one or more chart templates has been created, as described in the previous section, these templates may be used to 
generate additional graphs in the same format. To do so, complete the following steps:

1. Select a chart template using one of the following methods:

• Open the “Output” menu and click “Graphing - From Template” option (see Figure 61 on page 51) or open the “File” 

menu and click “Load Output Template” option (see Figure 65 on page 57). If any output templates (*.opt) have 
been saved, select the desired file in the dialog box shown in Figure 69 below. Then, Click [Open] button to load the 
properties and parameters to be graphed from the output template selected.

Figure 69: Opening an Output Template
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Note: The following menu option becomes active only after clicking on the [Clear Data] button to delete the data points 
from the current graph.

• Open the “File” menu and click “Load Chart Style” option (see Figure 65 on page 57). If any chart templates (*.oc2) 

have been saved, select the desired file at the dialog box shown in Figure 70 below. Then, click the [Open] button to 
load the graph properties from the output template selected.

Figure 70: Opening a Chart Style Template

2. After you have finished creating the desired graphs, click the [Close] button in the lower right pane of the “Graph” 
window (see Figure 63 on page 54).

Note: If you have not already saved the current graph as a chart template, you will be given an opportunity to do so 
when you close the “Graph” window.

After the “Graph” window has been closed, continue with any of the other PanaView procedures described in this manual.
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6.5 The Logging Output

PanaView can create and view log files of the following types:

• Meter Logs - log files stored in your meter’s memory

(see “Creating Meter Logs” on page 61)

Note: Meter logs are further subdivided into “Internal (A:)” logs, which are stored in the meter’s RAM, and “External (B:)” 
logs, which are stored on the meter’s PCMCIA card.

• PC Logs - log files stored on your PC’s hard drive

(see “Creating PC Logs” on page 65)

To create or view logs of the above types, proceed to the appropriate section of this chapter. Figure 71 below illustrates the 
options available in the Logging output.

Figure 71: The Logging Output

6.5.1 Creating Meter Logs
To create a new meter log, complete the following steps:

1. Open the “Output” menu (see Figure 61 on page 51), and click on “Logging” and then on the “Log Browser” option to 
open the dialog box shown in Figure 72 below.

Figure 72: Computer Selection

Note: If no log files have yet been created or if a log file has not yet been selected from the list, all of the buttons (except 
for [Cancel]) in the “Log Browser” dialog box are unavailable.

2. Navigate through the PanaView network tree as follows:

a. Double-click computer name to move to the network level shown in Figure 73 below.
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Figure 73: Communication Port Selection

b. Double-click communication port name to move to the network level shown in Figure 74 below.

Figure 74: Meter Selection

c. Double-click meter name to move to the network level shown in Figure 75 below

Figure 75: Log Type Selection
62 PanaFlow Z3 User’s Manual



Chapter 6. Data Handling
d. Double click on meter logs to move to the network level shown in Figure 76 below.

Figure 76: Create a Meter Log

e. At the dialog box shown in Figure 76 above, click [Create] button to create a new meter log.

f. Enter a name for the log file in the dialog box shown in Figure 77 below (“Untitled” is used here). Click [OK] 
button.

Figure 77: Log Name Dialog Box

3. At the “Meter Log” window shown in Figure 78 below, the following log specifications may be entered:

• Select either “Internal (A:)” or “External (B:)” (if available) in the storage location list box.

• Click [Sync to PC] button to synchronize the clocks on the meter and the PC.

• Enter the Start Time and Stop Time for the log.

• For a circular log, place a check mark in the text box. For a standard log, leave this box empty.

• Specify a sampling interval for the log in the text box.
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Figure 78: The Meter Log Window

4. Expand the network tree as far as necessary and double click process parameter(s) to be logged. As they are selected, 
the parameters are listed in the lower right pane of the “Meter Log” window (make sure that the “Log Items” tab in this 
pane is selected).

Note: Refer to the meter’s User’s Manual for detailed information applicable to your specific meter.

5. Click [Apply] button to record the log setup information, and then click [Start] button. Data logging begins when the 
preset “Start Time” is reached.

You may monitor the logging progress using one of these methods:

• Click “Log Items” tab (see Figure 78 on page 64) for a list of the parameters specified for logging.

• Click “Contents” tab (see Figure 78 on page 64) for a list of all the data points logged to date for the parameter 

currently highlighted on the “Log Items” tab.

• Click [Graph] button to display a graphical representation of the data logged to date.

Note: The graph is displayed in its own window, which is opened on top of the “Meter Log” window. For instructions on 
using the “Graph Log” window, refer to “The Graphical Display Output” on page 54.

• Click the [Refresh] button to update the information shown on the “Contents” tab and in the “Graph Log” window. 

Data logged since the last use of the [Refresh] button is added to the list and to the graph.

Remember that only two parameters per channel may be graphed, and that the same two parameters must be graphed 
for each channel (see “Graphing Data” on page 55) of a multi-channel graph display. After you have finished viewing the 
graph, click [Close] button to close the “Graph” window and leave the log running.

6. To manually terminate the logging process, click the [Stop] button, which has replaced the original [Start] button. 
Otherwise, the log stops automatically when the programmed “Stop Time” is reached.
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6.5.2 Creating PC Logs
PC logs are created in much the same way as the meter logs described in the previous section. To create a new PC log:

1. Open the “Output” menu (see Figure 61 on page 51), and click “Logging” option to open the window shown in Figure 79 
below.

Figure 79: Selections in the Logging Option

2. Select one of the following two choices:

• Click “New PC Log” option and proceed to step 5.

• Click “Log Browser” option to open the dialog box shown in Figure 80 below.

Figure 80: Computer Selection

Note: If no log files have yet been created or if a log file has not yet been selected from the list, all of the buttons (except 
for [Cancel]) in the “Log Browser” dialog box are unavailable.

3. Double-click computer name to advance to the dialog box shown in Figure 81 below.
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Figure 81: Log Type Selection

4. Double-click PC logs to advance to the dialog box shown in Figure 82 below.

Figure 82: Create a PC Log

5. At the dialog box shown in Figure 82 on page 66, click [Create] button to create a new meter log.

6. Enter a log file name (“Untitled” is used here) in the dialog box shown in Figure 83 below. Click [OK] button.

Figure 83: Log Name Dialog Box

7. At the resulting “PC Log” window shown in Figure 84 below, place a check mark in the text box to create a circular log, or 
leave this box empty to create a linear log.
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Figure 84: The PC Log Window

8. Enter a sampling interval in the text box shown in Figure 84 on page 67, or check “Max Comm Rate” to sample data at 
the fastest speed allowable by the system (1 sec).

Note: “Start Time” and “Stop Time” cannot be specified for PC logs. These options are inactive in the “PC Log” window.

9. Expand the network tree as far as necessary and double click on the process parameter(s) to be logged. As they are 
selected, the parameters are listed in the lower right pane of the “PC Log” window (make sure that the “Log Items” tab in 
this pane is selected).

Note: Refer to the meter’s User’s Manual for detailed information applicable to your specific meter.

10. Click [Apply] button to record the log setup information, and then click [Start] button to begin logging data 
immediately (the “Start Time” automatically appears in the “PC Log” window).

You may monitor the logging progress using one of these methods:

• Click “Log Items” tab (see Figure 84 on page 67) for a list of the parameters specified for logging).

• Click “Contents” tab (see Figure 84 on page 67) for a list of all the data points logged to date for the parameter 

currently highlighted on the “Log Items” tab).

• Click [Graph] button to display a graphical representation of the data logged to date.

Note: The graph is displayed in its own window, which is opened on top of the “Meter Log” window. For instructions on 
using the “Graph Log” window, refer to “The Graphical Display Output” on page 54.

• Click the [Refresh] button to update the information shown on the “Contents” tab and in the “Graph Log” window. 

Data logged since the last use of the [Refresh] button is added to the list and to the graph.

Remember that only two parameters per channel may be graphed, and that the same two parameters must be graphed 
for each channel (see “Graphing Data” on page 55) of a multi-channel graph display. After you have finished viewing the 
graph, click [Close] button to close the “Graph” window and leave the log running.

11. To terminate the logging process, click the [Stop] button, which has replaced the original [Start] button, and the “Stop 
Time” automatically appears in the “PC Log” window.

Because a PC log has no specific “Stop Time,” the log will continue to run until it is manually stopped (unless the PC is turned 
off or you run out of hard drive storage space).
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6.5.3 Viewing Log Files
After one or more log files has been created, the logs may be viewed by using the “Log Browser” as follows:

1. Open the “Output” menu (see Figure 61 on page 51), and click “Log Browser” option.

2. Advance to either the “PC Logs” or “Meter Logs” dialog box as described in previous sections. Using a meter log as an 
example, a screen similar to that shown in Figure 85 below opens.

Figure 85: Selecting a Log File

Note that each of the log files in Figure 85 above has a traffic light icon or a book icon next to its name. These icons indicate 
the current status of the log as follows:

• Book - The log has run to its specified stop time and is complete

(see A:Complete.LOG in Figure 85 above).

• Red Light - The log has not run to its specified stop time but has been manually stopped (see A:Stopped.LOG in 

Figure 85 above).

• Yellow Light - The log has been set up but the specified start time has not yet been reached (see A:Pending.LOG in 

Figure 85 above).

• Green Light - The log is currently running but is not yet complete

(see A:Running.LOG in Figure 85 above).

Note: The yellow light icon and the book icon are only possible for meter logs, because PC logs have no specific “Start 
Time” or “Stop Time.”

3. After you highlight the name of the desired log file, the following buttons become available:

• [Start] - resumes logging if the log is currently stopped

or

[Stop] - stops logging, if the log is currently running

• [Delete] - permanently deletes the log file

• [Open] - opens the log in the “PC Log” or “Meter Log” window

4. Click one of the buttons listed in Step 3 above.

For instructions on manipulating the information displayed in the log window, refer to “Creating PC Logs” on page 65 or to 
“Creating Meter Logs” on page 61.
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Appendix A. Menu Map
For convenient reference, a complete map of the PanaView menu system is shown in Figure 86 on page 70. The menu map 
consists of the PanaView menu bar, with all of the individual menus fully expanded.

When using the menu map, keep the following points in mind:

• All of the menu items shown are not available at all times - some items are grayed out or absent in certain 
situations

• See the appropriate sections of this manual and the programming sections of the User’s Manual for your specific 
instrument for detailed information regarding each menu and submenu

The menu map should be used in conjunction with the detailed information presented in the main body of this manual.
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Figure 86: Menu Map
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