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COPYRIGHT NOTICE 
This manual is a publication of Maple Systems, Inc., and is 
provided for use by its customers only. The contents of 
the manual are copyrighted by Maple Systems, Inc.; 
reproduction in whole or in part, for use other than in 
support of Maple Systems equipment, is prohibited 
without the specific written permission of Maple Systems. 

The copyright of EZwarePlus and its related software 
belongs to Weintek Labs, Inc. 

WARRANTY 
Maple Systems warrants each product to be free from 
electrical and mechanical defects in materials and 
workmanship for a period of one (1) year for the LCD 
display and backlight and two (2) years from the date of 
shipment for all other parts and labor. This warranty does 
not apply to defects in the Products caused by abuse, 
misuse, accident, casualty, alteration, negligence, repair 
not authorized by Maple Systems, use on current or 
voltages other than specified by Maple Systems, or 
application or installation not in accordance with 
published instruction manuals. This warranty is in lieu of 
any other warranty either expressed or implied. 

Maple Systems’ liability is limited to the repair or 
replacement of the Product only, and not costs of 
installation, removal, or damage to user’s property or 
other liabilities. If Maple Systems is unable to repair or 
replace a nonconforming Product, it may offer a refund of 
the amount paid to Maple Systems for such Product in full 
satisfaction of its warranty obligation. Maximum liability 
of Maple Systems is the cost of the Product. 

Information furnished by Maple Systems, Inc., is believed 
to be accurate and reliable. However, no responsibility is 
assumed by Maple Systems for the use of this information 
nor for any infringements of patents or other rights of 
third parties which may result from its use. No license is 
granted by implication, or otherwise, under any patent or 
patent rights of Maple Systems, Inc. Maple Systems 
retains the right to revise or change its products and 
documentation at any time without notice. 

 

 

 

 

 

IF SERVICE IS REQUIRED 
Contact Watlow Customer Service at (507) 454-5300 for 
instructions on how to return a product and how to 
obtain a Return Materials Authorization (RMA) number. 

Package the unit in its original packaging container or, if 
unavailable, any suitable rigid container. If a substitute 
container is used, surround the unit with shock absorbing 
material; damage in shipment is not covered by the 
warranty. Include a letter with the unit describing the 
difficulty and designating a contact person. 

All returns will be tested to verify customer claims of 
noncompliance with the product warranty. Improper 
return packaging, which makes verification impossible, 
will void the warranty. Products passing the tests will be 
returned, “AS IS” to the customer. 

If noncompliance is verified and is not due to customer 
abuse or the other exceptions described with product 
warranty, Watlow will, at its option, repair or replace the 
Product returned to it, freight prepaid, which fail to 
comply with the foregoing warranty, provided Watlow is 
notified of such noncompliance within the two-year 
warranty period. 

APPLICATIONS ASSISTANCE 
This manual is designed to provide the necessary 
information for trouble-free installation and operation of 
your new HMI. However, if you need assistance, please 
call Watlow at (507) 494-5656 between 7 a.m. and 5 p.m. 
Central Standard Time (CST). Ask for an Applications 
Engineer. Or you may e-mail your questions to 
wintechsupport@watlow.com. 
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Regarding Watlow Part Numbers 
When you purchased your Operator Interface Terminal and accessories from Watlow, you ordered and received them under 
Watlow part numbers. The parts are also labeled with Maple Systems’ part numbers and are referred to by those part 
numbers throughout this manual and other support documents. The table below correlates the Watlow and maple Systems 
part numbers. 

Watlow P/N Maple P/N Description 

Silver Series EM HMI5000  

TS00-0043-EM00 HMI5043L 4.3 inch diagonal (480 x 272) 65,536 (16-bit) color TFT LCD and an 
analog-resistive touchscreen 

TS00-0070-EM00 HMI5070L 7 inch diagonal (800 x 480) color TFT LCD touchscreen, USB, two 
serial ports and Ethernet. 

TS00-0100-EM00 HMI5100L 10 inch diagonal (800 x 480) color TFT LCD touchscreen, USB, two 
serial ports and Ethernet. 

0830-0750-0000 4010-0005 25W power supply: Input: 85-264 VAC, Output: 24VDC, 1.1A, CE/UL 
rated 

0219-0388-0000 7444-0185-5  TS00-0043-EM00 communication cable, 5-foot, COM1 [2-wire 485] to 
bare wires for Watlow EZ-ZONE® controller screw terminals 

0219-0374-0000 7446-0185-5  
TS00-0070-EM00 and TS00-0100-EM00 communication cable, 5-foot, 
COM1 [2-wire 485] to bare wires for Watlow EZ-ZONE® controller 
screw terminals 

0830-0782-0000 2203-0011 Package of 5 ea. protective screen covers for the TS00-0043-EM00 
0830-0753-0000 2253-1004 Package of 5 ea. protective screen covers for the TS00-0070-EM00 
0830-0754-0000 2253-1005 Package of 3 ea. protective screen covers for the TS00-0100-EM00 

 

  1010-1015, Rev. 03 



iv  EZwarePlus Programming Manual 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

This page intentionally left blank 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  v 

Table of Contents 

COPYRIGHT NOTICE ....................................................... ii 

WARRANTY .................................................................... ii 

IF SERVICE IS REQUIRED ................................................ ii 

APPLICATIONS ASSISTANCE ........................................... ii 

Regarding Watlow Part Numbers .................................. iii 

Table of Contents .......................................................... v 

Chapter 1 – Introduction ................................................ 1 

Welcome ....................................................................... 1 

EZwarePlus Support ...................................................... 1 

HMI Models Supported.............................................. 1 

PLCs Supported .......................................................... 1 

About Your Documentation .......................................... 1 

Conventions ............................................................... 1 

What You Need ............................................................. 2 

OIT/HMI Basics .............................................................. 3 

Projects ...................................................................... 3 

Backing Up Projects ................................................... 3 

Objects ....................................................................... 3 

Graphics Object ......................................................... 4 

Windows .................................................................... 4 

What is an HMI5000P/L/HD Series? .............................. 4 

List of Features .............................................................. 5 

Chapter 2 – HMI Local Setup .......................................... 8 

Factory Configuration .................................................... 8 

Calibrating the Touchscreen ...................................... 8 

Getting into Local Setup ............................................ 8 

Changing the System Settings .................................... 9 

Viewing System Information .................................... 14 

Transferring Projects and Data from USB/SD Card .. 15 

Changing or Restoring the HMI Settings by USB or SD 17 

Chapter 3 – Connect the HMI to the PLC or Controller .. 19 

Connecting to COM1 and COM3 on Port A ..............23 

Connecting to COM1 and COM3 on Port B ..............25 

Connecting multiple PLC/controllers serially using 
daisy chaining ...........................................................26 

Connecting one or more PLC/controllers via Ethernet
 ..................................................................................26 

Troubleshooting .......................................................27 

Chapter 4 – Creating a Sample Project ......................... 28 

Starting EZwarePlus .....................................................28 

To start Utility Manager and EZwarePlus: ..........28 

Creating a Bargraph .....................................................28 

To create Window 11: ........................................28 

To create a Function Key: ...................................30 

To create a Bar graph: ........................................33 

To create a Set Word: .........................................36 

To create a Bit Lamp: ..........................................41 

To create a Set Bit: ..............................................43 

Finishing Up .................................................................45 

Saving your first project ......................................45 

Compiling your first project ................................46 

Simulating your first project ...............................46 

Downloading your first project ...........................48 

Chapter 5 – Simulator Mode ........................................ 50 

The Simulation Screen .................................................50 

Simulating the HMI is done in on-line or off-line 
mode. .......................................................................50 

To use off-line simulation mode from EZwarePlus:
 ..................................................................................51 

To use off-line simulation mode from Utility 
Manager ...................................................................51 

To use on-line simulation mode from EZwarePlus
 ..................................................................................51 

  1010-1015, Rev. 03 



vi  EZwarePlus Programming Manual 

To use on-line simulation mode from Utility 
Manager .................................................................. 51 

To use EasySimulator ......................................... 52 

Chapter 6 – Using EZwarePlus ...................................... 53 

Overview ..................................................................... 53 

The Utility Manager .................................................... 53 

Utility ....................................................................... 55 

Easy Converter .................................................... 55 

EasyPrinter ......................................................... 60 

EasyAddressViewer ............................................ 62 

EasyDiagnoser .................................................... 62 

Recipe/Extended Memory Editor ....................... 62 

Build Download Data for SD/USB Disk ............... 67 

Download ........................................................... 67 

Upload ................................................................ 67 

Simulation Settings .................................................. 67 

On-line Simulation .............................................. 67 

Off-line Simulation.............................................. 67 

Pass-through mode.................................................. 68 

EZwarePlus Features ................................................... 71 

Objects Summary ..................................................... 71 

Managing Projects ................................................... 87 

Display Options ........................................................ 89 

Basic Editing Commands .......................................... 95 

Grouping Objects .............................................. 100 

Layering Objects ............................................... 100 

Nudging Objects ............................................... 100 

Making Objects the Same Size ......................... 101 

Making Objects the Same Color ....................... 101 

Flipping, Rotating, and Locking Objects ........... 102 

System Parameter Settings ....................................... 103 

Device tab settings: .......................................... 104 

Model tab settings: ........................................... 107 

General tab settings: ........................................ 109 

System Setting tab settings: .............................. 111 

Security tab settings: ........................................ 113 

Font tab settings: .............................................. 116 

Extended Memory tab settings: ........................ 117 

Printer/Backup Server tab settings: .................. 118 

E-Mail tab settings: ........................................... 119 

Recipes tab settings: ......................................... 121 

Reboot HMI ............................................................ 123 

Save and Compile the Project ................................ 123 

EZware-500 Project Translation Utility .................. 123 

Chapter 7 – Creating Windows .................................. 126 

Window Fundamentals .............................................. 126 

Opening and Closing a Window ................................. 126 

Creating a New Window ............................................ 127 

Window Settings ........................................................ 129 

Assigning a Window Name ..................................... 129 

Assigning the Window Number ............................. 129 

Assigning Size of Window ...................................... 129 

Assigning a Position ................................................ 129 

Monopoly Feature.................................................. 129 

Assigning Underlay Windows ................................. 130 

How to Display Underlay Windows .................. 130 

Creating a Frame .................................................... 131 

Window Background .............................................. 131 

Deleting a Window .................................................... 131 

Using Base Windows .................................................. 132 

How to Display Base Windows ............................... 132 

Using a Function Key ......................................... 132 

Using the PLC .................................................... 133 

Using the Common Window .................................. 138 

Displaying the common window above/below the 
base window ..................................................... 139 

Changing the Active Common Window ............ 140 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  vii 

Using the Fast Selection Window .......................... 142 

Using the Fast Selection Button ........................ 144 

System Message Windows .................................... 146 

Chapter 8 – Creating and Using the Tag Library and Label 
Library ....................................................................... 148 

Creating and Using the Tag Library ........................... 148 

Importing and Exporting the Tag Library ............... 149 

Using the Tag Library ............................................. 150 

Creating the Label Library ......................................... 151 

Setting Different Fonts for Different Languages .... 153 

Importing and Exporting the Label Library ............ 153 

Using the Label Library .......................................... 154 

Using Languages with the Label Library ........... 155 

Chapter 9 – Creating and Using Keypads .................... 156 

How to Create a Keypad ............................................ 156 

Displaying and Using a Keypad .............................. 157 

Chapter 10 – Bar Graphs and Meters ......................... 160 

Creating Bar Graphs .................................................. 160 

Creating Meter Displays ............................................ 163 

Chapter 11 – Data Sampling, Trend Displays, and History 
Data Displays ............................................................. 166 

Creating Data Sampling Objects and Trend Displays . 166 

History Data Display .................................................. 172 

Chapter 12 – Capturing Alarms and Events ................. 177 

Using Alarm/Events ................................................... 177 

Monitoring Alarms with the Event (Alarm) Log ..... 177 

Displaying Alarms using the Alarm Display Object 181 

Displaying Alarms using the Alarm Bar Object ...... 183 

Displaying Alarms Using the Event Display Object 184 

Chapter 13 – Security ................................................. 187 

System Parameter Settings Security tab ................... 187 

General Mode ........................................................ 188 

Enhanced Security Mode ....................................... 189 

Object Security .......................................................193 

User Restriction .................................................193 

Safety Control .........................................................194 

Interlock .................................................................194 

Sound .....................................................................195 

Auto logout ................................................................196 

Additional Security Features ......................................196 

Project Password (MTP file) ...................................196 

Project Protection ..................................................197 

Disable Upload Function ........................................198 

XOB Password ........................................................199 

Decompiling Prohibited ..........................................200 

System Passwords ..................................................201 

Chapter 14 – Administrator Tools .............................. 206 

User Accounts ............................................................206 

USB Security Key ........................................................208 

e-Mail SMTP Server Settings ......................................210 

e-Mail Contacts ..........................................................212 

Chapter 15 – Recipes ................................................. 214 

Creating a Recipe .......................................................214 

Adding and Editing Data in a Recipe in EZwarePlus ...215 

Adding and Editing Data in a Recipe in the Recipe 
Database Editor .........................................................216 

Adding and Editing Data in the Recipe Database File in 
the HMI ......................................................................217 

Chapter 16 – Operation Log ....................................... 221 

Configuration Settings ...............................................221 

View Settings .............................................................223 

Chapter 17 – EasyDiagnoser and Easy Watch ............. 226 

EasyDiagnoser ............................................................226 

Main Window .........................................................228 

Polling Packages .....................................................229 

Devices ...................................................................230 

  1010-1015, Rev. 03 



viii  EZwarePlus Programming Manual 

Output ................................................................... 230 

Logger .................................................................... 231 

EasyWatch ................................................................. 231 

Chapter 18 – Using the Modbus Gateway .................. 237 

Configuring the Modbus Gateway ............................ 238 

Configuring the ModbusTCP Master ......................... 240 

Appendix A – Reserved Local Memory ....................... 241 

 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  1 

Chapter 1 – Introduction 

Welcome 
Welcome to the Maple Systems’ Silver Series EM Operator Interface Terminals (OITs). Using graphic OITs has never 
been easier. This powerful family of graphic HMIs connects to programmable logic controllers (PLCs) to provide the 
human-machine interface in industrial applications. The Silver Series EM have several features not found in other 
graphic OITs. This manual explains the programming and operation of the Silver Series EM OITs and how to 
implement the many available features using the EZwarePlus Configuration Software. 

Watlow and Maple Systems have worked together to bring you this product. Please contact Watlow for support, and 
be sure to utilize any resources referenced in this manual on the Watlow website (www.watlow.com) and the Maple 
Systems Website (www.maplesystems.com). 

EZwarePlus Support 

HMI Models Supported 
For the latest list of Silver Series EM models supported by EZwarePlus, please visit our website at 
www.maplesystems.com. 

PLCs Supported 
For the latest list of PLCs and controllers supported by the Silver Series EM touchscreens, please visit our website 
www.watlow.com. 

About Your Documentation 
Watlow and Maple Systems provides many resources to allow you to get the most out of your touchscreen. 

• This EZwarePlus Programming Manual (shipped with EZwarePlus as a PDF file) describes the general operation 
and features of the Silver Series EM using EZwarePlus configuration software. 

• Silver Series EM Installation Guide provide information on installing, powering, and connecting the Silver Series 
EM to a PLC/Controller. 

•  Controller Information Sheets provide important information specific to each supported protocol (available on 
the Maple Systems website). 

•  EZwarePlus Online Help covers the operation of EZwarePlus. Help is always available by clicking Help Topics 
from the Help menu in EZwarePlus, or press F1 from any dialog. 

For more information, please visit the Support Center section at http://www.maplesystems.com/support.htm. The 
Support Center provides links to manuals, FAQs, technical notes, training videos, sample projects, controller 
information sheets, and controller cables. 

Conventions 
When using EZwarePlus, there are usually several ways to perform a task. For example, if you want to copy a graphics 
object, you can: 

•  Click the Copy command on the Edit menu. 

•  Click the Copy button on the Standard toolbar. 

•  Press the CTRL + C keys on your computer. 

 

  1010-1015, Rev. 03 

http://www.maplesystems.com/
http://www.watlow.com/
http://www.maplesystems.com/support.htm


2  EZwarePlus Programming Manual 

  Icon   Meaning 
 Identifies a procedure. 
  Indicates a reference to additional information. 
  Indicates an important note. 
 

In most cases, we will describe each method when the task is first discussed. The menu method is then used 
whenever the task is used in later procedures. Other conventions used in this manual are listed in the following table. 

Convention Meaning 
Bold Characters that you must type exactly as they appear. For example, if you are directed to 

type a:\setup, you should type all the bold characters exactly as they are printed. 
Italic Placeholders for information you must provide. For example, if you are directed to type 

filename, you should type the actual name for a file instead of the word shown in italic type. 
Italics are also used to indicate a glossary term. 

ALL CAPITALS Directory names, file names, key names, and acronyms 
KEY1+KEY2 A plus sign (+) between key names means to press and hold down the first key while you 

press the second key. 
Click Refers to clicking the primary mouse button (usually the left mouse button) once. 
Double-click Refers to quickly clicking the primary mouse button (usually the left mouse button) twice. 
Right-click Refers to clicking the secondary mouse button (usually the right mouse button) once. Right-

clicking usually opens shortcut menus. 
 

The following table identifies symbols and margin icons. 

 

 

 

What You Need 
The following items are needed to configure and operate your HMI. 

Configuration Software EZwarePlus 
Configuration Cable1 7431-0104 (Ethernet Crossover cable for Ethernet-equipped models) 

7431-0115 (USB download cable for USB Client-equipped models) 

Personal Computer2 User Provided 
Power Cable 6030-0009  2-conductor 18 AWG, shielded, no connectors 
24VDC Power Supply User Provided (or available from Maple Systems) 
PLC User Provided 
Controller Information 
Sheet 

Maple Systems provides Controller Information Sheets which contain important information 
specific to each PLC. Please locate the sheet that corresponds to your PLC on our website. 

Communication Cable 

   

Refer to our web site (www.maplesystems.com) for a list of available cables. 

 

1Allows you to connect the HMI directly to a PC Ethernet port or to a USB port to download/upload projects into the 
HMI. 

2Computer requirements include a Pentium 1.7 GHz or higher processor, 512 MB RAM, 200 MB available Hard Disk 
Space, SVGA or higher resolution monitor, Keyboard and Mouse, available Ethernet port, USB 2.0 port for 
downloading project (depending on model), at least one RS232 port for online simulation, Windows XP, Vista, or 
Windows 7 operating system. 
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OIT/HMI Basics 
Operator Interface Terminals (OITs) and Human Machine Interfaces (HMIs) provide much more versatility than 
traditional mechanical control panels. An OIT allows a plant floor operator to monitor current conditions of a control 
system and, if necessary, to initiate a change in the operation of the system. OITs connect to programmable logic 
controllers (PLCs) typically through the PLC’s serial communications port. The OIT can be programmed to monitor and 
change current values stored in the data memory of the PLC. 

OITs can have either text-based or graphics-based displays. A text-based OIT can display text characters but no 
graphics. Some text-based OITs can display text characters in various sizes. A graphics-based OIT can display text 
characters of varying fonts and sizes and graphics shapes such as icons, bitmaps, or pictures. Using pictures instead of 
words or characters often greatly simplifies the operation of the OIT, making the OIT much more intuitive to use. 

Some OITs use touchscreen displays while others use a membrane-style keypad. Membrane-style keypads are best 
used in applications in which the keypad is likely to become dirty. Touchscreen displays are placed over the OIT 
screen thus providing much more flexibility than typical membrane-style keypads. Because of this, switches can be 
created on a touchscreen that appear only when needed. 

The Maple Systems HMI5000 Series are graphics-based touchscreen OITs. The terms OIT and HMI can be used 
interchangeably, so we will use HMI in most cases. Now let us define some terms that are used throughout the 
EZwarePlus Help files. 

Projects 
The HMI has two basic segments of internal memory. The code memory contains the information required by the HMI 
that controls how it operates such as the features supported and how it communicates to a PLC. The HMI 
programmer does not have the ability to change code memory. The project memory pertains to all the window 
screens created and any other features that the HMI programmer can create using the EZwarePlus configuration 
software. Therefore, the term project is used to designate the file that is sent to the HMI from the EZwarePlus 
software. 

Backing Up Projects 
We recommend that you frequently back up your projects to another folder or an 
external or network drive. In addition, when you have completed a project, 
archive it by running the compression utility (Tools > Compress/Uncompress), 
which bundles the project with the libraries that are associated with the project. 
This allows the project to be opened on another computer and retain all the 
shapes and pictures that are linked to the project. Refer to the Help menu for 
more information (Help > Help Topics > Contents > How Do I…Backup a Project?). 

Objects 
An object is any ‘thing’ that performs an action while the HMI is communicating to the PLC. In order to get the HMI to 
‘do anything’, you must program the HMI with objects. Objects perform actions such as display text or graphics, write 
a value to a PLC register, or display an alarm. Objects most often are graphics shapes that are to be displayed on the 
HMI screen. For example, a Text Object is used to display text on the HMI. But objects are also used to configure the 
HMI to perform some action. For example, a PLC Control Object tells the HMI to continuously monitor a PLC register 
that is used by the PLC to request a new window. Some objects can display a graphics shape on the HMI screen and 
perform some action. For example, a Toggle Switch Object creates a graphic object on the HMI that, when pressed, 
activates a bit in the PLC. 
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Graphics Object 
A Graphics Object is any text, icon, or picture that can be displayed on the HMI. Graphics objects are further defined 
by how they are composed or created. A Text Object is a graphics object that displays text on the HMI screen. A 
Bitmap Object is a graphics object that displays a bitmap on the HMI screen. Bitmaps are files stored in the HMI to 
display pictures. A Shape Object is a graphics object that displays a shape on the HMI screen. Shapes are also files 
stored in the HMI to display pictures. Shapes differ from bitmaps in that shapes are stored using a vector-based file 
format whereas bitmaps use a pixel-based file format. Each format has its advantages and disadvantages. For 
example, vector-based graphics can be resized without losing resolution, whereas bitmap graphics lose resolution as 
they are magnified. Finally, a Group Object is the most complex type of graphics object. It is a combination of other 
objects. Briefly, a group object consists of one or more objects that are ‘grouped’ together and stored as one object. A 
good example is a keypad, which is really a combination of several keys each designed to perform a specific task. 
When grouped together, a keypad can be stored as a group object for use in other projects or windows. 

Windows 
A window is a screen that can be displayed on the HMI. Windows can be full-sized to completely cover the HMI 
display or partially sized. Any partially sized window is usually referred to as a popup window. Windows can appear on 
the HMI display by a request from the PLC or by a press from the touchscreen. Windows can be configured to any 
size. Once a window is displayed, it can be moved around the HMI display or removed from the display. Windows can 
even overlap each other. Each window can display graphics objects and there is no limit to the number of graphics 
objects that can be placed on each window. The HMI5000P/L Series is capable of storing up to 1999 windows, but the 
actual limit is determined by the total amount of memory used for the application. 

What is an HMI5000P/L/HD Series? 
The HMI5000P/L Series by Maple Systems are graphics operator interfaces designed to connect to PLCs in an 
industrial environment. The displays are covered with analog resistive touchscreens designed for harsh industrial 
environments. The touchscreens use the latest in touchscreen technology enabling the HMI programmer to create 
switches that are very fine in resolution. Unlike many other touchscreen HMIs on the market, the HMI5000P/L Series 
are not limited to a fixed number of cells in which switches can be created. The project can contain as many switches 
of varying sizes and shapes as desired, limited only by the total amount of memory available for the project. 

Three LED indicators are provided on the face of the HMI5000P Series to provide instant feedback to the HMI 
operator of the current operating condition of the HMI.  The HMI5000L has a power LED. 

 

 LED Indicator  Purpose 
 PWR LED (yellow)  indicates if power is applied to the OIT 
 CPU LED (green)  indicates if the OIT is operating correctly (HMI5000P Only) 
 COM LED (red)  indicates communications activity on PLC port (HMI5000P Only) 

 

The HMI5000P/L Series have two serial ports, which provide a connection to a PLC using RS-232, RS-485; CANbus 
communications, and an Ethernet connection for PLC communication and project upload and download. The serial 
ports also provide the ability to use the EZwarePlus configuration software in Pass-Through Mode, enabling the HMI 
programmer to test his project on the PLC through the HMI instead of downloading the project to the HMI. 

The HMI5000HD series are DIN-rail mount units designed to display information on an HDMI video device.  The 
HMI5000HD units do not have an integrated display. 

 

 The L and HD Series do not support CANbus. 
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The HMI5000P/L/HD Series are powered using +24VDC. A reset switch is provided on the back of the HMI to 
reinitialize the HMI if an operational failure occurs. The HMI5000P/L Series is designed for industrial environments 
and carries a NEMA4/IP65 rating as well as CE compliance for noise immunity and emissions.  The HMI5000HD series 
carry the CE rating for noise and immunity, but are designed to be installed inside an enclosure. 

List of Features 
The next chapter will guide you through the creation of your first project. Before you proceed, you may wish to read 
this brief list of some of the features offered in the EZwarePlus programming software. 

 
Bit Lamp Creates a graphic object to reflect the current status of a PLC bit. 

 
Word Lamp Creates a graphics object to reflect the current state of a multi-state PLC data 

register. 

 
Set Bit Creates a touchscreen graphics object that represents a two-state switch. When 

pressed it sets/resets a PLC bit. 

 
Set Word Creates a touchscreen graphic object that represents a multi-state switch. When 

pressed it can place a constant value in a PLC register or jog the value. 

 
Toggle Switch Creates a touchscreen graphic object that represents a two-state switch changing 

state (picture) based upon a PLC bit. When pressed, it can control another PLC bit. 

 
Multi-State 
Switch 

Creates a multi-state touchscreen graphic object that changes state (picture) 
according to the value in a PLC data register. When pressed, it sends a value(s) to 
another PLC register. 

 
Option List Displays a list of test items with the selected item being determined by the value in 

a register. Optionally, selecting an item can write the corresponding value to a 
register. 

 
Slider Object Creates a touchscreen graphic object that changes the state according to the 

position of a slider switch. 

 
Function Key Creates a touchscreen graphic object that changes windows, inputs data as part of 

a keypad, executes a macro, or prints the screen to a USB flash drive or printer. 

 
Numeric Display Displays a number stored in a PLC register. 

 
Numeric Input Displays a number stored in a PLC register. The number can be changed using a 

numeric keypad. 

 
ASCII Display Displays ASCII characters stored in a PLC register. 

 
ASCII Input Displays ASCII characters stored in a PLC register. Characters can be changed using 

an alphanumeric keypad. 

 
Indirect Window Displays any Window based on the value in a PLC word address. 

 
Direct Window Displays a specified Window based on a bit in a PLC register. 
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Moving Shape Creates a multi-state graphic object, which changes state (picture) and position on 

the screen according to a value in a PLC register. 

 
Animation Creates a multi-state graphic object, which changes state (picture) on the screen 

according to a value in a PLC register. The positions on the screen are predefined. 

 
Media Player Displays a video file from a connected USB flash drive or SD card. 

(HMI5121P and 5150P only) 

 
Video In Input and play video on the HMI from an external source. 

(HMI5121P and 5150P only) 

 
Bar Graph Creates a bar graph with alarm monitoring. 

 
Meter Display Creates a scale meter. 

 
Trend Display Creates a trend graph. Monitors data in single or multiple PLC registers  

and plots the data on a time graph. 

 
History Data 
Display 

Displays historical data in a tabular format. 

 
Data Block 
Display 

Displays the data stored in a series of registers as a line graph. 

 
XY Plot Creates an XY Plot of data stored in a series of registers. 

 
Recipe View Displays recipe data in a tabular format. 

 Alarm Bar Displays alarms detected by the Alarm (Event) Log Object on a single horizontal 
scrolling line. 

 
Alarm Display Display alarms detected by the Alarm (Event) Log Object in a table format. 

 
Event Display Displays messages detected in the Alarm (Event) Log and can acknowledge the 

message(s). 

 
Alarm (Event) 
Log 

Contains the data for detecting alarm conditions. 

 
Data Transfer 
(Trigger-based) 

Transfers data to the specified PLC registers based on a touch or PLC bit status. 

 
Backup Copies recipe, event, or historical data to one of the USB flash drives or to a PC 

connected via Ethernet. 

 
Timer Controls an internal bit or PLC bit based on a timer; supports five different 

configurations. 

 
PLC Control Configures the HMI to monitor PLC data registers to display full window screens, 

execute a data transfer, control the backlight, play a sound, execute a macro,  
or print a screen. 
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Data Transfer 
(Time-based) 

Transfers data to the specified PLC registers on a timed basis. 

 
Data Sampling Stores data for trending and archiving. 

 
System Message Customizes the content of system-generated messages. 

 
Scheduler Performs an action based upon a time schedule. 

 
Drawing Tools Includes Line, Arbitrary Line, Link Line, Arc, Ellipse/Circle, Pie, Rectangle, Polygon, 

Scale, Text, Picture, and Shape. 
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Chapter 2 – HMI Local Setup 

Factory Configuration 
Each HMI arrives from the factory with a demo project file that illustrates some of the most popular features of the 
HMI. For a first time user, it is worthwhile to navigate through the screens in the demo project and become familiar 
with the features and capabilities of the HMI and EZwarePlus. Refer to the EZwarePlus Help file for more information 
about the features and operation of the HMI and EZwarePlus.  

The HMI also has a black reset push button and a four-position DIP switch located through an access hole on the back 
of the enclosure. The reset switch can be used to reinitialize the HMI if the HMI malfunctions. DIP switch 1 puts the 
HMI into Touch Calibration mode. For normal operation, all of the DIP switches should be set to the OFF position. 

This chapter describes how to use the HMI5000P/L Series’ local setup options. The local setup allows touchscreen 
calibration, transferring projects to and from the HMI, configuring the HMI’s IP settings, passwords, time and date, 
screen contrast, as well as managing the storage of recipe and history files. Additionally, memory and other system 
information can be viewed. 

Calibrating the Touchscreen 
The touchscreen of the HMI is fully calibrated before it leaves the factory so there is no need to adjust it. However, 
over time the touchscreen may need to be recalibrated. 

To calibrate the touchscreen: 
1. Turn DIP switch 1 ON. On units without DIP switches, open the System Toolbar and touch the Calibration 

icon (see below). 
2. Cycle power to the HMI (or press the reset button next to the DIP switches). 
3. After the HMI displays a crosshair cursor, you are prompted to touch the cursor for: 

Top left position     Top right position 
Center position 

Bottom left position    Bottom right position 
4. Units with DIP switches will present the option to restore the system settings password to the default setting 

(111111). If you choose Yes, a dialog box will inform you that the project will be erased in the HMI. You must 
type Yes to complete the operation. After performing this operation, you must reset the Upload, Download, 
and Upload (History) Passwords in the System Settings Security tab. When you next download a project, 
check the Firmware and Font files checkboxes in the Download dialog.  
If you choose No or allow the option to timeout, the HMI will resume initializing and run the project. 

Getting into Local Setup 
Access the local setup menu by touching the arrow in the lower right-hand corner of the HMI screen. The following 
Toolbar will pop up: 

 

 

 

  System info icon 

Small keyboard icon 

Large keyboard icon System settings icon 

Touchscreen calibration icon 

 The Touchscreen Calibration icon is present only on units without DIP switches. 
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Changing the System Settings 
To change the system settings on the HMI: 

1. Open the System Setup Toolbar as described above, and click the System Settings icon. 

2. A dialog will be displayed requesting the Local password. The default password is 111111. 

  You may have to move windows around a bit to gain access to the virtual keyboard.  
You may also have to click inside the password field again. 

3. Once the correct password has been entered, the System Settings dialog is displayed. For all tabs, the Cancel, 
Apply, and OK buttons are available. 

Cancel  Close the System Settings dialog without saving any changes. 
Apply  Save the current settings without closing the System Settings 

 OK  Save the current settings and close the System Settings dialog. 
 

4. Click on the Network tab to configure network settings. The Network dialog is displayed. 

 

5. The Network tab allows configuration of the IP settings. The default setting is Obtain an IP Address 
Automatically. Use this setting if the HMI will obtain an IP address from a DHCP server. If connected to a 
DHCP server, this dialog will display the IP settings obtained by the HMI. The IP fields are disabled and are 
not editable. 

6. If using a static IP address, use the IP Address get from below option. The IP fields are enabled. Enter the 
appropriate settings for your network. 

7. Click the Time/Date tab to configure time/date settings. The time/date dialog is displayed. 
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8. Configure appropriate time and date settings. 

9. Click on the Security tab to display the security settings dialog. Here, you can select your system passwords. 

 

10. Configure your password settings. 

Local Password  The password required to enter local setup. 
Upload Password  The password required to upload data from the HMI to a PC or memory module. 
Download 

 
 The password required to download data to the HMI from a PC or memory module. 

Upload (History) 
Password 

 The password required to upload history files from the HMI to a PC or 
memory module. 
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11. The new password must be entered, and then entered again to confirm. As the password is entered into the 
confirm field, an indicator will show if the two passwords match. 

 

12. Click on the History tab to display the History dialog. This is where data stored in the HMI can be cleared. 

 

 This will not clear data stored on an SD card or USB flash drive. 

Clear Recipe  The HMI’s stored recipe data will be cleared when the Clear button is clicked. 
Clear Eventlog  The HMI’s stored event log data will be cleared when the Clear button is clicked. 
Clear Datalog  The HMI’s stored data log data will be cleared when the Clear button is clicked. 

 

13. Click on the HMI name tab to give the HMI a unique name. This name can be used to address the HMI for 
downloading over Ethernet. 
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14. Click the Firmware setting tab to access the Upgrade firmware option and the Portrait Mode settings (for 
models with the Portrait feature). 

 

Upgrade Firmware: Click this button to upgrade the firmware in the HMI from a USB flash drive or SD card. 
Portrait Mode: Select the orientation of the display on the HMI when a project is configured for Portrait 
Mode (selected when a new project is created). 

 

 

15. Click the VNC server setting tab to enable remote access using VNC (Virtual Network Computing). 
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Click Start VNC to enable the VNC server. 

Click the VNC login password to enter the password used to login to the HMI with a remote VNC viewer. The 
default password is 111111. 

Click Apply and then click OK to save the settings and exit the System Settings window. 

 The VNC server option in the System Parameters > System Settings tab will override the VNC login 
password in the HMI when Password from project is checked. 

 

 The HD Series does not support VNC. 

 

16. Click on the Misc(ellaneous) tab to display the Backlight dialog. The Brightness control adjusts the brightness 
of the HMI’s backlight. Use the mouse or touchscreen to roll the wheel. Rolling to the left decreases the 
brightness, rolling to the right increases the brightness. 

 System tags “Backlight Up (LB9040),” “Backlight Down (LB9041),” and “Backlight Index (LW9040)” can be 
used to adjust the brightness at runtime (range 0-31). 
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The Popup download window option allows you to turn on or off whether the Download dialog window 
appears on the screen when a USB flash drive is connected to the USB port on the HMI. The Restart after 
download/upload option causes the HMI to reboot after a download or upload from a USB flash drive or SD 
card, when selected. 

Viewing System Information 
 To view system information: 

1. Open the System Setup Toolbar as described above, and click the System Information icon. A dialog will be 
displayed with two tabs. 

2. Click on the Network tab to display the current IP settings. 

 

 

3. Click on the Version tab to display the current firmware information. 
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Transferring Projects and Data from USB/SD Card 
When a USB or SD device is inserted into the HMI5000P Series, a dialog is displayed. The same dialog is displayed for 
transferring projects or data. 

 Data is placed on the USB or SD device by EZwarePlus or Utility Manager. 

 

 

Download  Transfer data from the USB/SD to the HMI 
Upload  Transfer data from the HMI to the USB/SD 
Restart Project and exit  Close the dialog and restart the HMI 
Cancel  Close the dialog without transferring 
Time Remaining  The dialog will automatically close after 10 seconds if no selection  

 is made; shows the time remaining 
 

When Download is selected, a dialog will appear requesting the Download password and what data to download. 
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Password  Enter the Download password. 
Download project files  When checked, the HMI will check the specified folder for project data, and 

transfer it if it exists. 
Download history files  When checked, the HMI will check the specified folder for history data, and 

transfer it if it exists (includes data log files, event log files, and recipe files). 

Clear history files  When checked, clears all history files in the HMI (includes data log files, 
event log files, and recipe files). 

 

If a USB flash drive is being used to upload or download a project, select the folder under the usbdisk folder (if the 
project was saved on the root of the USB drive) and then click OK. If the project is in a folder on the USB drive, select 
the folder just above the MT8000 folder. 
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Changing or Restoring the HMI Settings by USB or SD 
There may be times when it is necessary to change or update the settings in an HMI, when the IP address or password 
of the HMI are unknown.  EZwarePlus provides a tool to create a system settings file, and transfer that file to the HMI.   

The following settings can be changed with the System Setting Editor: 

Password Local, Upload, Download, Upload History 

General HMI Name, Backlight Brightness, Time Offset (Time Zone Adjustment), 
Portrait Mode (0, 90, 180, 270 degree rotation) 

Network Use DHCP, IP Address, Subnet Mask, Gateway, DNS 

Clear History Recipe, Data Log, Event Log, Operation Log 

VNC Server Enable, Stop VNC, Stop VNC, Start VNC Single Connection, Start VNC Multiple Connection 

Download Popup Download Window, Restart After Download/Upload 

 

To open the System Settings Editor, use the Tools menu in EZwarePlus: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once all the settings are made, click the Export button to save the data to a file.   
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Then, from the EZwarePlus Tools menu, select Build Data for USB Disk or SD Card Download. 

 

1. Select the drive corresponding to the SD or USB device.  Note that the Save folder must be the root level of 
the SD or USB device (in this case, the root level of the F: drive). 

2. Check the Use System Setting box, and select the file exported above. 
3. Click the Build button to create the required data structure on the SD or USB device. 

 
 In this example, the ‘Use user-defined startup screen’ option is checked, but that is not required for 
configuring the System Settings. 
 
EZwarePlus will also create folders with the data for the project currently open in EZwarePlus.  Therefore, it 
is recommended that a very simple project be created in EZware prior to building the USB/SD data. 

4. Insert the SD or USB device into the HMI.  The following dialog will appear after a few seconds. 

 
5. Click the Load System Setting button.  The HMI will transfer the system settings from the SD/USB device. 

  The HMI will also load in the project from the SD/USB device, overwriting the project currently present on the 
HMI.  This is done to protect any intellectual property in the project currently residing on the HMI.   

 

 If Local Bit LB9063 is set in the HMI 
project, this dialog will not appear. 
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Chapter 3 – Connect the HMI to the PLC or Controller 
 
The HMI5000P/L family of HMIs can connect to one, two, or more PLC/controllers. This is accomplished via two 9-pin 
D-sub serial communications connectors (Port A and Port B) and one Ethernet port. Each PLC/Controller has its own 
wiring requirements. Maple Systems offers HMI-to-PLC/Controller communication cables for most PLC/Controllers 
that are built to any length and tested for high reliability. The HMI5000P/L family has three software controlled 
communications ports (COM1, COM3, and CAN bus) located on two physical connectors, designated as Port A and 
Port B. 

 The L and HD series do not support CANbus. 
 

 

Figure 1: COM Ports – Bottom View 

Each software controlled communications port can only be selected for one communication type. Once a 
communication type is selected for one of these software controlled ports, that port cannot be used for another 
communication type. Each of these communication ports has between one and three communication types. COM1 
can be RS232, RS485 4-Wire, or RS485 2-Wire. COM3 is either RS232 or RS485 2-Wire. The CAN bus port is strictly for 
CAN bus connections using the CANopen protocol. COM1 cables are readily available for purchase from Maple 
Systems. COM3 and CAN bus cables are custom-made according to wiring diagrams that can be found on Maple 
Systems' web site. Connecting multiple PLCs and controllers may require a splitter. 
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Figure 2a: COM Ports for the HMI5070P, HMI5121P, and HMI5150P 
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Figure 2b: COM Ports for the HMI5100L and HMI5070L 

HMI5100L 

HMI5070L 
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Figure 2c: COM Ports for the HMI5000HD 
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Connecting to COM1 and COM3 on Port A 
Maple Systems HMI5000P/L family of HMIs is capable of connecting to multiple PLC/controllers. If you choose to take 
advantage of this feature, and one of your PLC/controllers uses either RS485-4 Wire or RS485-2 Wire communication, 
one of two splitters will be needed. 

Scenario 1 – Two RS485 2 Wire PLC/Controllers, with COM1 configured for RS485-2 Wire and COM3 configured for 
RS485-2 Wire. 
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Scenario 2 – One RS485 2 Wire PLC/Controller with COM3 configured for RS485-2 Wire and one RS485 4 Wire 
PLC/Controller with COM1 configured for RS485-4 Wire. 
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Connecting to COM1 and COM3 on Port B 
 

Two RS232 PLC/Controllers, with COM1 and COM3 configured for RS232. 
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Connecting multiple PLC/controllers serially using daisy chaining 
The RS485 4-wire and RS485 2-wire communications ports of the HMI5000P/L/HD family support multi-drop 
connections. A daisy-chain connection is made from the HMI to the first PLC/controller, and then from the first 
PLC/controller to the second and so on (see below). The network may need biasing resistors – refer to the 
PLC/controller documentation for more information. 

 

 

 

 

 

 

 

 

 

 

 
 

Connecting one or more PLC/controllers via Ethernet 
The HMI5000P/L/HD Series have a single RJ45 Ethernet connector configured for 10BaseT and 100BaseT operation. 
This port is for both communicating with a PC for configuration purposes, as well as for communicating with 
supported Ethernet PLCs and protocols. 

The connector is wired just like the RJ45 Ethernet connector on a PC. The Ethernet connection to a PLC/controller will 
vary with each PLC/controller. Some will require a straight-through connection, while others require a crossover 
connection. See Maple Systems' website for cable drawings of Ethernet cables. 

To connect a single PLC/controller to an HMI: 

1. Attach one end of the Ethernet cable to the RJ45 connector on the HMI. 

2. Attach the other end to the RJ45 connector on the PLC/controller. 

A router or switch is required to connect multiple PLCs/controllers to a single HMI. In general, standard straight-
through type cables can be used when connecting to a PLC/controller through a router or switch. Some routers and 
switches may be auto-sensing. In this case, either type of cable may be used. 

 

  

HMI5000P/L/HD 

RS-485 

PLC  PLC  PLC       PLC 
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Troubleshooting 
The HMI must be connected to a PLC/controller in order for the project to run correctly in the HMI. If there is a 
problem with communications between the HMI and PLC/controller, the “PLC no response” message (window 5) will 
appear on the screen and objects addressing PLC registers will not appear on the screen. Here are some things to 
check if this occurs: 

1. Make sure you have selected the correct communication protocol (driver) for the PLC you are using in the 
System Parameters (Edit > System Parameters > Device Properties). 

 The demo version of EZwarePlus will not download the driver to the HMI and will automatically generate 
a “PLC no response” error message. 

2. Make sure the communication settings in the HMI (Edit > System Parameters > Device Properties) match the 
communication settings in the PLC. 

3. Make sure the communication cable is wired correctly for your application. Refer to the Controller Cable 
Assembly drawings on our website for specific cabling information for your PLC/controller. 
(http://www.maplesystems.com/cables1023.htm). 

4. Check the address formatting for objects that are reading from or writing to registers in the PLC. If the 
objects cannot access specific registers in the PLC, they will not appear on the screen. Refer to the Controller 
Information Sheet for your particular PLC/controller for specific information about accessible registers in the 
PLC memory and the correct addressing format for the various registers. 
(http://www.maplesystems.com/products/prodbycon-bot.htm) 
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Chapter 4 – Creating a Sample Project 
 
Often the best way to learn about new software is to jump right in and begin using it. This chapter will step you 
through the process of creating a sample project that can be downloaded to your HMI. In this sample project, we will 
create a bar graph with a tank shape that will represent the level of the fluid in the tank, and create a pump with a 
pipeline connected to the tank to indicate when the pump is operating to increase or decrease the level in the tank. 
 

Starting EZwarePlus 
Before you can create a sample project, you must start the configuration software. The EZwarePlus software has two 
main applications: 

• EZwarePlus – used to create the project downloaded to the HMI. 
• Utility Manager – used to place the HMI into different operating modes. 

To start Utility Manager and EZwarePlus: 
1. From the Windows Task Bar, click the Start button, select All Programs > Maple Systems > EZwarePlus > 

Utility Manager. 
2. On the Utility Manager dialog box, click EZwarePlus. 
3. The EZwarePlus dialog box appears. Click New and then OK.  
4. Select the HMI model that you intend to use with your project and whether you want to use the HMI in 

Landscape or Portrait mode. Select the Use template checkbox to open the project with the default template 
for your selected model. 

 

5. Click OK. The System Parameter Settings window opens next. Refer to the Help menu “How Do I… Set Up a 
PLC or Controller in EZwarePlus?” to configure the devices in the Device List. You may also jump ahead to 
“Chapter 6 – Using EZwarePlus” (System Parameter Settings on page 93). For now, we will not add any more 
devices to the Device List and we will use the default settings in the System Parameters. Click OK to accept 
the settings. 

Creating a Bargraph 
Window 10 is the default initial screen that EZwarePlus uses when a project is opened. Let’s create Window 11 to 
place the bar graph, and use a Function Key to change windows from window 10 to window 11. 

To create Window 11: 
1. From the Window menu, click Open Window. The Open Window dialog box appears. 
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2. Click New… The Select Window Style dialog box appears. 

 

3. Click Base Window. The Window Settings dialog box appears. 
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4. Type “Bargraph” in the Name field. The number 11 should already be in the Window No. field. 

5. Click the box for the Background color. The color palette box opens. Click on the white color box in the 
lower-right corner. The color box will reflect the color that you have selected. 

6. Click OK. Highlight Window 11: Bargraph in the Open Window list, then click the Open button. Window 11 
now appears on your work area. 

Now let’s create a function key to open Window 11 from the initial screen, Window 10. 

To create a Function Key: 
1. Click on Window 10 in the Windows Object List to open Window 10. 

2. In the top menu bar in EZwarePlus, click Objects > Button > Function Key (or select the Function Key icon in 
the Object 1 Toolbar). 

3. In the Function Key Properties General tab, select Change full-screen window and select 11. Bargraph in the 
Window no.: box. 

 

4. Click the Shape tab and select the Use Shape checkbox. Click the Shape Library button to open the Shape 
Library window. Click the Select Lib. button in the upper-right corner and browse to the arrow1.plb file and 
click Open. 
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5. Select shape number 7 and click OK. The Function Key Object’s Shape tab now shows a preview of how the 
function key will appear on the screen. Click OK. 

 

6. On the main screen of EZwarePlus you will see a white rectangle outline that is attached to your cursor in the 
work area. This represents the function key just created. Click to place the function key in the middle of 
Window 10. You can click and drag on the control buttons around the Function Key Object to resize it. 
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7. In the top menu bar in EZwarePlus, click Draw > Text (or select the Text Tool icon in the Draw Toolbar). In the 
New Text Object properties window, select Arial in the Font box and 16 pt in the Size box. Click the Color box 
and the color palette box opens. Click on the white color box in the lower-right corner. The color box will 
reflect the color that you have selected. 

8. In the Content box at the bottom of the properties window, type To next window and click OK. 

 

9. On the main screen of EZwarePlus you will see a white rectangle outline that is attached to your cursor in the 
work area. Click to place the text just below the function key in the middle of Window 10. You can click and 
drag it to center it beneath the function key. 
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Now let’s create a bar graph on Window 11. We will use the bar graph to indicate the level of a tank. We will create 
pushbuttons to increase or decrease the level of the tank by turning a pump on and off. 

To open Window 11, select Window > Open Window and double-click Window 11 in the list. Alternatively, double-
click on Window 11 in the Windows Option list on the left side of the EZwarePlus screen. 

To create a Bar graph: 
1. In the top menu bar in EZwarePlus, click Objects > Bar Graph (or select the Bargraph icon in the Object 2 

Toolbar). 

2. In the Bar Graph Properties General tab, select LW0 for the Read address. Leave the numeric format set to 
the default 16-bit unsigned. 
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3. Click the Outline tab. In the Attribute section, select the following: 

Type: Normal 
Direction: Up 
Zero: 0 (the register value represented when the bar graph is minimum) 
Span: 100 (the register value represented when the bar graph is maximum) 
Bar width ratio (%): 30 

 

4. In the Bar color/style section, click the Transparent checkbox. Leave the Bar and Bar style colors at their 
default blue. 

5. Leave the Target indicator Enable box unchecked. 

6. In the Alarm indicators section, select the following: 
Low limit: 25  
High limit: 85 
Low color: yellow (the bar graph color is yellow when the register value is below 25) 
High color: red (the bar graph color is red when the register value is above 85) 

7. Click the Shape tab. Leave the Use shape checkbox unchecked and click the Use picture checkbox. 
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8. Click the Picture Library… button and click the Select Lib… button. Locate tank.flb in the Library folder. Select 
it and click Open to add it to the list. 

 

9. Select picture number 16 and click OK. This is the picture that will appear over the bar graph on the screen. 

  1010-1015, Rev. 03 



36  EZwarePlus Programming Manual 

10. Click OK to accept the properties settings. On the main screen of EZwarePlus you will see a white rectangle 
outline that is attached to your cursor in the work area. Click to place the Bargraph Object in the middle of 
Window 11. You can click and drag it to adjust its position once you have placed it on the window. 

 

Next we will create a pushbutton to raise the level of the tank and another one to lower the level of the tank. This will 
use the Set Word Object to increment and decrement the value in LW0, the register that the bar graph is monitoring. 

To create a Set Word: 
1. In the top menu bar in EZwarePlus, click Objects > Button > Set Word (or select the Set Word icon in the 

Object 1 Toolbar). 

2. In the Set Word Object’s Properties General tab, you can enter a description of the object such as “Tank 
Level Up.” Select LW for the Device Type and 0 for the Write address. Leave the numeric format set to the 
default 16-bit unsigned. 
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3. In the Attribute section, select the following: 
Set Style: Press and hold increment (JOG++)  
     (this will cause the value in the register to increase while the button is pressed) 
Inc. value: 1 
Upper limit: 100 
JOG delay: 0.5 second(s) 
JOG speed: 0.1 second(s) 

4. Click the Shape tab. Click the Use Shape checkbox and click the Shape Library… button. Select the arrow1 
library. Select shape number 6 and click OK. 

 

11. A preview of the selected shape appears in the properties window.  
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12. Click OK and place the Set Word Object below the bargraph on Window 11 in EZwarePlus. You can click and 
drag it to adjust its position once you have placed it on the window. 

13. Click on the screen to deselect the Set Word Object, then double-click on it to reopen the properties (or 
right-click on it and select Attribute) and click the Profile tab (the Profile tab is not available when creating a 
new object). Set the Width and Height to 60 (pixels). 

 

14. Click OK to accept the new profile settings. 

 

15. Now we will create another Set Word Object to lower the level of the tank. Select the Set Word Object that 
we just created and copy it (Edit > Copy or Ctrl+C on the keyboard).  
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16. Paste the Set Word Object to the window (Edit > Paste or Ctrl+V) and drag it next to the other Set Word 
Object.  

 

17. Click on the screen to deselect it, then double-click on the new Set Word Object to open the Properties 
window (or right-click on it and select Attributes). 

 

18. In the Set Word Object’s Properties General tab, you can enter a description of the object such as Tank Level 
Down. Select LW for the Device Type and 0 for the Write address. Leave the numeric format set to the 
default 16-bit unsigned. 
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19. In the Attribute section, select the following: 
Set Style: Press and hold decrement (JOG--)  
     (this will cause the value in the register to decrease while the button is pressed) 
Dec. value: 1 
Bottom limit: 0 
JOG delay: 0.5 second(s) 
JOG speed: 0.1 second(s) 

20. Click the Shape tab. Click the Shape Library… button. Select the Arrows 1 library. Select shape number 8 and 
click OK. 

 

21. Click OK to accept the properties settings. 

 

Next we will create a Bit Lamp Object to represent a pump and another to represent a pipe connecting the pump to 
the tank. 
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To create a Bit Lamp: 
1. In the top menu bar in EZwarePlus, click Objects > Lamp > Bit Lamp (or select the Bit Lamp icon in the Object 

1 Toolbar). 

2. In the Bit Lamp Object’s Properties General tab, you can enter a description of the object such as Pump. 
Select LB for the Device Type and 0 for the Write address. 

 

3. In the Blinking section, select None for the Mode. 

4. Click the Shape tab and check the Use Picture checkbox (uncheck the Use Shape checkbox if it is selected). 

5. Click the Picture Library… button and select Pumps1 in the Library list. If it does not appear in the Library list 
on the left side of the Shape Library window, click the Select Lib… button and locate Pumps1.flb in the 
Library folder. Select it and click Open to add it to the list. Select shape number 5. Notice that it has four 
states associated with it. We will use the first two states, grey and green. Click OK and a preview of the pump 
will appear in the Properties window. 
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6. Click OK and place the Bit Lamp Object to the left of the tank. You can click and drag it to adjust its position 
once you have placed it on the window. 

7. Click on the screen to deselect the Bit Lamp Object, then double-click on it to reopen the properties (or right-
click on it and select Attribute) and click the Profile tab. Set the Width and Height to 50 (pixels). 

8. Click OK to accept the new Profile properties. 

 

9. Copy and paste the Bit Lamp Object (pump) to the same window and open the Properties window. Leave the 
read address set to LB0 and set the Blinking Mode to Alternating image on state 1 (Blinking time: 0.5 
seconds). 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  43 

10. Click the Shape tab. Click the Picture Library… button and select the Pipes Blue library (use the Select Lib… 
button if it doesn’t appear in the Library list). Select picture number 1 and click OK. 

 

11. Click the Profile tab and set the Width to 100 and the Height to 25 (pixels). 

12. Click OK to accept the properties. Click to place the Bit Lamp Object between the pump and the tank. You 
can click and drag it to adjust its position once you have placed it on the window. 

 

Now we will create a Set Bit Object to turn the pump and pipe on and off whenever the Up or Down Arrows (Set 
Word Objects) are pressed. 

To create a Set Bit: 
1. In the top menu bar in EZwarePlus, click Objects > Button > Set Bit (or select the Set Bit icon in the Object 1 

Toolbar). 

2. In the Set Bit Object’s Properties General tab, you can enter a description of the object such as Pump On. 
Select LB for the Device Type and 0 for the Write address. Select Momentary for the Set Style. 
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3. Click the Shape tab and deselect the Use Shape checkbox. This will make the Set Bit invisible on the screen. 
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4. Click OK and place the Set Bit Object on the window. It will appear as a square frame. Click on the screen to 
deselect it, then double-click on it to reopen the properties (or right-click on it and select Attribute). Click the 
Profile tab and set the Width and Height to 65 (pixels). Click OK to accept the new Profile settings. 

5. Move the Set Bit Object over the Arrow Up button. 

6. Copy and paste the Set Bit Object and place the second one over the Arrow Down button. When the Up or 
Down buttons are pressed, the pump and pipe will change states to indicate that they are on.  

 

Finishing Up 
There are still a few more steps to finish your first project. In this section, you will: 

• save the project onto your computer hard drive 

• compile the project into a format that can be understood by the HMI 

• run the offline simulator to test the project 

• download the project to the HMI 

• verify that the HMI operates as expected 

• exit the EZwarePlus software 

Saving your first project 
1. From the File menu, click Save As. The Save As dialog box appears. 

 

2. Use the drop-down menus to locate the project folder in EZwarePlus. 
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3. In the File name text box, type Sample_Project.mtp. 

4. Click Save. The file is saved onto your computer hard drive and the main screen of EZwarePlus reappears. 

Compiling your first project 
1. From the Tools menu, click Compile. The Compiling dialog box appears. 

 

2. Click the Compile button. EZwarePlus will compile your project and display error results. 

3. If no errors occur, click Close. The main screen of EZwarePlus reappears. If errors have occurred, repeat the 
steps in the “Creating a Sample Project” section. 

Simulating your first project 
1. Click Tools in the top menu bar and select Off-line Simulation (Ctrl+T) or click the Off-line Simulation icon in 

the Project Toolbar. The Simulation Window will appear on the screen. 

 

2. Click the arrow button to go to the next window. 
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3. Click and hold the arrow UP button to fill the tank. The pump turns green and the pipe starts blinking. The 
bar graph is yellow when the tank begins to fill and turns blue when it fills more than 25%. 

 

4. When the tank fills above 85% the bar graph turns red.  

 

5. Click and hold the arrow DOWN button to lower the tank level. 

6. Right-click in the simulation window and select Exit simulation. 
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Downloading your first project 
First, connect a +24 VDC power supply to the HMI. Refer to the HMI5000P/L/HD Installation Guide for more 
information.  

In order to download your project, you must first connect the HMI to your computer. There are two methods of 
downloading to the HMI, Ethernet or USB. 

Configuration Wiring 

Ethernet Crossover Configuration Cable: P/N 7431-0104 
USB Configuration Cable: P/N 7431-0115 

Ethernet 

It is necessary to determine the IP Address of the HMI. By default, the HMI is configured to get a dynamic IP address 
from a DHCP server. This setting can be changed. To determine or change the HMI’s IP address: 

1. Connect the HMI to your computer using an Ethernet crossover cable (7431-0104). 

2. Touch the arrow in the lower right corner of the HMI screen. A menu bar will appear. Touch the gear icon on 
the menu bar. 

3. Enter the System Settings password (default password is 111111). 

4. On the Network tab of the System Settings dialog, the HMI’s IP address will be shown. If set for Obtain an IP 
Address Automatically, the HMI’s current IP setup information is displayed but is not changeable. To change 
the IP address, select IP Address Get From Below and enter the data. 

5. Once the IP Address has been established, the project can be downloaded. Select Tools > Download from 
the EZwarePlus menu (or click the Download icon). 

6. Enter the HMI’s IP address (or optionally the HMI name). The default download password is 111111.  
Note: The computer’s Ethernet port IP address should have the same Subnet Mask as the HMI’s IP address, 
usually 255.255.255.0. Therefore, the first three octets of the IP address should be the same for both 
devices. 

7. Make sure that the Ethernet, Firmware, and Reboot HMI After Download boxes are checked. 

8. Click the Download button. If the HMI is properly connected to the PC, the status box on the download 
dialog will update with messages indicating the progress of the transfer. The HMI itself will also display 
messages reflecting its status. 

9. When the download is complete, the HMI will restart and will begin running your project. Click the Exit 
button on the Download dialog. 

USB (HMI5070P, 5121P, 5150P Only) 

1. Make sure the USB driver has been installed on your computer. See the Help menu “How Do I…Install the 
Maple Systems USB Driver” for more information. 

2. Connect the HMI to your computer using the USB configuration cable (PN 7431-0115).  

3. Select Tools > Download from the EZwarePlus menu (or click the Download icon). 

4. Make sure that the USB, Firmware, and Reboot HMI After Download boxes are checked. 
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5. Click the Download button. If the HMI is properly connected to the PC, the status box on the download 
dialog will update with messages indicating the progress of the transfer. The HMI itself will also display 
messages reflecting its status. 

6. When the download is complete, the HMI will restart and begin running your project. Click the Exit button on 
the Download dialog. 

Note: When connecting two powered devices, a difference in potential can exist between the ground reference 
on each device. If there is a large difference in ground potential (voltage), making a connection via a USB cable 
can complete a ground loop that may damage the HMI and PC. The connectors on the Maple Systems USB 
Configuration Cable (P/N 7431-0115) are electrically isolated to prevent a potentially damaging ground loop, and 
we recommend using this cable to connect the HMI to the PC. Maple Systems cannot be held responsible for any 
damage to the HMI, PLC, or PC due to improper wiring. Please refer to page 5 of the HMI5000 Series Installation Guide for 
proper wiring instructions. 

 

CONGRATULATIONS. You have completed your first EZwarePlus project. Select File > Exit to close EZwarePlus. 
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Chapter 5 – Simulator Mode 
 
As you saw from creating the sample project in the last chapter, downloading any changes you make to the HMI can 
take time. To decrease the amount of time required to download a project to the HMI, you can uncheck the Firmware 
option on the EZwarePlus download dialog after you have downloaded it once. 

A better way of testing changes made to a project is to use the computer to simulate the operation of the HMI. 

This chapter shows you how to dramatically save time when creating and testing a project by putting the computer 
into Simulation Mode. In Simulation Mode, the computer displays a screen that simulates what is seen when the HMI 
executes the project file. You can use the mouse on your computer to simulate the operation of the touchscreen on 
the HMI. Rather than waiting for the download to test each change you make to your project, you can now instantly 
switch to Simulation Mode to see if your project is working as expected. 

You can enter Simulation Mode from EZwarePlus or from the Utility Manager. 

The Simulation Screen 
All modes of simulation use the same screen.  

 

For our example, we are showing the sample project as it would appear after the “To next window” function key has 
been pressed. When the Simulation Mode screen first appears, it will always show the startup screen of the project. 
You can test any objects you have created which require touchscreen input by clicking on them. In this example, 
clicking on the increment key simulates the key as it is pressed on the touchscreen. Simulation Mode always uses the 
compiled version of the project that you have created (the *.xob file). Therefore, you must save and compile any 
changes you make to the project before you can simulate it. 

Simulating the HMI is done in on-line or off-line mode. 
On-line simulation is most useful when a project is near completion and you need to test the interaction of the 
project with the PLC. It is also very convenient when making minor changes to a project because these changes can be 
instantly checked for operation. 

Off-line simulation does not require any connection to the HMI. Because of this, off-line simulation is most often used 
when starting a project. You can quickly test new ideas and create preliminary screens without the HMI. 

Off-line simulation is also great for demonstrating the operation of the HMI and becoming familiar with the operation 
of the HMI before it is installed. If you want to simulate the interaction with a PLC when off-line, it can be done by 
creating additional windows on the HMI which allow PLC data input. 
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To use off-line simulation mode from EZwarePlus: 
1. If the project has been modified since the last time it was saved and compiled, or if it has not yet been 

compiled, it must be saved and compiled before the simulator can start. 

2. Select Tools > Off-line Simulation from the top menu bar (or click the Off-line Simulation icon in the Project 

toolbar ). 

3. The Simulation Mode screen will appear. 

4. To end off-line simulation, right-click in the simulation screen and click Exit simulation. 

Simulation mode can also be started from the Utility Manager. Utility Manager requires only the compiled project file 
(*.xob). This can be useful in situations in which you want to demonstrate changes made to a project for a client 
without giving him access to your project file. It also allows you to rapidly switch from simulating one project to 
another without having to open, save, and compile each project. 

To use off-line simulation mode from Utility Manager 
1. Start the Utility Manager software. 

2. Click Offline-Simulator. The Open Project box appears. 

3. Click on the compiled project file that you wish to simulate. 

4. Click Open. The simulation screen will appear. 

5. To end off-line simulation, right click in the simulation screen and click Exit. 

Online simulation requires a direct connection between the PC and the controller. It is not necessary to have the HMI 
connected. 

The HMI’s COM1 RS232 connection is wired the same as a standard PC 9-pin serial connector. Therefore, the standard 
Maple Systems’ COM1 RS232 cable for the selected PLC/controller can be used with online simulation. Connect the 
cable end marked "HMI" to the PC’s serial port, and connect the other end to the PLC/controller. 

To use on-line simulation mode from EZwarePlus 
1. If the project has been modified since the last time it was saved and compiled, or if it has not yet been 

compiled, it must be saved and compiled before the simulator can start. 

2. Select Tools > On-line Simulation from the top menu bar (or click the On-line Simulation icon in the Project 

toolbar ). 

3. The Simulation Mode screen will appear. 

4. To end on-line simulation, right-click in the simulation screen and click Exit simulation. 

To use on-line simulation mode from Utility Manager 
1. Start the Utility Manager software. 

2. Click Online-Simulator. The Open Project dialog box appears. 

3. Click on the compiled project file that you wish to simulate. 

4. Click Open. The simulation screen appears. 

5. To end on-line simulation, right click in the simulation screen and click Exit. 
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 The above method will work with a standard PC serial COM port, regardless of the COM number assigned to 
the PC serial port. EZwarePlus supports RS232 communication on ports COM1 – COM9. COM4 and higher are 
intended for use with online simulation only, since the HMI5000P itself only supports RS232 communication 
on COM1 – COM3.  The L and HD Series support RS232 on COM1 only. 

 If simulating with RS422 or RS485 communication, the PC will require some mechanism to support 
RS422/485. A communication card can be installed in the PC, a USB communications module can be used, or 
an external RS232-to-RS485 converter can be used. In any case, a standard Maple Systems cable may not 
work. 

If simulating a project using Ethernet communications, an Ethernet cable between the PC and the PLC/controller is 
needed. Consult the PLC/controller documentation for details. 

To use EasySimulator 
Online or offline simulation can be initiated without having to open EZwarePlus or Utility Manager by using 
EasySimulator. EasySimulator is located in the same folder as EZwarePlus and Utility Manager 
(C:\MapleSystems\EZPlus\EasySimulator.exe). If you have installed the EZwarePlus Downloader, it is located at 
C:\MapleSystems\EZPlusUtil\EasySimulator.exe. 

When EasySimulator starts, it reads the file “XOB_POS.def,” which is also located in the same folder as EasySimulator. 
This definition file determines whether to run offline or online simulation, the location of the com.exe and gui.exe 
files, and the location and name of the *.xob file to simulate. The following are the default settings for the 
XOB_POS.def file: 

// mode – 0: offline, 1: online 
“0” 

// directory containing com.exe and gui.exe 
“c:\MapleSystems\EZPlusUtil” 

// xob file 
“c:\MapleSystems\EZPlusUtil\HMI5121PDemo.xob” 

Edit the XOB_POS.def file in a text editor such as Notepad. See Technical Note 5053, “Using EasySimulator” for more 
information. 

Now that you are familiar with using simulation mode, the next chapter guides you through the fundamental 
operation of three primary segments of the EZwarePlus configuration software. 
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Chapter 6 – Using EZwarePlus 

Overview 
The EZwarePlus software is composed of a number of separate applications that are accessible from the 
EZPlus folder, including EZwarePlus, Utility Manager, and EasyConverter. EZwarePlus is the application 
software used to create a project file. Utility Manager is a utility application that puts the HMI into different 
operating modes. EasyConverter changes certain binary files created by the HMI into text files. 

By the end of this chapter, you should be quite familiar with the operation of EZwarePlus and Utility Manager 
and be able to maneuver around the EZwarePlus programming software easily. 

 EZwarePlus includes extensive online help. From any dialog box within the software, click on the HELP 
button, or press the computer's F1 key. 

 Projects created in EasyBuilder-5000 can be opened in EZwarePlus. The System Parameters window 
will open on the Model tab so you can reassign the project to an HMI5000P/L model. If the screen 
size of the selected HMI5000P/L model is different from the original project, the Resize pop-up 
windows/objects dialog will open with options for resizing objects in the project. 

 Projects created in EasyBuilder-500 can be converted to EZwarePlus using the Translate HMI500 
Project selection under the Tools menu. 

The Utility Manager 
The Utility Manager is a launching pad for a number of EZware applications. 
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The applications are divided into groups: 

Design 

• EZwarePlus: create projects for the HMI 
• EasyAddressViewer: examine supported addresses and devices for the PLC and controller 

communications drivers provided with EasyBuilder. 
• Simulation: run a compiled EasyBuilder project without transferring to an HMI. 

Analysis & Testing: 

• EasyDiagnoser: Connect to an HMI via Ethernet, and monitor/debug communications to an HMI. 
• EasyWatch: Monitors data in the PLC and HMI, displayed in a spreadsheet-style arrangement. 
• Reboot: reboot the HMI connected to the PC by Ethernet or USB. 
• Pass-Through: allows PC applications to communicate to the PLC through the HMI. 

Publish: 

• Download: transfer a compiled EasyBuilder project, as well as firmware, startup screen image, recipe, 
and data log files to the HMI. 

• Upload: transfer a compiled EasyBuilder project, as well as firmware, startup screen image, recipe, 
and data log files from the HMI. 

• Build a data structure on an SD or USB device for direct transfer to the HMI. 

Maintenance: 

• EasyPrinter: runs on a PC so that data can be sent to the PC from the HMI over an Ethernet 
connection. 

• Administrator Tools: put user account and email data on an SD or USB device for direct transfer to an 
HMI. 

• EasyAccess: allow remote access to the HMI from anywhere that has internet access. 
• Data/Event Log Information: display information about the size and quantity of Data and Event log 

files on the HMI. 

Data Conversion: 

• Recipe Database Editor: edit a recipe database without modifying the HMI project itself. 
• EasyConverter: convert binary data and event log files to CSV format. 
• Recipe Editor: edit recipe data stored in RW and RW_A memory. 

To access Utility Manager, click on the Windows Start button and select All Programs >Maple Systems > 
EZPlus > Utility Manager. 

Many of the applications launched by the Utility Manager are self-contained and have their own 
documentation.  Some of the applications are discussed below. 
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Utility 

Easy Converter 
The EasyConverter application is used to view data log files (*.dtl) and event log files (*.evt) that are created 
by the HMI during operation. Data log files are files the HMI creates when capturing data using the Data 
Sampling object. Event log files are history files the HMI creates when using the Event (Alarm) Log object. Both 
files are in binary format to minimize the amount of file space required. 

To view these files with a computer, you must use the EasyConverter application. In addition, EasyConverter 
can take a data or event log file and convert it into a CSV (Comma Separated Value) file that can be easily 
imported into other applications such as Microsoft Excel. For more information on how to do data logging, see 
Chapter 11 “Data Sampling and Trend Displays.” For more information on how to use Event Log files, see 
Chapter 12 “Capturing Alarms and Events” section “Monitoring Alarms with the Event (Alarm) Log.” 

 

To start the EasyConverter Application   

1. Click the EasyConverter button in the Utility Manager window or click the EasyConverter icon in the 
Project Toolbar. The EasyConverter application appears. 

 

2. Click File > Open to display the Open dialog box. Search for the data log file (*.dtl) or event log file 
(*.evt) that you wish to view, then click the Open button. 

Please Note: 
These files are captured by the HMI and stored in internal HMI memory, an attached SD card, or USB flash 
drive. You must copy these files into your computer before using the EasyConverter utility. If you are running a 
project that is capturing data log or event log files using the Offline Simulator, the EZwarePlus application 
automatically creates new folders on your computer and creates the files 
(C:\\MapleSystems\EZPlus\HMI_memory). 

Data log files are stored in a folder using the name that you assigned in the Data Sampling Object attribute box 
(e.g., C:\\MapleSystems\EZPlus\HMI_memory\datalog\History Data1\20100618.dtl) 

Event log files are stored in an eventlog folder (e.g., C:\\MapleSystems\EZPlus\eventlog\EL_20100625.evt). 

Viewing an Event Log File (*.evt) 

1. From the EasyConverter application, click File… Open and locate the Event Log file (*.evt). 
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2.  “Event”: This column indicates the following: 0 = Event triggered; 1 = Event acknowledged; 2 = Event 
returns to normal. 
“Category”: Indicates the event category. 
“Date”: Indicates the date of the event (YYYY/MM/DD). 
“Time”: Indicates the time of the event (HH:MM:SS) 
“Message”: Indicates the Event/Alarm message. 

 This is read only – the EasyConverter application does not allow any edits. 

Viewing a Data Log File (*.dtl) 

1. From the EasyConverter application, click File…Open and locate  
the Data Log file (*.dtl). As the file is loaded,  
the following popup window appears: 
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Sampling Data Information: This shows the type and number of data samples contained in the data file. 
You can select the number of digits after the decimal point to display and whether or not millisecond 
information is displayed. 

2. In addition, there is a scaling option that can apply linear scaling to the data before it is displayed. 
For this example, we have elected to use the linear scaling formula on Data No 1 to convert the raw 
data (which is measuring temperature in °F) to °C. 
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3. Also, the raw data collected for Data 4 is a floating point number calculated to three decimal places. 
However, we are only concerned with a two decimal accuracy, so we change the ‘Digits’ field from 3 
to 2. If we want to use these same changes on other files, click the Save Setting… button to save the 
changes as a conversion file (*.lgs). When opening other data log files, we can apply the same 
changes by clicking on the Load Setting… button and selecting the proper conversion file. 

4. Click OK to continue. The data log file is shown: 
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5. The data shown includes the Date (YYYY/MM/DD), Time (HH:MM:SS), Milliseconds, and the actual 
data for each register sampled. In our example, notice that the value for Data 1 has been converted 
to °C and the value for Data 4 has two decimal places instead of three. 

 This is read only – the EasyConverter application does not allow any edits. 

Saving a Data/Event Log File as a CSV or XLS file  

After opening a Data/Event Log file in EasyConverter, you can easily save the file as a CSV or XLS file. 

1. Click File > Save As… or click the Save As icon. The Save As dialog opens. 

2. Click the Save as type: drop-down box and select either Text files (*.csv) or Excel files (*.xls).  
By default, the new file is saved in the same folder as the original file, but you can navigate to a 
different folder by clicking the Save in box at the top. 

Exporting a Data/Event Log File as an XLS file to Excel  

After opening a Data/Event Log file in EasyConverter, you can export the file as a XLS file and open it directly in 
Microsoft Excel.  
 Microsoft Excel is required to convert the file when exporting to Excel. 

1. Click File > Export to Excel or click on the Excel icon. 

2. Microsoft Excel opens and you should see the data in a spreadsheet format. Simply click File…Save As 
to save the file. 

Converting Multiple Files  

EasyConverter also has a feature that allows you to select multiple Data/Event Log files and save them to one 
XLS file.  

1. Click File > Multi-File or click on the Multi-File icon. 

 

2. Click Add File…, then select which Data/Event Log files you wish to combine. 
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3. Enable Setting file: Check this box to select a conversion (*.lgs) file that performs a linear scaling 
conversion or decimal point conversion on the selected files. 

4. Combine to a file: Check this box to combine the files and save them into an Excel spreadsheet. Click 

the browse button  to select the location and filename where you want to save the combined XLS 
file. Click OK to save the file. 

EasyPrinter 
The Easy Printer button allows monitoring of the print server through Utility Manager. The EasyPrinter utility 
must be running on the PC that is hosting the networked printer from which you wish the HMI5000P Series to 
print. 

The printer is set up on the Printer/Backup Server tab in the EZwarePlus Systems Parameters. Select the Use 
Remote Printer/Backup Server checkbox to enable remote screen printing and backup of datalog file (*.dtl). 

 

File Menu 

Enable Output: Enable the printer. If not enabled, nothing will be sent to the printer. 
Exit: Terminates the EasyPrinter utility. If EasyPrinter is terminated, the HMI cannot send data to the 
printer. 

Edit Menu 

Edit: Edit the selected print job. 
Delete: Delete the selected print job. 
Select All: Select all print jobs. 

View Menu 

The Jobs area is always displayed and indicates the source of the data, the operation being performed, and 
the status of the job. 

Properties Bar: Displays the properties of the selected print job. 
Preview Bar: Displays an image of the data being sent to the printer. 
Download Bar: Displays the status of the data being transferred from the HMI, not the status of the 
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data being sent to the printer. 
Logger Bar: Displays the status of the EasyPrinter utility. 

 

 

Options Menu  

Toolbars: Provides the option of turning on and off the Standard toolbar and the View toolbar. 
Status bar: Provides the option of turning on and off the Status bar at the bottom of the EasyPrinter 
window. 
 Settings: The Settings window is used to configure the operation of EasyPrinter. 
 The Output must be disabled before the Settings option is enabled. 

General 

Port Number of the Server Socket: Specify the IP Port number to use. This must match the Port 
setting on the Printer Server tab in the EZwarePlus System Parameters dialog. 

User Name: Specify a User Name. This must match the User Name setting on the Printer Server tab in 
the EZwarePlus System Parameters dialog. 

Password: Specify a Password. This must match the Password setting on the Printer Server tab in the 
EZwarePlus System Parameters dialog. 

Naming Convention for HMI Folder (when writing files): Select Use IP address to create a folder 
named with the IP address of the HMI. Select Use HMI name to create a folder using the HMI name 
assigned in the Data Sampling Object’s Folder name, which is used to save history data files. The 
folder name is stored in LW9032-LW9039. 

Prefix: Optional prefix to append to the folder name defined above. For example, if Use IP address is 
selected for the naming convention, the IP address of the HMI is 192.168.1.211, and IP_ is entered in 
the Prefix box, the folder will be named IP_192.168.1.211. 

Minimize to System Tray: If checked, the minimized EasyPrinter utility will appear in the System Tray. 
If unchecked, the utility will be minimized to the Task Bar. 

Detailed Message: If checked, detailed messages will be written to the Logger window. If unchecked, 
general messages will be written to the Logger window. 

Hardcopy 

Print Out To: When checked, specifies the printer or device to send the data to. The drop-down list 
will be populated with devices available on the PC. 

Save to files in: When checked, saves a *.bmp file of the screen print to the designated folder on the 
computer. 

Backup 

Backup files in: Specifies the location on the computer to save the data file 
(C:\MapleSystems\EZ5000\BackupData is the default). 
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When target file has existed: When Overwrite it is checked, the existing file will be overwritten by 
the new file. When Append.BAK to the file name is checked, the existing file will have .BAK appended 
to the filename so it will be preserved. 

Convert Batch File: When enabled, defines the path to the definition file used to convert the data file 
to CSV file format (C:\MapleSystems\EZPlus\convert2csv.def is the default). 

 

 

 

EasyAddressViewer 
Starts the Easy Address Viewer application for viewing the device types and memory ranges for the selected 
communications driver. 

EasyDiagnoser 
Opens the EasyDiagnoser utility, which connects to the HMI over Ethernet and monitors the read/write 
commands between the HMI and the PLC and help resolve communication errors. See “Chapter 17 – 
EasyDiagnoser and Easy Watch” for more information. 

Recipe/Extended Memory Editor 
The Recipe/Extended Memory Editor is an application that allows you to create, view, and modify recipe 
(*.rcp) files and Extended Memory (*.emi) files. You can also use this editor to import/export recipe and 
extended memory files to CSV formatted files, which can then be shared by other applications. 

 EZwarePlus has a new way of implementing recipes in addition to the method described here. With the 
new implementation, recipe data is stored in a database file and can be edited in the Database Editor or 
directly on the HMI screen. See “Chapter 15 – Recipes” for more information. 

To create a new Recipe/Extended Memory file: 

From the Project Manager application, click Recipe/Extended Memory Editor: 

 

1. Click File > New. The following dialog box appears: 
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2. Address range (unit: word): Use this area to select the total number of RW (recipe word) registers or 
EMx (Extended Memory) registers that are used for the recipe or extended memory file. In the 
example above, RW0 thru RW100 will be used. 

3. Select your data format: Use this area to enter how each data register element is interpreted by the 
HMI. The data collected and stored in recipe/extended memory files is in binary format and does not 
contain any information about how each data should be interpreted by the HMI (for example, is the 
data in 16-bit signed integer format or BCD?). Therefore, the data format is used to define how each 
data element is formatted (i.e., Signed vs. Unsigned, 16-bit vs. 32-bit, Float, String, etc.). 

a. Add: Click to add a new data register format. The following dialog box appears: 
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In the Data Type dialog box you can enter a description of the Data Type and select which format that 
the HMI will use to interpret the data. 

 For String format, you must enter the total number of 16-bit register words used for the character 
string. 

b. Delete: If you wish to delete an item from the list, highlight a data element and click Delete 
to remove from list.  

c. Clear All: Click to erase entire list of data elements. 

d. Modify: Highlight a data element and click Modify to revise the name of the data element or 
format. 

2. Select your data format: Use to select or create a data format template that can be used for other 
recipes or extended memory files. In the example above, the data elements configured in the Data 
format list have been saved to a template called ‘Example’. Click OK. 

 
3. A table of data elements appears that shows the recipe or extended memory table. 

 

4. This table has several columns with headers: 

a. ID: This is the ID number for each record. 

b. ADDRESS: This is the starting RW address or EMx address for each record. 

c. Data headers: These are the descriptions used for each data element created in the step 
above. 

5. Edit the table by clicking on each data element field and entering the preset value. Please note that 
you are only allowed to enter data according to the format defined for each data element. 

6. Here is an example of a completed table: 

 

7. Click File > Save with the following options: 

a. Save file as *.rcp for recipes. 
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b. Save file as *.emi for extended memory files.  
 You must use file names which correspond to the ten extended memory areas 
preconfigured in the HMI (ex. em0.emi, em1.emi, …, em9.emi). 

c. Save file as *.csv to open the file in applications such as Microsoft Excel. 

8. Once the file is saved, you can copy the recipe file to your HMI by: 

a. Procedure 1-- Downloading the file using the Utility Manager: 

i. With the computer connected to your HMI, click Download. 

ii. On the Download dialog box, check the RW enable box, then select the recipe file.  

 

b. Procedure 2 -- Downloading using a SD card or USB Flash Drive: 

i. Attach an SD card or USB Flash Drive to your computer. 

ii. In Project Manager, click Build Download Data for SD/USB Disk button. 

 

iii. Select the folder to save download data. Enter the SD card or USB Flash drive 
location.  
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iv. Check the Recipe (RW) enable box, then select the recipe file. 

v. Click the Build button. A folder called ‘mt8000’ is created on the root directory of 
your drive.  

vi. Remove the SD or USB drive and connect it to your HMI. 
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Build Download Data for SD/USB Disk 

 

Data can be downloaded to the HMI5000P Series using an SD card and USB flash drive. The Build Download 
Data function builds the data files to do this. 

To build download data for SD card or USB flash drive: 

1. Start Utility Manager. 

2. Click Build Download Data for SD/USB Disk… The Utility Manager dialog appears. 

3. Insert SD card or USB flash drive into PC. Note the drive that represents the SD/USB device. 

4. Click Browse... next to Select the folder to save download data: to select the drive that represents 
the SD/USB device. 

5. Check the boxes that will be the sources for your data and browse to the appropriate file for that 
source. Click Build. 

 The L Series do not support SD cards. 
 

Download 
Sends a compiled project file stored on the computer to the HMI. 

Upload 
Receives a compiled project file from the HMI to be stored on the computer. 

Simulation Settings 

On-line Simulation 
Opens a compiled project (*.xob) in on-line simulator mode. 

Off-line Simulation 
Opens a compiled project (*.xob) in off-line simulator mode.  
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Pass-through mode 
The pass-through mode allows serial communications from the PC to the PLC, though the HMI. This can 
eliminate the need to disconnect the PLC from the HMI when it is necessary to configure the HMI. 

 

 Pass-through mode is only available on HMIs with an Ethernet port. An Ethernet 
connection from the PC to the HMI is required to initiate pass-through mode, even 
when using serial pass-through mode. 

 

To use the serial pass-through mode: 

 

1. Select COM port. In the serial pass-through mode, data coming in on one serial port on the HMI is re-
transmitted out another serial port to the PLC. 

2. HMI/IP: If the HMI has an Ethernet port, Utility Manager can query the HMI to get its communication 
parameters through the Ethernet port. Specify the IP Address of the HMI that is to be used in pass-
through mode and click Get HMI Communication Parameters to read the current communication 
settings for the HMI (if the HMI is connected directly to the PC’s Ethernet port, you must use a 
crossover Ethernet cable). 
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3. HMI work mode: Indicates the current mode of the HMI. After the communication parameters have 
been received, the mode will be either Normal (HMI set to communicate with PLC) or Pass-through 
(HMI is in pass-through mode). 

4. Source COM Port (PC -> HMI): Set COM settings for the HMI COM port that will be connected to the 
PC. 

5. Destination COM Port (HMI -> PLC): Set COM settings for the HMI COM port that will be connected 
to the PLC. 

6. Click Start Pass-through to begin pass-through communication and Stop Pass-through to end. Click 
Exit to exit pass-through mode. 

 When the HMI is in serial pass-through mode, the HMI suspends communications with the PLC and 
the application in the HMI does not run. 

To use the Ethernet pass-through mode: 

 

In the Ethernet pass-through mode, the HMI acts as an Ethernet-to-Serial bridge. A virtual COM port driver is 
installed on the PC (in this example, COM3), which provides the connection between EZwarePlus (or the PLC 
programming software) and the Ethernet port connected to the HMI. The virtual COM port uses the next 
available port on the PC.  
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1. Click Install to install the virtual COM port driver. The Virtual COM Port (PC <-> PLC) indicates the 
virtual COM port used on the PC.  
 To change to another port, use the COM ports section of Device Manager on the PC. 

2. PLC Connection Port (HMI <-> PLC): 
For most PLCs, set the mode to Normal.  Some Siemens PLCs will use MPI ISOTCP; 
Enter the IP address of the HMI; 
Select the TCP Port to use.  This must the same setting as the Pass-Through Port Number set in the 
EasyBuilder project, on the Model tab of the System Parameters dialog; 
Set the COM port on the HMI connected to the PLC. 

3. Click Apply to accept the settings. 

4. Click Stop Pass-through to end. 

5. Click Uninstall to uninstall the virtual COM port driver on the PC. 

 The HMI must be powered and connected to the PC or Windows will not recognize the virtual port 
as an available serial port. 
 When the HMI is in Ethernet pass-through mode, the HMI suspends communications with the PLC 
and the application in the HMI does not run.  

 Refer to Technical Note TN5047 for more information on “Using the Pass-Through Mode.” 
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EZwarePlus Features 
This section guides you in a basic understanding of the features and capabilities that EZwarePlus has to offer, 
from an overview of all the objects available in the software to enter and display data, to setting up the 
system parameters and selecting the target PLC. This information will be useful for understanding more 
advanced features explained in later chapters. 

 

EZwarePlus Development Window 

Objects Summary 
EZwarePlus includes several active graphics objects that are used to represent data that is stored in the PLC or 
internal memory of the HMI. The data represented can be single bit coils, 16-bit, or 32-bit registers. The data 
can be represented as numbers, ASCII characters, or as graphic shapes or bitmap images. This section provides 
a summary of all the objects available in EZwarePlus. Most of these objects are accessible by clicking Objects 
in the top menu in EZwarePlus, or by clicking on its icon in the Object 1 or Object 2 Toolbar. 

Refer to the Help file (Help > Contents > Parts List) for more information relating to each object. 

Bit Lamp  

The Bit Lamp Object is used as an indicator to represent the ON or OFF status of a bit or coil in the PLC, or a bit 
in the HMI local memory (LB). If the bit is cleared (0, False), the State 0 Shape of the Bit Lamp will be displayed. 
If the bit is set (1, True), the State 1 Shape of the Bit Lamp will be displayed. The Bit Lamp can also blink in 
various ways. 

Word Lamp  

The Word Lamp Object is used as an indicator to represent the value in a PLC register, or the value in a register 
in the HMI local memory (LW). Creates a graphics object to reflect the current state of a multi-state PLC data 
register. It can display a different shape or picture depending on the value in the register. If the value is 0, the 
first shape is displayed, if the value is 1, the second shape is displayed, etc. A Word Lamp can display up to 256 
different shapes and text strings, corresponding to register values of 0 – 255. 
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Set Bit  

The Set Bit Object is used as a button to toggle ON or OFF the state of a bit or coil in the PLC, or a bit in the 
HMI local memory (LB). There are a number of different options (Set Styles) available to operate the button 
including touch (On, Off, Toggle, Momentary), window open or closed, and backlight on or off. 

Set Word  

The Set Word Object is used as a button to change the value in a PLC register, or the value in a register in the 
HMI local memory (LW). There are a number of different options (Set Styles) available to operate the button 
including touch (Write a constant value, increment or decrement), window open or closed, backlight on or off, 
and periodic bounce or jog. 

Toggle Switch  

The Toggle Switch Object is a combination of the Bit Lamp and Set Bit objects. It is used as a button to toggle 
ON or OFF the state of a bit or coil (specified by the Write Address), and as an indicator to represent the ON or 
OFF status of a bit or coil (specified by the Read Address) in a PLC register or HMI local memory. It can be 
configured with various Switch Styles including Set On , Set Off, Toggle, or Momentary. 

Multi-State Switch  

The Multi-State Switch Object is a combination of the Word Lamp and Set Word objects. It is used as a button 
to change the value of a register (specified by the Write Address), and as an indicator to represent the value in 
a register (specified by the Read Address). A Multi-State Switch can display up to 256 different shapes and text 
strings, corresponding to register values of 0 – 255. 

Option List  

The Option List Object provides a way to display a list of names corresponding to values in a register (Monitor 
address). The Source of item data selection determines how the Option List operates. 

Predefine: The Option List displays a list of items where the item displayed or selected (configured on the 
Mapping tab) is determined by the value in a register. Optionally, selecting an item from the list can write its 
corresponding value to a register.  

Dates of historical data: When data sampling (Data Sampling Object) or Alarms (Alarm/Event Log) are 
employed, the Option List can be used to list the dates corresponding to Historical data/event files for 
displaying in a Historical Trend Display, History Data Display, or History Event Display. 

Item address: Custom text for the Option List can be stored in registers and changed or updated during 
runtime. 
Control register: Set to 1 to update the item list. 
Control register + 1: Determines the number of items in the list. 
Item address: The starting address for the item list contents (ASCII or UNICODE). 

User account: When “Enhanced Security Mode” is enabled in the System Parameters > Security tab, the 
Option List can display the user names in the drop-down list. With the Monitor address pointing to the Control 
Address + 2 (Index of accounts register) configured for the Enhanced Security, you can select the user name to 
login from the Option List and the corresponding value will be written to the Index register. 
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Slider Object  

The Slider Object is used as a control to change the value in a PLC register, or the value in a register in the HMI 
local memory (LW), based on the position of the slide control. Low and High limits can be configured based on 
constant values or on PLC/HMI register values, and the resolution of the slide control can be adjusted to 
accommodate the range of values in the register. The position of the Slider will change if the register value is 
changed by some other device. 

Function Key  

The Function Key Object is used to change windows, popup a window, return to a previous window, close a 
window, or input data as part of a keypad. It can also be used to execute a macro or print the screen to a USB 
flash drive, SD card, or printer. 

Numeric Display  

The Numeric Display Object is used to display the current value in a register. The value can be displayed as 
BCD, Hex, Binary, or Decimal (signed or unsigned). 

Numeric Input  

The Numeric Input Object is used to display the current value in a register and to change the value in the 
register using a popup numeric keypad (or external keyboard). The value can be displayed as BCD, Hex, Binary, 
or Decimal (signed or unsigned). The Numeric Input has the option to read and write to different registers, to 
set a notification bit when a value is entered, and to set a notification bit on an invalid (out-of-range) entry. 

ASCII Display  

The ASCII Display Object is used to display the value in one or more registers as text (ASCII characters or 
Unicode characters). Up to 64 registers can be displayed. 

ASCII Input  

The ASCII Input Object is used to display the value in one or more registers as text (ASCII characters or Unicode 
characters) and to change the value in the register using a popup ASCII (alphanumeric) keypad or external 
keyboard. Up to 64 registers can be written to and displayed. 

Indirect Window  

The Indirect Window Object is used to display a window based on the value in a register (specified by the Read 
Address). The window whose number appears in the register is displayed within the frame of the Indirect 
Window. The Indirect Window Object should be the same size as the window(s) that are being displayed. If the 
Indirect Window is too small, some information may not display properly. 

The window is displayed as long as the value in the register contains the window number. Set the value to zero 
(or to a window number that hasn’t been created) to clear the Indirect Window. 

  

  1010-1015, Rev. 03 



74  EZwarePlus Programming Manual 

Direct Window  

The Direct Window Object is used to display a window based on the state of a bit in a register (specified by the 
Read Address). The window being displayed is selected in the Attributes section of the Direct Window Object’s 
Properties and appears within the frame of the Direct Window. The Direct Window Object should be the same 
size as the window being displayed. If the Direct Window is too small, some information may not display 
properly. 

The window can be triggered to display for bit ON or bit OFF. Toggle the bit to turn the window on and off (the 
window can be triggered to display with bit ON or OFF). 

Moving Shape  

The Moving Shape Object is used to move a shape or picture on the screen based on values in consecutive 
registers (specified by the Read Address). The value in the Read Address register determines the state of the 
object and can be used to change its appearance. The value in the next consecutive register(s) determines the 
position of the part (relative to the object’s initial position, in pixels). The position can be defined by X values, 
Y values, and XY values, where the Read Address + 1 = the X or Y position (for X axis only or Y axis only modes), 
or the Read Address + 1 = the X position and Read Address +2 = Y position (for X & Y axis mode). These 
addresses define the position relative to the upper-left corner of the shape. The Min/Max XY values in the 
Moving Shape object’s properties define the total area within which the object is allowed to move, regardless 
of the values in the controlling registers. 

Animation  

The Animation Object is used to move a shape or picture on the screen based on values in consecutive 
registers (specified by the Read Address). The value in the Read Address register determines the state of the 
object and can be used to change its appearance. The value in the next consecutive register (Read Address + 1) 
determines the preselected position of the part. 

When the Animation Object is selected, the cursor changes to a crosshair (+). Left-click the mouse on each 
location where the object will appear. When all locations have been defined, right-click the mouse to finish 
drawing the object. There must be at least three positions defined. The first location is represented by a 0 in 
the register, the second location by a 1 in the register, and so on. 

Media Player  

The Media Player Object is used to play a media file on the HMI screen. The media file is stored on a USB flash 
drive or SD card connected to the HMI. Click the Preview tab to load the media file and view the file. If the file 
plays in the Preview tab, it will play in the simulator and the HMI. The media player supports the following 
formats: avi, flv, mov, mp3, mp4, mpg/mpeg, wav, wmv.  

Specify the folder on the USB device where the media file(s) reside in the Folder name: field. The root folder is 
not allowed; and only one level is supported. For example, an entry of “video” specifies the folder “video” on 
the USB device, and is allowed. An entry of “video\files” specifies the folder “files” under the folder “video,” 
and is not allowed. 

 The Media Player is available only on the HMI5121P and HMI5150P. 
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Video In  

The Video In Object is used to input and play video on the HMI from an external source. One of two video 
input channels can be selected either in the program or dynamically using a PLC register. The composite 
video inputs can be configured to accept NTSC or PAL video formats. A control function can be enabled 
that allows the value in a PLC register to control the video input. 

Control Word address 0 = Stop playing 
1 = Input Video 1 and display onscreen. 
2 = Input Video 2 and display onscreen. 
3 = Input Video 1 but don’t display onscreen (available for capture 
function). 
4 = Input Video 2 but don’t display onscreen (available for capture 
function). 

Control Word address + 1 0 > 1 transition toggles Pause/Play (register resets to 0 after each 
transition) 

 
Recommended Format and Resolution 

 100% (1:1) 50% (1:2) 

NTSC 720 x 480 360 x 240 

PAL 720 x 576 360 x 288 

 

A capture function allows capturing video images and storing them as *.jpg files on a USB flash drive or SD 
card. The video capture is triggered by a PLC or local bit (OFF > ON) and can be configured to capture 
video once per second for a period of time defined by the Record time. The time Before and time After 
define the time period (up to 10 seconds each) before and after the trigger during which the video 
capture takes place. A buffer memory stores 10 seconds of captured video when the capture function is 
enabled. The capture function continues uninterrupted even if the video is in Pause mode.  

 The Video In is available only on the HMI5121P and HMI5150P. 

Video In(USB)  

The Video In (USB) Object is used to input and play video on the HMI from an external USB camera. The 
size of the object at runtime may not be the same as what was configured.  The Video In (USB) object will 
resize based on the size of the image from the camera.  The maximum size of the object is 572x430 pixels.  
The object must be at least 50 pixels from the bottom right corner of the window it is placed on.  If the 
camera is unplugged, the display will go blank.  When the camera is re-connected, the display can be 
restored by using the Control Address, by switching screens, or by restarting the HMI. 
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A control function can be enabled that allows the value in a PLC register to control the video input. 

Control Word address 0 = Connect video and start playing 
1 = Stop playing and disconnect video 

Control Word address + 1 0 > 1 transition toggles Pause/Play (register resets to 0 after each 
transition) 

 

The Video In (USB) can capture stills from the live video.  One PNG image is captured when the specified bit 
transitions from Off to On.  Stills are captured only when the Video In (USB) Object is displayed. The stills are 
stored on external memory.  Since the camera is connected to the HMI5070P's only USB port, images must be 
stored on the SD card. 

 The Video In (USB) is available only on the HMI5070P. 

Bar Graph  

The Bar Graph Object is used to display register data in a bar graph display. It can be configured to have alarm 
indicators using different colors on the bar graph to provide a warning when the value in the register is 
approaching a maximum or minimum allowable value. 

Meter Display  

The Meter Display is used to display register data in an angular position on an analog-style meter. The scale 
(tick marks) can be adjusted around the circumference of the meter and the pointer style can be changed. 
Scale values can be assigned to the tick marks by assigning a span range (e.g., 0-100).  

It can be configured to have alarm indicators using different color bars around the inside of the meter to 
provide a warning when the value in the register is approaching a maximum or minimum allowable value. 

Trend Display  

The Trend Display Object is used to display real-time or historical data collected by the Data Sample Object on 
a line graph. Up to 20 channels can be displayed on the graph with data collected from consecutive addresses, 
and with different colors assigned to each channel (pen).  

The Y-axis scaling is configured on the Channel tab with the Zero and Span fields (this defines the bottom and 
the top of the Trend Display and should contain the range of values in the data sample). The X-axis scaling is 
configured on the General tab with the Distance between data samples section. There are two options: Pixel 
(number of pixels between samples) and Time (sets the width of the entire Trend Display in seconds). 

In Real-time mode, data is displayed on the graph as it is generated. In History mode, data is plotted from 
data log files saved in memory. A new data log file is created each day and can be displayed in the Trend 
Display by changing the value in the History Control register. When the value in the History Control register is 
0, the data for today is displayed on the trend. When the value is 1, the data from yesterday is displayed, etc. 

See Chapter 10 for more information on “Creating Data Sampling Objects and Trend Displays.” 
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History Data Display  

The History Data Display Object is used to display historical data collected by the Data Sample Object in a table 
format. Up to 16 channels of data can be displayed from consecutive addresses, and can be any mix of data 
types (e.g., 16-bit unsigned, 16-bit signed, 32-bit float, etc.). 

Note: The History files section in the Data Sampling Object must have a box checked (e.g., Save to HMI 
memory) and a Folder name defined in order for the data files to be stored and displayed in the History Data 
Display. 

The History Control register is used to select the historical data file to display. When the value in the History 
Control register is 0, the data for today is displayed in the table. When the value is 1, the data from yesterday is 
displayed, etc. 

Data Block Display  

The Data Block Display Object is used to draw line graphs of the data contained in consecutive registers (up to 
1024 consecutive registers). In addition, up to 12 individual sets of data can be displayed in the Data Block 
Display. The line graphs can display data in any supported format, but the data in each graph must be of the 
same format. 

The Y-axis scaling is configured on the General tab with the Minimum and Maximum Limit fields (this defines 
the bottom and the top of the Data Block Display and should contain the range of data values). The X-axis 
scaling is configured on the Display Area tab in the Data Samples field (this defines the number of data 
samples to plot on a single screen). 

The Control address specifies the address to use to control the selected channel (data set). Each channel has 
its own Control Word address. The following values can be written to the Control address to control the plot: 

Trigger Value Control Function 

1 Draws the plot for the selected channel, leaves existing data. 
Can display up to 32 plots for 1 channel, 16 plots for 2 channels, 8 plots for 4 channels, etc. 

2 Clears the plot for the selected channel. 

3 Clears the plot for the selected channel, then redraws the plot with the current data. 

 
The HMI will write a 0 to the Control Word address after the operation is complete. 
If Offset to start address is unchecked, the following addresses are used by the Data Block Display: 

Control Word address Draws/clears the plot 

Control Word address + 1 Defines number of data points to plot (n = up to 1024) 

Data storage start address First data point to plot 

Data storage start address + 1 Second data point to plot 

Data storage start address + n + 
1 

Last data point to plot 

n = number of data samples 
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The number of data points must be stored at [control word address + 1], and the data must be stored starting 
at [Data storage start address] before the control value is written to the Control Word address. 

If Offset to start address is checked, the following consecutive addresses are used by the Data Block Display:  

Control Word address Draws/clears the plot 

Control Word address + 1 Defines number of data points to plot (n = up to 1024) 

Control Word address + 2 First data point to plot 

Control Word address + 3 Second data point to plot 

Control Word address + n + 1 Last data point to plot 

The number of data points must be stored at [control word address + 1], and the data must be stored starting 
at [control word address + 2] before the control value is written to the Control Word address.| 
n = number of data samples 

XY Plot  

The XY Plot Object is used to plot one series of values against another series of values on a line graph. 

The direction of the plot is defined in the Direction field as follows: 

Direction Result 

Right The origin is at the lower left. The X-axis moves to the right, the Y-axis moves up. 

Left The origin is at the lower right. The X-axis moves to the left, the Y-axis moves up. 

Up The origin is at the lower left. The X-axis moves up, the Y-axis moves to the right. 

Down The origin is at the upper left. The X-axis moves down, the Y-axis moves to the right. 

The No. of channels field specifies the number of datasets to plot (up to 16 channels). 

The Control Address specifies the address to use to control how the XY Plot operates. The following values can 
be written to the Control Address to control the plot: 

Trigger Value Control Function 

1 Draws the plot for the selected channel, leaves existing data. 
Can display up to 32 plots for 1 channel, 16 plots for 2 channels, 8 plots for 4 channels, etc. 

2 Clears the plot for the selected channel. 

3 Clears the plot for the selected channel, then redraws the plot with the current data. 

 

The HMI will write a 0 to the Control Word address after the operation is complete. 

The No. of data address field is automatically assigned to the next consecutive address after the Control 
Address. It must be loaded with the number of pairs of X-Y data to plot. This value must be set before a trigger 
value is written to the Control Address. Up to 1023 data points can be plotted per channel. 
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The Read address field is the starting address of the data to plot. Each channel has its own Read address. 
Normally, the X and Y data are read from two consecutive addresses beginning with the Read address. To have 
the XY Plot use separate addresses for X and Y data, check the Separated address for X and Y data checkbox. 
Separating the X and Y data addresses also allows the X and Y data to have different formats. The first Read 
address field defines the X-axis data and the second Read address field defines the Y-axis data. 

The X-axis and Y-axis scaling is configured in the Limits section on the General tab. The Low and High limits 
define the left-to-right range and the bottom-to-top range for the X-axis and Y-axis respectively. 

If Dynamic limits is checked, the limits are read from registers determined by the Read address as follows: 

With Separated address for X and Y data unchecked 

Read address X minimum 

Read address + 1 X maximum 

Read address + 2 Y minimum 

Read address + 3 Y maximum 

Read address + 4 X Data 1 

Read address + 5 Y Data 1 

Read address + 6 X Data 2 

Read address + 7 Y Data 2 

Read address + n + 4 X Data n 

Read address + n + 5 Y Data n 

n = number of data samples 

With Separated address for X and Y data checked 

X Read address Y Read address 

X Read address X minimum Y Read address Y minimum 

X Read address + 1 X maximum Y Read address + 1 Y maximum 

X Read address + 2 X Data 1 Y Read address + 2 Y Data 1 

X Read address + 3 X Data 2 Y Read address + 3 Y Data 2 

X Read address + 4 X Data 3 Y Read address + 4 Y Data 3 

X Read address + n – 1 X Data n  Y Read address + n – 1 Y Data n 

n = number of data samples 

The appearance of the plot is configured on the Display Area tab, including the frame and background color of 
the display, and the color and width of the plot line. The Maker area lets you configure how the data for each 
channel is plotted: 
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Line: The data is plotted as a Line graph, with squares plotted at each data point. 
Point: The data is plotted as squares at each data point. 
X-axis projection: The data is plotted as a line graph (no squares). The plot is filled along the X-axis. 
Y-axis projection: The data is plotted as a line graph (no squares) with the X and Y data transposed. The plot is 
filled along the Y-axis. 

The Reference line section lets you configure up to four horizontal lines that can be drawn across the plot. 
Each line can be enabled separately, and can have a unique color and position. The position specified for each 
line is relative to the values entered in the Low Limit and High Limit fields. If the Limit from PLC box is 
checked, the reference lines are referenced to the values entered in the specified register addresses (low limit 
= value in register address; high limit = value in register address + 1). 

Recipe View 

The Recipe View is used to display recipe data on the HMI screen. The recipes are created on the Recipe tab in 
the System Parameters and the data is stored in the recipe database file (*.db). Recipe data cannot be edited 
in the Recipe View table. However, Numeric Input objects can be used to enter or change recipe data by 
selecting the Recipe Device Type in the address field and selecting the Recipe and Item to be edited. See 
“Chapter 15 – Recipes” for more information. 

Alarm Bar  

The Alarm Bar Object is used to display alarms detected by the Alarm (Event) Log Object. It displays the alarm 
message for each current alarm in a single horizontal scrolling line across the Alarm Bar’s display. Only the 
most recent alarm appears in the Alarm Bar. 

Alarm Display  
The Alarm Display Object is used to display alarms detected by the Alarm (Event) Log Object. It displays the 
alarm message for each alarm in a table format arranged in chronological order. All current alarms are 
displayed in the Alarm Display and are removed from the list once the alarm condition is cleared. 

An Alarm Acknowledge function can be enabled, which provides a Write address for the Alarm Display. Each 
alarm/event can be acknowledged by touching the message in the Alarm Display. A different color can be 
assigned for the Acknowledge status. 

An Indirect Window can be configured to popup when the alarm/event is acknowledged to provide additional 
information to the operator on how to proceed. The Indirect Window should be placed on the same window 
as the Alarm Display. The window number is configured in the Alarm (Event) Log’s Message tab (Write value 
for Event Display object) and is written into the Write address assigned in the Event Display. 

Event Display  

The Event Display Object is used to display alarms or events monitored by the Alarm (Event) Log Object. 
Events can be displayed in Real-time or History mode. In Real-time mode, each alarm/event can be 
acknowledged by touching the alarm/event in the Event Display. Different colors can be assigned for the 
Acknowledge and Return To Normal statuses.  

An Indirect Window can be configured to popup when the alarm/event is acknowledged to provide additional 
information to the operator on how to proceed. The Indirect Window should be placed on the same window 
as the Event Display. The window number is configured in the Alarm (Event) Log’s Message tab (Write value 
for Event Display object) and is written into the Write address assigned in the Event Display. 
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In History mode, alarm/events from previous days can be displayed. The Write address changes to History 
Control address, and the value in the History Control register determines which historical data is displayed. 
When the value in the History Control register is 0, the data for today is displayed in the Event Display. When 
the value is 1, the data from yesterday is displayed, when the value is 2, the data from two days ago is 
displayed, etc. Use the Option List configured for “Source of item data: Dates of historical data” to select the 
day by date. 

Check Enable reading multiple histories to display events from more than one day at a time. There are two 
modes:  

With Number of days selected, the value entered in the History control register determines the starting 
day (most recent, where 0 = today) and the value in the History control register + 1 determines the number 
of days of data to display (including the starting day). If three days are selected, but only two event files 
are included within the three day period, only two event files will be displayed. 

With Index of the last history selected, the value entered in the History control register determines the 
starting day (most recent, where 0 = today) and the value in the History control register + 1 is the number 
of event files to display. This setting is not dependent on the date and the Event Display will display the 
designated number of event files from most recent to oldest. 

 The Event Display can display up to 4MB of historical data. If the combined file size of the selected 
historical data exceeds 4MB, the most recent data is displayed and the oldest data beyond 4MB is not 
displayed. 

Select Enable event management to control which events to display or hide, and allow users to delete 
selected events. 
Control address 0 = All events are displayed. 

1 = Confirmed events are hidden. 
2 = Returned to normal events are hidden. 
3 = Confirmed and returned to normal events are 
hidden. 

Control address + 1 1 = Users can delete selected events in real-time 
mode. 

Event (Alarm) Log  

The Event (Alarm) Log Object is used to configure alarms and events. Select one of the History files 
checkboxes to save alarm/event files in HMI memory or to an SD card or USB flash drive. This is used when an 
Event Display is configured for History mode. The Preservation limit lets you limit the number of history files to 
save. A new file is created each day with the filename EL_yyyymmdd.evt where yyyy=year, mm=month, and 
dd=day. For example, the file for June 12, 2010 would be EL_20100612.evt. 

Click the New button to create a new alarm/event. An alarm/event can be triggered by a bit or a word. The 
Notification field can be configured to set or clear a bit when the alarm is triggered.  

The Message tab allows you to enter a message that will appear in the Alarm Bar, Alarm Display, or Event 
Display when the alarm/event is triggered. The Write value for Event Display object is used to enter a window 
number that is written to the Write address configured in the Event Display object. This window number is 
used by an Indirect Window configured to popup when an alarm/event is acknowledged. 

For HMI5000P models with the audio line-out option, a sound can be played when the alarm/event is 
triggered. Click the Enable button and select a sound from the Sound Library. 
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The WATCH addresses can be used to display the data in up to four registers in messages. Click the Syntax 
button to see how to configure the message to display the data. 

Data Transfer (Trigger-based)  

The Data Transfer (Trigger-based) Object is used to transfer word-based data from the specified Source 
address(es) to the specified Destination address(es). This can be used to transfer data from one device to 
another. 

The Source and Destination address fields define the starting addresses, and the No. of words field specifies 
how many consecutive addresses are transferred. The data transfer can be triggered by touch (Touch trigger 
mode) or by an external or internal bit (External trigger mode). 

Backup  

The Backup Object is used to copy recipe files (*.rcp), event files (*.evt), and data files (*.dtl) from the HMIs 
internal memory to a USB flash drive, SD card, or a PC connected via Ethernet. 

 The L Series do not support SD cards. 

 
When Historical event log or Historical data log is selected, the historical event logs or data logs can be saved 
in their native file formats (*.evt or *.dtl respectively) or in *.csv format. The range of history files can be 
selected and the backup can be triggered by touch (Touch trigger mode) or by an external or internal bit 
(External trigger mode). 

When External trigger (word) is selected for the Trigger Mode, the following registers control the Backup, 
allowing the operator to define what files are backed up: 
Trigger address: When the value changes from 0 to 1, the backup is triggered. 
Trigger address + 1: Defines the start day for the backup. 
Trigger address + 2: Defines the range of days to backup (maximum 90 days). 

When the backup process starts, local bit LB9039 is set. When the backup is complete, local bit LB9039 is 
reset. 

Timer  

The Timer Object is used to control an output bit based on the state of an input bit and a measurement bit 
that is controlled by a preset time. There are five different configurations or modes for the timer including On 
Delay, Off Delay, Pulse, Accumulated On Delay, and Accumulated Off Delay. 

When placed on a base window, the timer object is active only when that window is showing on the HMI. 
When placed on the Common Window (Window 4), the timer object is active at all times, regardless of which 
window is displayed on the HMI. 

PLC Control  

The PLC Control Object is used to perform a number of background tasks. Click the New button to set up a 
control object. Click Type of control to open a drop-down box with the following options: 
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Change Window 

This causes the HMI to close the currently-displayed Base Window, and display the Base Window whose 
number is in the specified Trigger address. 

The Change Window action occurs only when the HMI detects a change in the value of the specified Trigger 
Address. After the window is changed, the HMI will write the number of the newly-displayed window to 
(Trigger Address +1). 

Write data to PLC (current base window) 

When the HMI initializes, and when the Base Window changes (for any reason), the number of the new Base 
Window is written to the PLC Register specified by the Trigger address. 

General PLC Control 
Executes a data transfer of up to 32 words from the HMI to the PLC or from the PLC to the HMI when the 
value in the Trigger Address is set to a valid operation code. After the operation is complete, the HMI sets the 
value in the Trigger address to 0. A total of four values are needed to configure the General PLC Control 
attribute. 

Address Function Details 

Trigger address Operation code. Valid codes are 1, 2, 3, 4. 
The Trigger address is set to 0 by the HMI 
when the transfer is complete. 

1. PLC to HMI: RW (recipe words) 
2. PLC to HMI: LW (local words) 
3. HMI to PLC: RW to PLC 
4. HMI to PLC: LW to PLC 

Trigger address + 1 Number of words to transfer  
(32 words maximum) 

The number of words to transfer from 
the PLC to the HMI or HMI to PLC. 

Trigger address + 2 PLC Data Address Offset The Address Offset (from the Trigger 
address + 4) at which the transfer of data 
to/from the PLC will start.  

Trigger address + 3 HMI Data Address Offset The Address Offset at which the transfer 
of data to/from the HMI will start. 

 

Note: The HMI will transfer data to/from the Device Type specified by the Trigger address. 

It is recommended that the data in (Trigger Addr + 1), (Trigger Addr +2), and (Trigger Addr +3) be set before 
writing the Operation Code to (Trigger Addr). 

Backlight Control (Write Back) 

Allows the PLC to control the HMI’s backlight via the bit specified in the Trigger address. Once the requested 
operation has been performed, the HMI will reset the bit. 

Note: The PLC Control Object may be configured with two Backlight Control (Write Back) items, with different 
bits for the On and Off control. The backlight can then be controlled directly from the PLC. 

Backlight Control 

Operates the same as the Backlight Control (Write back) attribute described above, but the HMI will not reset 
the bit specified in the Trigger address. 
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Sound Control 

Plays the selected sound when the bit specified by the Trigger address matches the trigger mode conditions. 

Execute Macro Program 

Executes the designated macro when triggered by the bit specified in the Trigger address. 
Note: Only available when a macro has been created in the project. 
 

Screen Hardcopy 

Prints the specified window when the bit specified by the Trigger address matches the trigger mode 
conditions. The Source window for print option provides the following selections: 

Current base window: When the trigger occurs, the window currently displayed on the HMI is printed. 
Window no. from register: When the trigger occurs, the window number is read from the specified register; 
the window is displayed and printed. 
Designate window no.: The window is selected from a list during project development. When the trigger 
occurs, this pre-selected window is displayed and printed. 

The Printer field allows you to select the destination for the screen hardcopy: a printer attached to the HMI, 
one of the USB ports, or the Remote Printer Server. 

Data Transfer (Time-based)  

The Data Transfer (Time-based) Object is used to transfer bit-based or word-based data from the specified 
Source address(es) to the specified Destination address(es) at periodic intervals. The interval is adjustable 
from 0.5 to 25.5 seconds, in 0.1 second steps. 

The Address type selects whether the data transferred is word or bit, and the No. of word/No. of bit field 
specifies how many consecutive addresses are transferred. The Source and Destination address fields define 
the starting addresses.  

Note: When transferring bits, bits can only be transferred to the local HMI’s internal memory. It is not possible 
to transfer bits to a remote HMI or another PLC. 

Data Sampling  

The Data Sampling Object is used to create Data Logs. A Data Log gathers data that can be saved as History 
files to the HMIs internal memory, or to a compact flash, SD card, or USB drive (depending on the model). That 
data can then be displayed in a Trend Display or History Data Display in real-time or historical. The data can 
then be displayed in a Trend Display in real-time, and data files from previous days can also be displayed in 
History mode. The History Data Display can also display historical data in a table format. 

The data files can also be transferred to a PC and saved in *.csv or *.xls format using the EasyConverter 
application (included with EZwarePlus). 

Note: Every 60 seconds, the HMI checks to see if the size of the updated data file exceeds 4000 bytes. If so, 
the data file is written to non-volatile memory. 

Sampling can be configured to occur periodically (Time-based) with sampling intervals ranging from 0.1 second 
to 120 minutes, or it can be triggered by the state of a bit (Trigger-based). The Read address defines the 
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starting address of the data samples and the Data Record area allows you to configure how many consecutive 
registers to sample. 

The Data Format button opens a dialog to configure the format of a data log record. A record is a single line or 
group of lines of data. Different data formats can be used within the same record. When multiple items are 
configured in the same record, consecutive addresses are used beginning with the address specified in the 
Read address. The number of registers is determined by the number of items defined in the Data Format list 
and the size of each item (i.e., 16-bit or 32-bit). The first item is read from the specified Read address, the next 
item is read from the address after the Read Address, etc. 

Note: When creating a Data Sample for use with a multi-pen Trend Object, use the Data Format button to 
configure the data for each of the trend's pens. Each additional item in the Data Format list will use the next 
consecutive address from the specified Read Address. 

When logging data, one data file is created for each day. The data file has a file name of the form 
yyyymmdd.dtl, where yyyy is the four-digit year; mm is the two-digit month (01 for January, 12 for December); 
dd is the two digit date. 

System Message  

The System Message is used to customize the content of system-generated messages. 

Confirmation required: Message that is displayed when confirmation of an operation is required. 
Password required: Message that is displayed when the current security level prevents an operation. 
System error: Message that is displayed when the HMI experiences a critical internal error. Contact Maple 
Systems if this message is displayed. 

Scheduler  

The Scheduler is used to change a bit or a word based on a time schedule. Each scheduled action can have a 
start time and an end time. Up to 32 items can be entered in the Scheduler list. 

Power-ON start/end action: Determines the action to perform when the HMI is turned ON.  
When checked: If the HMI is turned ON within the scheduled time range, the start action is performed 
immediately. If the HMI is turned ON outside of the scheduled time range, the end action is performed 
immediately (if enabled). 
When unchecked: If the HMI is turned ON within the scheduled time range but after the start time, the start 
action is not performed but the end action is performed (if enabled). If the HMI is turned ON outside of the 
scheduled time range, no action is performed. 

Action modes include Bit ON, Bit OFF, or Word write. 
Bit ON: Start action sets the Action address bit. End action clears the Action address bit. 
Bit OFF: Start action clears the Action address bit. End action sets the Action address bit. 
Word write value settings – Constant: Start action writes the Start value into the Action address register. End 
action writes the End value into the Action address register. 
Word write value settings – Address: Start action writes the value stored in the designated register into the 
Action address register. End action writes the value stored in the designated register+1 into the Action 
address register. 

Note: The end action is only available when Enable termination action is checked on the Time Set tab. 
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Click the Time Set tab to configure the start and end times for the scheduled action. When Constant is 
selected, the action is configured to occur on the specified days at the specified times. Multiple days can be 
selected. If the start and end times need to span several days, select the Setting on individual day checkbox. 

When Address is selected, the start and end times are determined by values in 11 consecutive registers 
beginning with the designated Time setting address as follows: 
Address Function Details 

Time setting address Control Set to 1 to load the Scheduler with 
the current time data. Do this each 
time the start and end times are 
updated in the registers. 

Time setting address + 1 Status Bit 0 is set when the time data has 
been properly loaded. 
Bit 1 is set when there has been an 
error in loading the time data. 

Time setting address + 2 Action mode Set Bit 0 to use end time. 
Clear Bit 0 and the Scheduler will 
not use end time. 

Time setting address + 3 Start time (day) Bits 0-6 determine day of the week 
the Start Action is executed. 
Bit 0=Sunday; Bit 6=Saturday. 

Time setting address + 4 Start time (hour) This register determines the hour 
the Start Action is executed. 
Range is 0-23. 

Time setting address + 5 Start time (minute) This register determines the 
minute the Start Action is 
executed. 
Range is 0-59. 

Time setting address + 6 Start time (second) This register determines the 
second the Start Action is 
executed. 
Range is 0-59. 

Time setting address + 7 End time (day) Bits 0-6 determine day of the week 
the End Action is executed. 
Bit 0=Sunday; Bit 6=Saturday. 
Note: If bit 0 of the Action Mode 
register is clear, the Scheduler will 
not execute the End Time action. 

Time setting address + 8 End time (hour) This register determines the hour 
the End Action is executed. 
Range is 0-23. 

Time setting address + 9 End time (minute) This register determines the 
minute the End Action is executed. 
Range is 0-59. 

Time setting address + 10 End time (seconds) This register determines the 
second the End Action is executed. 
Range is 0-59. 
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Drawing Tools  

Includes Line, Arbitrary Line, Link Line, Arc, Ellipse/Circle, Pie, Rectangle, Polygon, Scale, Text, Picture, Shape. 

Refer to the Help file for instructions in using each individual drawing tool (Help > Parts List > By Function > 
Drawing Objects). 

Managing Projects 
Like most Windows™ application software, EZwarePlus will open, save, close, and print files using the standard 
windows format. 

Opening, Editing Projects 

To create a new project   

1. On the File menu, click New or click the New icon in the Standard toolbar. The EZwarePlus dialog box 
appears. 

 

2. Select the HMI model that you intend to use with your project and whether you want to use the HMI 
in Landscape or Portrait mode. Select the Use template checkbox to open the project with the 
default template for your selected model. 

3. Click OK. The System Parameter Settings window opens next. Refer to the Help menu “How Do I… Set 
Up a PLC or Controller in EZware?” to configure the devices in the Device List. You may also jump 
ahead to System Parameter Settings on page 93. Click OK to accept the settings. 

To open an existing project   

1. On the File menu, click Open or click the Open icon in the Standard toolbar. The Open dialog box 
appears. 

2. Click on the project file you intend to open. 

3. Click Open. The main screen of EZwarePlus appears with the initial screen of the project displayed. 

To close a project: 

1. On the File menu, click Close. 
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2. If changes have been made to the project file, EZwarePlus will ask you if you would like to save the 
project. Then the main screen of EZwarePlus will remain but with no work area displayed. You must 
now use the Open or New commands to edit a project. 

To save an existing project   
1. On the File menu, click Save or click the Save icon in the Standard toolbar. 

2. If the project already has a name, then the project will automatically be saved. If this is a new project, 
then the Save As dialog box appears. 

3. Enter a file name and then click Save. 

4. The main screen of EZwarePlus reappears. 

To save a project using the compress feature: 

The compress feature allows you to save a project in compressed format so that the project data takes less 
space on your hard drive. This utility also will save the graphics libraries associated with the project into the 
compressed file. This facilitates sending a copy of the project to another person who has EZwarePlus in order 
to open and download the project into an HMI. It is also the best way to archive and backup your projects 
when you have completed them. 

 The compress feature doesn’t save the fonts used in the project. It is best to use common Windows True 
Type fonts (or the HMI True Type fonts) in your project so that if it is opened on another computer, 
EZwarePlus will have access to the same fonts. 

1. From the Tools menu, select Compress/Uncompress.... The Compress/Uncompress Project dialog 
box appears. 

 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  89 

2. In the Compress box under Source Name, select the project (*.mtp) file that you wish to compress. 
The file must have a .mtp extension. 

3. Click Compressing… to begin. The utility will compress the project file and all related graphics libraries 
into a single file. 

To extract a compressed project file: 

1. From the Tools menu, select Compress/Uncompress.... The Compress/Uncompress Project dialog 
box appears. 

2. In the Uncompress box under Source Name, select the project (*.cmp) file that you wish to 
uncompress. 

3. Click Uncompressing… to begin. The utility will extract the project file and all graphics libraries from 
the *.cmp file. 

Note: It is a good idea to backup your Library folder before uncompressing a *.cmp file because the 
uncompress utility will overwrite any existing library files with the same name. You also have the option 
not to overwrite existing files, and in most cases this is okay unless the project being uncompressed uses 
modified libraries with the same names as the standard libraries in the Library folder. 

To exit EZwarePlus   

On the File menu, click Exit or click on the standard windows Close icon in the upper right corner. 

Display Options 
EZwarePlus provides a Window Tree that can be used to easily maneuver among windows of a project. It also 
allows you to select any object that is on the window that is currently displayed. 

To display/hide the Window Tree 

1. On the View Menu, click Window Tree 

Using the Window Tree to display window screens 

1. At the top of the Window Tree, there is a drop-down box that allows you to select either Object List 
or Window Preview. The Window Preview displays thumbnail views of each of the windows in the 
project.  
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2. The Object List combines a list of all of the windows in a project, and all of the objects on each 
window, into a single tree. Notice that the tree displays the title for each window next to the window 
number. This makes it easy to determine the windows that have been created for a project. An 
asterisk (*) next to a window indicates that the window is currently open. 
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3. To display an open window, click on the window number in the Window Tree. To display a window 
that is not yet open, double-click on the window number. This will automatically open the window 
and display it.  

4. To change any settings or close an open window, click on the window number to select it. Then right-
click anywhere inside the Window Treebar to display a popup dialog box. Select Close to close the 
window or Setting to change any of the window settings. 

5. Finally, to create a new window click on any window number that is not currently used. Then, right-
click inside the Window Tree and select New. 

 
Using the Window Tree to change object attributes 

1. On the Window Tree, click + adjacent to any window number. The tree will expand to list the objects 
on that window, as shown: 

  1010-1015, Rev. 03 



92  EZwarePlus Programming Manual 

 

2. The Object ID of each object will be listed. For example, WC_0 is Direct Window #0, TS_0 is Toggle 
Switch #0, etc. 

3. To highlight a particular object on the screen, click on the Object ID in the list. This allows the quick 
selection of a particular object, especially on crowded screens or screens where objects may be 
overlapping. 

4. To display the object’s attribute dialog box, double-click the Object ID in the Window Tree. 

 

Using the grid function  

One display option is to have the work area covered with grid lines. These grid markings can be helpful when 
trying to align objects that are created on the work area. If grid lines are selected, you can decide what size 
each grid is. 

Turning the Grid on and off: 

1. On the Option menu, click Grid/Snap. 

2. Click the Display box or click the Grid icon in the Standard toolbar to turn the grid on and off. 
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 If you still don’t see the grid after you have enabled it, make sure that the color of the grid doesn’t 
match the background color of the window currently displayed. 

Changing the grid size and color: 

1. On the Option menu, click Grid/Snap. 

2. Select the X spacing and Y spacing for grid size. 

 

 Spacing is measured in pixels.  

3. Select the Grid color in the drop down menu.  

If you enable the Grid on the work area, you may also take advantage of a useful feature called Snap. The Snap 
option causes all objects placed into the work area to fall along the boundaries set by the grid lines. The Snap 
option can help provide a more ordered appearance to graphics objects. 

Using the snap option 

1. The Grid option must be enabled. 

2. On the Option menu, click Grid/Snap. The Grid/Snap Settings dialog box appears. 

3. Click the Snap checkbox. 

4. Click OK. 

Finally, you will find that you can move objects by selecting them with the mouse cursor and dragging them to 
a new location. However, you may find it difficult to select an object without accidentally moving it just a little. 
At times this may be frustrating, so you may wish to disable the move feature using the mouse and only move 
an object by changing its X and Y position parameters in the Profile tab of the object’s attributes box. This is 
the intent of the Fix all objects feature. 

To enable the fix all objects command 

1. On the Option menu, click Grid/Snap. The Grid/Snap Settings dialog box appears. 

2. Click the Fix all objects checkbox. 

3. Click OK. Movement by mouse cursor is now disabled. 
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To zoom in on the selected window 

1. Use the zoom pull-down menu in the Edit Toolbar. Zoom levels range from 50% to 200% in 25% 
increments. 

2. On the View menu, select Zoom Level. Zoom levels range from 50% to 200% in 25% increments. 

Another option is to display what are known as Object ID tags. Every time you create a new object in 
EZwarePlus, an Object ID tag is assigned to the new object. This is done for several reasons: 

• Object ID tags are required by EZwarePlus to differentiate each object created. 

• If an error occurs during the compile process, EZwarePlus can refer to the window and object ID to 
indicate the object that is causing problems. 

To enable/disable displaying Object ID tags 

1. On the Option menu, click Function Property. The Function Property dialog box appears. 

 

2. Click the Display Object ID checkbox to display tags. 

3. Click OK.  

The Function Properties dialog also has the following options: 

Display Common Window objects on Base Windows: When unchecked, objects on the Common Window 
will not appear on base windows in the EZwarePlus development screens. Objects on the Common 
Window will always appear on the base windows when the project is downloaded to the HMI. Check this 
to enable viewing the Common Window objects on the base windows in the development screens. 

Using Function key to make shape library object: Allows shapes to be placed inside the area defined by a 
Function Key before being imported into a Shape library. This allows a shape to occupy any position inside 
a shape library cell. See “Help > How Do I…Add a New Shape or Picture into the Libraries?” for more 
information. 

Automatic save and compile when download and simulate: This option causes EZwarePlus to 
automatically save and compile the project when a Simulation is started or prior to commencing a 
download to the HMI. 
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To change the state of the selected window   

1. Click the State pull-down menu in the State Toolbar and select the State number you wish to display 
(0-255). 

2. The objects will appear as they would in the selected state. 

Basic Editing Commands 

To select a graphics object  

1. On the Edit Menu, click Select or click the mouse cursor icon in the Draw Toolbar. 

2. Click on the graphics object. This causes the text box to be selected, with small square blocks around 
the edges indicating the boundaries of the object. Deselect the object by clicking somewhere else in 
the work area. 

3. When a graphics object is selected, it can then be modified, copied, deleted, or moved to a new 
location. 

To select multiple graphics objects 

1. On the Edit Menu, click Select or click the mouse cursor icon in the Draw Toolbar. 

2. Click and hold down the left mouse button at the upper left corner of the graphics objects you wish 
to highlight. 

3. Drag the mouse cursor to the lower right corner of the highlighted objects. Notice that a rectangle is 
formed as you do this. 

4. Release the mouse button. The rectangle outline changes to small clear square blocks around the 
perimeter of the objects selected. Now both objects are selected. 

 If you do not completely enclose any graphics objects you wish to highlight, then they will not be 
selected. 

5. Alternatively, you may select objects by holding down the CTRL key while selecting each object until 
all objects are selected. 

6. When several graphics objects are selected, they can easily be moved, deleted or copied together. 

To select next object  
1. This option can be used to easily select an object that is underneath another object on the screen. To 

use this option, you must first select the overlapping object. 

2. On the Edit Menu, click Select Next Object or click on the Select Next Object icon on the Standard 
Toolbar. You can also right-click on the top-most object on the screen. This will display a menu with a 
list of the overlapping objects on the bottom. Then check the object that you wish to access. 

3. Once the object you are trying to access is selected, you can proceed to modify its attributes or 
delete it. 
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To select all objects 

1. On the Edit Menu, click Select All Objects. 

2. Small, clear, square blocks appear around the perimeter of all the objects on the window. 

3. You can now easily move, delete or copy the entire window screen to a new window. 

Using the Undo    and Redo    commands 

1. The Undo command is used to cancel the last command or action that you made. 

2. Press the DELETE key on your keyboard to delete the text box. 

3. From the Edit menu, click Undo or click the Undo icon from the Standard Toolbar. You can also press 
CTRL+Z. The deleted text box reappears. 

4. The Redo command is used to cancel the Undo command. 

Using the Cut     , Copy    , and Paste    commands 

1. These commands are all selected from the Edit menu. 

2. Select the graphics object or objects you wish to cut or copy. 

3. Click Cut to copy and remove the graphics object(s) from the work area or click Copy to copy the 
graphics object(s). 

4. Objects cut or copied from one window can be pasted into other windows. Once the object has been 
selected and cut or copied, open another window, then paste the object into that window. 

5. The pasted object appears highlighted in the upper leftmost corner of the work area. 

6. Move the object by clicking on the highlighted area and dragging it to the desired position. 

Using the Multi-Copy command 
The Multi-Copy command is used to make multiple copies of a single object on a screen. This is most useful 
when creating new keyboards or data tables. In addition to copying the object, this command will 
automatically assign new memory addresses to each object. 

1. Select the object you wish to copy. 

2. From the Edit menu, select Multi. Copy.... The Multi. Copy dialog box appears. 
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3. Modify the settings according to your requirements. 

4. Click OK. The main screen of EZwarePlus is redisplayed with the Multi. Copy command executed. 

 

Multiple objects can be created according to these parameters: 

Pitch vs. Interval: This setting affects how EZwarePlus places the copies of an object on the screen relative to 
each other. The Pitch setting will interpret the X Distance setting as the distance from the left side of an object 
to the left side of the next object and the Y Distance setting as the distance from the top of one object to the 
top of another object. 

The Interval setting will interpret the X Distance setting as the distance from the right side of one object to the 
left side of the next object. The Y Distance setting is the distance from the bottom of one object to the top of 
the next object. 

X, Horizontal Distance and Y, Vertical Distance: These settings determine the spacing (in pixels) between 
objects. 

Quantity X and Quantity Y: These settings determine the number of copies to be made along the X axis 
(horizontal) and the Y axis (vertical). 

Left to right and Top to bottom: When Left to right is selected, objects are created and addressed in the X-
axis first and then in the Y-axis. When Top to bottom is selected, objects are created and addressed in the Y-
axis first and then in the X-axis. 

Adjust Distance: This is the offset used when assigning a new address to each new copy. For example, if 1 is 
selected, then EZwarePlus will add one to the address for each new copy made. 

Using the Window Copy command 

The Window Copy command is used to copy a window from an existing project into the project that you are 
currently editing. This feature reduces time spent creating new projects since you can now use windows that 
you created for other similar projects. 
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1. From the Edit menu, select Window Process and click Window Copy.... The Window Copy dialog box 
appears. 

 

2. In the Source project box, specify the path to the project that contains the window screen(s) you 

wish to copy. Use the Browse... button  to navigate to the project if you are unsure of the 
location or name of the project file. 

3. In the Source boxes, enter the numbers of the window screen(s) you wish to copy. They must be 
consecutive windows. If you are only copying one window, put the same window number in both 
boxes. 

4. In the Destination box, select the number of the window in the current project that you wish to copy 
the selected window(s) to. If multiple windows are selected, they will be copied into consecutive 
windows beginning with the one designated in the Destination window. 

5. There are checkboxes for PLC control, Event (Alarm) log, Schedule, Data transfer, and Data sampling. 
The selected options will also be copied into the current project. 

6. Click OK. The EZwarePlus Destination window is redisplayed with the Window Copy command 
executed. 

To delete a graphics object(s) 

1. Select the object or objects you wish to delete. 

2. Press the DELETE key or from the Edit menu, click Delete. 

 You can restore the deleted object by using the Undo command. 

To move a graphics object(s) 

1. Select the object or objects you wish to move. 

2. When you place the mouse cursor over a highlighted object, the cursor changes to a crosshair. This 
indicates that you are able to move the selected object. Move the object by clicking on it and 
dragging the object to the proper position on the work area. 
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To resize a graphics object 

1. Select the object to be resized. 

2. To resize the object, move the mouse cursor over one of the small black squares. The cursor changes 
to a double-arrow icon to indicate that it is in resizing mode. 

3. Click and drag the mouse to resize the object. 

4. Objects can also be resized by changing the width and height attributes in the Profile tab of the 
Attributes dialog box (see below). 

To change attributes of a graphics object 

1. Select the object to be changed, then select Change Object Attributes from the Edit menu. You can 
also double-click the object. 

2. The object’s attribute dialog box is displayed. Object Attributes defines what the object is or how it 
behaves, (i.e., size, position, color, etc.). Click OK to accept any changes made or Cancel to cancel any 
changes. 

To view object attributes of multiple graphics objects on a window 

1. There will be times when you may want to quickly determine what PLC data registers are tied to 
which objects in a window. This can easily be done using the object attributes command. 

2. On the Edit menu, click Select all objects. 

3. From the Edit menu, click Change Object Attributes. The Object Attribute dialog box is displayed. 

 

4. All of the objects that use PLC data registers or the internal memory of the HMI are listed in this 
dialog box according to their Object ID tag. Alongside each ID tag is the PLC or HMI memory identifier. 
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Grouping Objects 
When creating graphics on a window, you may create a complex graphic that is actually composed of several 
simpler objects grouped together. Grouping objects together makes it easier to move or copy multiple objects 
at the same time. 

To group objects   

1. Select the objects to be grouped. 

2. From the Edit > Group menu, click Group or click the Group icon from the Edit toolbar. 

3. All objects within the group can now be copied, deleted, or moved by clicking on the group. 

To ungroup objects   

1. Select the objects to be ungrouped. 

2. From the Edit > Group menu, click UnGroup or click the UnGroup icon from the Edit toolbar. 

3. All objects within the group can now be copied, deleted, or moved separately. 

 

Layering Objects 
Graphics objects can be overlaid upon each other. When ‘layered’ the graphics object on the topmost layer 
will be completely seen. How much of the other graphics objects are seen depends on what is on top of them. 
The following layer commands help to position the overlaid objects exactly how you want them. 

Top Layer:  Brings the selected object to the top layer. 

Bottom Layer:  Send the selected object to the bottom layer. 

Previous Layer:  Moves the selected object to the previous layer. 

Next Layer:  Moves the selected object to the next layer. 

Normally, an object that is controlled by a PLC Register (i.e., a Word Lamp, Bit Lamp, Animation, etc.) is 
brought to the Top Layer when the value in the PLC Register changes. This behavior can be changed by the 
Object Layout option on the General tab of the System Parameters dialog. A setting of Control sets the 
behavior as outlined above. A setting of Nature (default setting) results in the object remaining at the layer 
assigned during development. 

 The Object Layout setting is global and affects all PLC-controlled objects in the application. 

Nudging Objects 
Nudging is used to fine-tune the movement of objects in the work area of EZwarePlus. Using the nudge 
feature on a selected object will move that object in the specified direction either by one pixel or by the grid 
setting amount. 
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Use the nudge up  , down  , left  , and right   commands (Edit > Nudge or the Nudge 
icons in the Edit toolbar) to move objects on the window. This function is duplicated with the arrow keys on 
the keyboard. 

Aligning Objects 

The alignment tools can be used to quickly align two or more objects. Aligning justifies objects to the desired 
position of the last-selected object. The last selected object will have "handles" of a different color than the 
other selected objects.  

Use the align left  , align right  , align top  , align bottom  , horizontal center  , and 

vertical center  commands (Edit > Align or the Align icons in the Edit toolbar) to clean up the alignment 
of objects on the window. 

Making Objects the Same Size 
This feature is handy if you want to quickly make two or more objects the same size. Objects are sized to the 
size of the last-selected object. The last-selected object will have "handles" of a different color than the other 
selected objects. This is most often used when you are trying to overlap objects that must be the same size. To 
better illustrate, refer to the left side of Window_12 of the sample project: 

To make objects the same width  : 
1. Select the objects you wish to make the same width.  

2. From the Edit menu, select Make Same Size, then Width or click the Make Same Width icon from the 
Edit toolbar. 

To make objects the same height  : 

1. Select the objects you wish to make the same height. 

2. From the Edit menu, select Make Same Size, then Height or click the Make Same Height icon from the 
Edit toolbar. 

To make objects the same size  : 

1. Select the objects you wish to make the same size. 

2. From the Edit menu, select Make Same Size, then Both or click the Make Same Size icon from the 
Edit toolbar. 

Making Objects the Same Color 
This feature can be used to make two or more drawn objects the same color. 

To make objects the same color 

1. Select the objects that you wish to make the same color. EZwarePlus will choose the color of the last 
selected object. 
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2. From the Edit menu, select Make Same Color. The selected objects will all change to the same color 
as the last selected object. 

 

Flipping, Rotating, and Locking Objects 
These three commands allow you to quickly ‘flip’ or position an object in a new direction. 

To flip objects vertically  : 

1. Select the object you wish to flip vertically. 

2. From the Edit menu, select Flip/Rotate > Flip Vertical or click the Flip Vertical icon from the Edit 
toolbar. 

To flip objects horizontally  : 

1. Select the object you wish to flip horizontally. 

2. From the Edit menu, select Flip/Rotate > Flip Horizontal or click the Flip Horizontal icon from the Edit 
toolbar. 

To rotate objects  : 

1. Select the object you wish to rotate. 

2. From the Edit menu, select Flip/Rotate > Rotate 90 Degrees or click the Rotate icon from the Edit 
toolbar. 

To lock an object  : 

Each object position and size can be locked by using the Pin button. When the object is locked, its position and 
size cannot be changed. 
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1. Select the object you wish to lock. 

2. From the Edit menu, select Pinned or click the Pinned icon from the Edit toolbar. 

3. To unlock the object, deselect Pinned from the Edit menu or click the Pinned icon once again in the 
Edit toolbar. 

 

System Parameter Settings 
 

The final section of this chapter shows all the settings or parameters that can be configured using EZwarePlus. 
From the Edit menu, select System Parameters. The System Parameter Settings dialog box appears. The 
dialog box has ten tabs: Device, Model, General, System Setting, Security, Font, Extended Memory, 
Printer/Backup Server, e-Mail, and Recipes. 
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Device tab settings: 
1. Click the New… button. The Device Properties dialog appears. 

 

 You can “export” a project created for one PLC brand to a different PLC brand by loading the 
project file into EZwarePlus, then entering a different PLC type in this box. EZwarePlus will go through 
your entire project and attempt to change each reference to PLC data registers to a logical selection 
for the new PLC protocol; however, we strongly recommend that you review these changes to assure 
that they are satisfactory. 

2. Make sure the PLC button is selected. 

3. There are two choices for Location – either Local or Remote. Select Local if the PLC will be connected 
directly to the HMI. Select Remote if the PLC will be connected to a remote HMI via Ethernet. If 
Remote is selected, then click the Settings button and configure the appropriate IP settings. 
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Ethernet/COM port: Select whether the remote HMI will be connected using Ethernet or a serial 
COM port. You must use the Master-Slave Server protocol when COM port is selected. 
IP Address: Enter the IP address of the remote HMI. 
Port No.: Enter the TCP/IP port assigned to the remote HMI during its configuration (default is 8000). 
Click OK. 

4. Click the PLC type drop-down box and select the appropriate driver for your PLC type. 

5. There are five selections for PLC I/F: 
RS-232 /RS-485 2W / RS-485 4W / Ethernet / USB 
Choose the PLC interface appropriate for your PLC model. 

6. Select the PLC station number for your PLC if appropriate (see Controller information Sheet for your 
PLC) and then click Settings… The COM Port Settings dialog appears. 

 

7. Select the appropriate COM port. This is the COM port used by the HMI. 

8. Select Baud rate, Data bits, Parity and Stop bits. Use Maple Systems’ Controller Information Sheets 
or the PLC manufacturer’s operations manual for information on the communications parameters 
required by the PLC. These parameters must match the PLC settings. 
Timeout adjusts the amount of time (in seconds) it takes for the PLC no response message to popup 
when communication is lost or disrupted between the HMI and PLC. 
Turn around delay adjusts the amount of time (in milliseconds) that the HMI waits after receiving a 
reply before sending the next request. 
Send ACK delay and the Parameter 1-3 settings are optional depending on the PLC type. Refer to the 
Controller Information Sheet for the PLC selected. 

9. The number of resending commands sets the maximum number of retries the HMI will attempt to 
establish communication when communication is lost. When “0” is selected, the HMI will continue to 
retry indefinitely. 

10. Click OK. 

11. PLC default station no.: Defines the station number or unit ID number of the PLC, if applicable (e.g., 
Modbus station number). 
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12. Default station no. use station no. variable: Enables using a Local Word (where LW10000-LW10015 
corresponds to var0-var15) to define the station number. By using the var syntax in the address field 
(e.g., var0#100), the station number can be changed at runtime by changing the value in the 
corresponding Local Word. 

13. Use broadcast command: When enabled, causes the HMI to not expect a response from the station 
number specified by the Broadcast station no. field. 

14. Interval of block pack (words): Determines how many words are read from the PLC in one 
communication cycle. For more information on this feature, select Help> Help Topics in EZwarePlus 
and select Miscellaneous > Optimizing the Update Rate With PLC Block Pack.  

15. Max. read-command size (words): The maximum data size to be read from a device at one time. 
 The Interval of block pack (words) setting must be less than this setting. 

16. Max. write-command size (words): The maximum data size to be written to a device at one time. 

17. Refer to chapter xx for details on the Address Mapping Table and Modbus Gateway. 

18. Click OK. 
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Model tab settings: 

 

1. HMI model: Select the HMI model that you are programming. 

2. HMI station no.: When multiple HMIs are used, this selects the unique network address of the HMI. 
See Controller Information Sheet for more information. 

3. Port No: Assign a TCP/IP port so that another HMI can access this port. For more information, select 
Help > Help Topics > How Do I…Setup TCP Port Forwarding With the HMI. 

4. Support CloudHMI communications protocol: reserved for future use. 

5. Clock Source: Select internal HMI RTC or External Device. 

6. Printer Type: Select type of printer to be connected locally to the HMIs serial port or USB port. 

7. Scroll bar: select the size and appearance of the scoll bar(s) on certain display objects. The scroll bars 
appear automatically as needed. 
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8. Pass through: select the Port Number to use in Pass-Through mode. The same setting needs to be 
made in the Utility Manager when Pass-Through is selected. 

 

Auto Resizing Using the Model Tab 

This tab can be used to automatically resize your project when changing to another HMI model with a 
different size touchscreen. The project and all objects and graphics will be proportionately resized 
automatically. 

 To auto resize your project using the Model tab in the System Parameters dialog: 

1. In the Model tab, select a different display size from the HMI model drop-down box and click OK. 

2. The Resize popup windows/objects dialog appears. 

 

3. Check all the resize options and then click OK. The project will automatically resize. 
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General tab settings: 

 

1. Fast selection button: The Attribute: drop-down enables or disables the fast selection button, which 
is used to open the Fast Selection window (window number 3). The Settings button sets the look of 
the button including shape and color. The Position drop-down sets the fast selection button on either 
the lower left or lower right portion of the display. When checked, the Hide button when HMI starts 
option causes the fast select button to be hidden when the HMI starts. Use Local Bit 9014 to control 
the Fast Select button. Clear the bit to show the button and set the bit to hide it. 

2. Screen Saver: The Back light saver sets the number of minutes (none-255) of inactivity after which 
the backlight is turned off. If the value None is selected, then the back light saver is disabled. 
 The backlight is re-triggered when the screen is touched or when an alarm occurs (if the Enable 
back light when alarm occurs option is selected). 
 

Screen Saver sets the number of minutes (none-255) of inactivity after which the screen saver is 
activated. If the value None is selected, then the screen saver is disabled. 

Saver window no. designates the window that will be used as the screen saver. 
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3. Options: The Startup window no. selects the window number that will be displayed every time the 
HMI is started up. Window 10 is the default startup window. 

The Common window determines if objects in the common window (window 4) are placed above or 
below the base window. 

The Object layout drop-down determines the layout and display of objects by selecting either Control 
mode or Nature mode. 

 Normally, an object that is controlled by a PLC Register (i.e., a Word Lamp, Bit Lamp, Animation, 
etc.) is brought to the Top Layer when the value in the PLC Register changes. This behavior can be 
changed by the Object layout option. A setting of Control sets the behavior as outlined above. A 
setting of Nature (default setting) will result in the object remaining at the layer assigned during 
development. 

The RW_A enabled checkbox enables an extra 64K of recipe storage memory. 

4. Event: When the Use LW9450-9455 as time tags of event logs box is checked, the Time/Date stamp 
for items in the Event Display will be taken from Local Words LW9450-9455. You can select the data 
format of the Time/Date stamp – BCD (binary-coded decimal) or BIN (16-bit signed decimal). 
If unchecked, the Time/Date stamp is taken from the selected clock (HMI RTC or External). 

Extra No of events: N/A 

5. Keyboard: Lists the windows that have been configured as keyboards.  

Add: Opens a window list from which you can select an additional window to be available as a project 
keyboard. 

Delete: Deletes the selected keyboard from the list. 

The Caret color drop-down allows you to set the color of the cursor in the Numeric Input object when 
the keyboard is activated 

The Select color drop-down allows you to set the highlight color in the Numeric Input object when 
the keyboard is activated. 

6. Project protection: When checked, the HMI will compare the value in the Project key field to the 32-
bit unsigned value stored in HMI Local Words LW9046 and LW9047. If the value is different, the HMI 
will not run the project. 
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System Setting tab settings: 

 

1. Startup language after redownloading the project: Select the language that the HMI is to use when 
restarting after a download. 

2. Execute init. MACRO when power on: When checked, the HMI will execute the selected macro on 
startup. Available only when one or more macros exist in the project. 

3. Auto logout: When checked, the HMI will automatically log out of security if no touchscreen activity 
is detected during the specified interval. The time interval can range from 1 -256 minutes. 

4. Hide system setting bar: When checked, the HMI will not display the button in the lower-right corner 
that displays the System Setting toolbar. Local Bit LB9020 can be used to control the button. Set the 
bit to show the button and clear the bit to hide the button. Local Bit LB9062 will cause the System 
Setting dialog window to open when set. 

5. Hide mouse cursor: When checked, the HMI will not display the mouse cursor. Local Bit LB-9018 can 
be used to control the mouse cursor. Set the bit to hide the cursor and clear the bit to show the 
cursor. 
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6. Disable buzzer: When checked, the HMI will not sound the buzzer (beep) when the screen is touched. 
Local Bit LB9019 can be used to control the buzzer. Set the bit to disable the buzzer and clear the bit 
to enable the buzzer. 

7. Prohibit remote HMI connecting this machine: When checked, the HMI will not allow connections 
from a remote HMI. Local Bit LB9044 can be used to control remote connections. Set the bit to 
disallow remote connections, clear the bit to allow remote connections. 

 This setting controls whether or not other HMIs can connect to this HMI. It does not affect how 
this HMI connects to other HMIs. 

8. Disable upload function (effective after rebooting HMI): When checked, prevents the project from 
being uploaded from the HMI (sets LB9033 ON). Reports “error: uploading /mt8000/001/mt8000.” 

9. Prohibit password remote-read operation: When checked, a remote HMI cannot read from the local 
words containing the Project and User password data (sets LB9053 ON). 

10. Prohibit password remote-write operation: When checked, a remote HMI cannot write to the local 
words containing the Project and User password data (sets LB9054 ON). 

11. Use a disconnection icon on relative objects when PLC communication fails: When checked, any 
object that cannot be resolved due to communication loss will be displayed with a special icon: 

  

12. VNC server: Check Password from project to use the password entered in the adjacent Password box 
for a VNC client to use to connect to the HMI’s internal VNC server. When not checked, use the VNC 
password entered in the HMI’s System Settings VNC Server Setting tab.  

 The VNC Server Password is stored in Local Words LW9530-9537. 

13. VNC Server: Check Monitor Mode to allow VNC Client(s) to connect to the HMI, but not allow the 
client(s) to change any data.  

 This setting is also controlled by Local Bit LB12088. 

14. LW protection: When checked, remote HMI(s) are prevented from writing to the range of Local Word 
addresses specified in the LW range boxes.  

15. RW protection: When checked, remote HMI(s) are prevented from writing to the range of Recipe 
Word addresses specified in the RW range boxes.  

16. EasyAccess server: Check Login EasyAccess server to enable EasyAccess in the HMI. See Technical 
Note 5082, “Using EasyAccess” for more information. 
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Security tab settings: 

 

The Security tab is used to set up a table of users, user levels (access classes), and passwords. When General 
mode is selected, up to 12 users can be individually enabled, and each has a unique password and 
combination of any six access classes (A-F). Only numbers are allowed for passwords. When an object is 
created, it can be assigned an access class. When that object is activated (for example, a button is touched), 
the HMI compares the access classes allowed for the currently logged-in user to the access class specified for 
the object. If the access class of the object is within the classes allowed, the object’s action is executed. 

The access class for an object is configured in the User restriction section of the Security tab for that object. 
So, for example, if you wish to set the access class for a set bit object, click on the Security tab of that object’s 
properties dialog, as shown below: 
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The object can be configured to handle insufficient security in one of two ways: 

• The object can be hidden while security is not sufficient (Make invisible while protected). 

• The HMI can display the message defined as Message 1 in the System Message object  
(Display warning message if access denied). 

There are a number of local HMI addresses that can be used with the security features. 

Address Description Data Type Notes 

LB9050 Reset security level to 0 (no security) Boolean Set momentarily to trigger. 
Also serves as user logout. 

LB9060 Invalid password Boolean Set by the HMI when an invalid 
password is entered. Must be 

  LB9061 Load new passwords Boolean Loads new passwords as defined by 
LW9500-9523 

LW9219 User level 16-bit unsigned Set to 1-12. Determines which 
password is used. 

LW9220 Password 32-bit unsigned Enter password into this address to 
change the security level 
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LW9222 Current access classes 16-bit binary Indicates the Access Classes currently 
allowed. Bit 0 indicates Class A; Bit 5 
indicates Class F. 

LW9500, 
LW9501 

New password, user 1 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9502, 
LW9503 

New password, user 2 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9504, 
LW9505 

New password, user 3 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9506, 
LW9507 

New password, user 4 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9508, 
LW9509 

New password, user 5 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9510, 
LW9511 

New password, user 6 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9512, 
LW9513 

New password, user 7 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9514, 
LW9515 

New password, user 8 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9516, 
LW9517 

New password, user 9 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9518, 
LW9519 

New password, user 10 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9520, 
LW9521 

New password, user 11 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

LW9522, 
LW9523 

New password, user 12 32-bit unsigned Loaded into security system when 
LB9061 is set momentarily 

 
To log out a user, use a Set Bit Object to momentarily set bit LB9050. 

When Enhanced security mode is selected, each user can be assigned up to twelve access classes (A-L). 
Passwords and User Names can be alphanumeric, which are stored in local memory as assigned by the Control 
address. One user is reserved as an administrator, which has complete access. The Option List object can be 
configured to display the User Names, providing a quick way to select a user to log-in. 

In addition, up to 127 more user accounts can be added using the Administrator Tools. See “Chapter 13 – 
Security” and “Chapter 14 – Administrator Tools” for more information. 

 

Project password (MTP file): Select this option to set a password in order to prevent unauthorized users from 
opening and editing a project. The correct password must be entered in order to open the password-
protected project. 
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Font tab settings: 

 

Determines the fonts available for non-ASCII strings. If a non-ASCII character set or double-byte character set 
is used (e.g., simplified Chinese, Japanese, Korean, etc.) but not listed in the Fonts for non-ASCII strings table, 
EZwarePlus will select a font from the list to substitute for it automatically. To add a Windows TrueType font 
that is on your computer, click Add... and select the font from the drop down menu that appears, and click OK. 

 

Line spacing: Select the spacing between lines of text, with a range of 0 (closest) to 6 (widest). 
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Extended Memory tab settings: 

 

The Extended Memory tab is used to configure the extended memory for saving data to an SD card or USB 
flash drive. There are 10 files that can be configured for saving data, em0.emi through em9.emi. Each 
extended memory location can be accessed using the Device Type setting in an object’s properties. There is no 
address limitation for the extended memory other than the size of the SD card or USB drive connected to the 
HMI. The HMI will assume 16-bit data registers for unused addresses, so if address 100 is used for em0.emi, 
the memory storage must have at least 200 bytes of available memory. 

 Extended memory files (*.emi) can be edited and converted to *.csv file format using the Recipe/Extended 
Memory Editor, which can be opened with Utility Manager. 
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Printer/Backup Server tab settings: 

 

1. Check the Use Remote Printer/Backup Server checkbox to enable the HMI to print to a printer 
connected to a PC on the network or backup files to a PC on the network. 

 The EasyPrinter utility (included with EZwarePlus and accessible through Utility Manager) must be 
running on the PC with the network printer connected. 

2. In the Output settings section, select page layout (horizontal or vertical), print area size, and margins. 

3. In the Communications settings section, set the settings for the PC hosting the printer. 
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E-Mail tab settings: 

 

 

The e-Mail tab is used to enable and configure the email feature in EZwarePlus. Alarms can be configured to 
automatically send an email to a list of recipients when the alarm occurs and when the alarm is cleared. In 
addition, a screenshot of the HMI’s screen can be attached to the email. 

Enable e-Mail function: Check this box to enable the emailing feature. 

Use existing contact settings on HMI: Email SMTP settings and contacts can be imported to the HMI from a 
USB flash drive using the Administrator Tools. When this box is checked, emails will be sent using the settings 
in the HMI. 
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SMTP settings: SMTP (Simple Mail Transfer Protocol) is an internet standard for sending email across IP 
networks. Contact your IT or LAN administration staff for specific information on entering the SMTP settings. 

 Server: Enter the SMTP server address for your particular email provider. 

 Port: Enter the port number used by the email server for SMTP communications. 

User name: Enter the user name that the email account requires (usually the email address). 

Password: Enter the password associated with the email account. 

Confirm Password: Enter the password again. It must match the first password entry. 

Log on using Secure Password Authentication (SPA): Check this box if your email server requires 
Secure Password Authentication. 

Use the following type of encrypted connection: Check this box if your email server requires TLS or 
SSL encryption. 

Sender information: Configures how the sender (HMI) will appear to the recipients. 

Name: Check “Use HMI name” to use the name assigned to the HMI in the System Parameters Device 
List. If unchecked, a name can be assigned in the field below. 

 Mail address: This is the “From” email address as it will appear in the email that is sent. 

See “Chapter 12 – Capturing Alarms and Events” for more information on using the email feature. 
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Recipes tab settings: 

 

There are two methods for creating and storing recipes in EZwarePlus. One method uses the RW memory in 
the HMI to store data and LW9000 to index (jump) from one recipe to another. The data can be entered 
manually using Numeric Input objects or imported as a *.rcp file from the Recipe Editor. 

Another method stores the data in a database file (*.db) in the HMI. The recipe format (definition) is created 
in the Recipe tab of the System Parameters and the data is entered manually in Offline or Online Simulation 
mode using the Recipe View object and Numeric Input objects, or edited directly in the database file using the 
Recipe Database Editor (Tools > Recipe Database Editor). 

Click the “Add New Recipe” button   to create a new recipe. There are six parameters to define for the 
recipe records in a new recipe. 

1. Item name: Provides a name for the recipe record, usually an alphanumeric name, occupied by the 
first column when displayed in the Recipe View object. 

2. Data type: Defines the type of data that is used for each element in the recipe record (i.e., ASCII, 16-
bit unsigned, 32-bit float, etc.). 
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3. Size: Defines the number of words for each element in the recipe record. Adjustable only for the 
ASCII, Unicode, and High/Low Reversed data types. All other data types set this field automatically. 

4. Display width: Defines the width of the data to be displayed in number of characters. This includes 
the sign, decimal point, and all digits to the left and right of the decimal point. 

5. Decimal Pt.: Defines the number of digits to the right of the decimal point. 

6. Alignment: Defines how the data will be aligned in the Recipe View cell (Align left, Align center, Align 
right). 

Click the New button to add items (data fields) to the recipe after the selected item. Each new item adds a 
column to the recipe when viewed in the Recipe View object. 

Click the Settings button to edit the parameters for the selected item in the Recipes Item Information popup 
window.  

 

The parameters can also be edited directly in the item list in the Recipes tab. 

Click the Delete button to delete the selected item from the list. 

Click the Up/Down arrow buttons on the right side of the Recipes tab to move the selected item up and down 
in the list. 

Click Export definition file of recipes to save the recipe definitions in a *.rdef file. This can be imported into 
the Recipe Database Editor for adding data to the recipe. 

See “Chapter 15 – Recipes” for more information about using recipes in EZwarePlus. 
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Reboot HMI 
EZwarePlus can automatically reboot the HMI after download. 

To enable automatic reboot of HMI after download: 

1. From the Tools menu, select Download. The Download dialog box is displayed. 

2. Check the Reboot HMI after download checkbox. 

3. Click OK. 

To manually reboot HMI: 

1. From the Tools menu, select Reboot HMI. 

2. Select Ethernet or USB cable. 

3. You can reset the recipe, recipe database, event log, and data sampling by selecting the 
corresponding checkbox. 

4. Click Reboot HMI. 

Save and Compile the Project 
EZwarePlus can automatically save and compile the project when downloading or simulating. 

To enable automatic save and compile 

1. From the Option menu, select Function Property. The Function Property dialog box is displayed. 

2. Check the Automatic save and compile when download and simulate checkbox. 

3. Click OK to exit the Function Property dialog box. 

EZware-500 Project Translation Utility 
EZwarePlus has a translation utility that will convert projects created in EasyBuilder-500 into a project format 
that can be read and modified using the EZwarePlus software. Below is a brief description of how to use this 
utility (for more information, download technical notes on this subject from Maple Systems’ website): 

To convert a *.eob (EasyBuilder-500 compiled project) into a *.mtp (EZwarePlus project): 

1. From the Tools menu, click Translate HMI500 Project: 
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2. Click the Browse… button for the HMI500 EOB file and select the EasyBuilder-500 project file you 
wish to convert. 

3. By default, the converted file is automatically placed into the same directory. To modify the name of 
the file or location, click the Browse… button for the HMI5000P project file. 

4. Default font: All text objects in theEasyBuilder-500 project file use a proprietary fixed font. When 
converting to an EZwarePlus project, these text objects are converted to TrueType fonts. Use this 
section to specify which TrueType fonts you wish to use. 

 The EZware-500 configuration software uses proprietary fonts that must be replaced with a 
Windows TrueType font. EZwarePlus installs three TrueType fonts into the Windows > Fonts folder 
that closely resemble the fonts used in EZware-500 (HMI 500 16p, HMI 500 24p, HMI 500 8p). Select 
Use HMI500 ASCII font files to use these fonts. If you choose to use another Windows TrueType font 
(by unchecking Use HMI500 ASCII font files), additional ‘tweaking’ may be required after you have 
converted your project. We recommend using Calibri if you have this font available on your 
computer. Otherwise, another san serif font like Helvetica should work. 

You can allow EZwarePlus to automatically adjust the font size for you by selecting Use the most 
suitable font size automatically. If you uncheck this box, you can click on the Font Size Table button, 
which allows you to customize the transition size of the fonts from EasyBuilder-500 to EZwarePlus 
projects. This gives you maximum flexibility in deciding which font and which sizes you would like to 
use. For the Calibri font, we recommend those items as shown in the table below. 
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5. Delete “Direct Window” objects which are triggered with LB9060~9069, 9080, 9081, (HMI5000-
series use a new mechanism to manage keyboards.): Check this box to delete any Direct Windows 
objects in the EasyBuilder-500 project file that are triggered by the internal local memory bits 
LB9060-LB9069, LB9080-LB9081. 

 In EasyBuilder-500, these local memory bits allowed a popup window to appear in the display 
based upon touching any Numeric Input or ASCII Input object located in a particular area of the 
screen. This feature is not available in EZwarePlus. By default, this option is checked. 

6. Click the Translate button to begin conversion of the file. When done, you will see text in the 
comments field that indicates if the conversion is successful. 

 

7. Click the Exit button to go back to the main screen of EZwarePlus. Open the converted file as you 
would normally open any EZwarePlus project file. 

 Due to some incompatibilities between the EZware-500 software and the EZwarePlus software, 
you should check each screen and test operation after conversion to make sure that your HMI works 
to your satisfaction. 

 The Shape Library and Picture Library file formats in EZwarePlus are different than those used in 
EasyBuilder-500. When a project is translated, EZwarePlus creates new libraries with the same file 
name as the translated project containing the shapes and pictures (bitmaps) from the original 
EasyBuilder-500 project. For example, if a 500 Series project is translated and saved with the filename 
“PumpStation4.mtp,” a Shape Library is created with the name “PumpStation4_0.plb” and a Picture 
Library is created with the name “PumpStation4_0.flb” and saved into the EZPlus Library folder 
(C:\MapleSystems\EZPlus\library). 
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Chapter 7 – Creating Windows 
This section shows how to create and use windows in EZwarePlus.  

Window Fundamentals 
An operator interface terminal wouldn’t be very useful if all of the information to be displayed could only be placed 
onto one screen. Therefore, most HMIs have multiple screens that you can use to display information. The Maple 
Systems HMI5000P/L are capable of storing up to 1999 windows (actual limit is determined by memory requirements 
of each screen), giving you maximum flexibility in designing your operator interface. We prefer to call these screens 
‘windows’ because they have several features not normally associated with screens: 

• Windows can be created in any size. You can make the window full-sized so that it fits the entire area 
of the HMI display or you can create a window that partially covers the display. 

• Windows can be overlaid on top of each other. All data on each window displayed is updated 
continuously regardless of whether or not it is covered up by another window. 

• Windows can be moved around the HMI display to allow portions of other windows to come into view. 

The HMI5000P/L Series has four basic types of windows available for use: Base windows, a Common window, System 
Message window, and a Fast Selection window. Base windows are the windows that you will most often use. The 
Common window and Fast Selection window are two windows reserved for special functions. System Message 
windows are reserved for custom messages from the controller. By the end of this chapter, you will be able to create 
these windows and use the many features available to them. 

Opening and Closing a Window 
To view the contents of a window in EZwarePlus, it must first be opened. When you create or open an existing project 
file, only the initial window is opened. To view any other windows that have already been created, you must first 
open the window. This can be done using the Window Tree (see Chapter 6, “Using EZwarePlus,” Display Options) or 
by performing the following: 

To open a window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

 

2. Click on the Window you wish to open. Then click Open.  
 You can also open the window by double-clicking the window. 

3. The Open Window dialog box closes and the opened window is displayed in the EZwarePlus work area. 
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The Open Window dialog box lists all of the windows currently created for the project. An asterisk next to a Window 
indicates that the window has already been opened. Each window is listed with the Window name and size. The 
window name is the name that you assign to the window when it is created. The window size is shown for quick 
reference. Finally, you will notice that the Open Window dialog box is also used to create a new window or change 
any of the settings for a window.  

By default, when a window is opened it will replace any window that was displayed in the work area of EZwarePlus. 
To switch between open windows, click the Window menu and select from the list of windows currently open. You 
can also cascade (select Window-Cascade) or tile (select Window-Tile) the open windows to see the windows at the 
same time. 

EZwarePlus requires more resources from your computer every time you open another window. When many 
windows are open, the performance of the computer may be affected. Therefore, you may wish to close some of the 
windows until you need to edit them. 

To close a window: 

1. You will notice three small icons located in the upper right hand corner of each window: the minimize icon 

 , the maximize icon  , and the close icon  . To close a window, click the close icon associated with 
that window. These icons show in the window if minimized. Otherwise, the icons are located on the 
rightmost end of the menu bar of EZwarePlus. 

2. There is a close icon on each window tab as well, located just above the work area. 

Creating a New Window 
Whenever you create a new project, several windows have already been created by EZwarePlus: 

#3: Fast Selection – The window controlled by the Fast Sel button that appears on every window (when enabled in the 
System Parameters > General tab). This allows you to quickly jump to commonly accessed windows or objects by 
placing Function Keys on the Fast Selection window. 

#4: Common Window – A window that displays graphics (such as a company logo) or objects that are always on every 
screen of the display. The common window runs below every other window that is being displayed on the HMI. 

#5: PLC Response – This is the window that is displayed when the HMI loses communications with the PLC. 

#6: HMI Connection – This is the window that is displayed with the HMI loses communications with a remotely 
connected HMI. 

#7: Password Restriction – This is a window that is displayed when access is attempted on a protected object without 
the proper password. 

#8: Storage Space Insufficient – This is a window that is displayed when the available memory in the HMI, USB Flash 
drive, or SD card is running low.  

#10: Startup Window – The window that displays whenever the HMI is started up. The Startup window can be 
redefined in the System Parameter Settings, on the General tab. 

#50-65: Various Keypads– A selection of different style keypads to use for numeric or alphanumeric entry including 
Integer, Hex, Floating, and ASCII. 

The remaining windows are available to be created as you desire for your project. In order to create new windows, 
the following steps must be performed. 
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To create a new window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

 

2. Click New… The Select Window Style dialog box appears. 

 

3. Click Base Window. If the Fast Selection and Common Window buttons appear grayed out, then it is because 
those windows have already been created. The Window Setting dialog box appears. 

 

4. Modify the window parameters, then click OK. The Open Window dialog box reappears. 

5. If you wish to open the window you just created, click on the window and click Open. Otherwise, click Exit to 
return to the main screen of EZwarePlus. 

6. An alternate method of creating a new window is to right-click on an unused window number in the 
Windows Object List and select New. The Window Settings dialog opens. 
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Window Settings 
Let’s look more closely at the parameters you can change when creating a new window. 

 When a window is initially created, the window settings can be edited to make changes; however, once a window 
has been created, the window number cannot be changed. To change the window settings, highlight the desired 
window in the Open Window dialog and click on the Settings... button. 
Alternately, right-click on the desired window in the Windows Object List and select Settings. 

Assigning a Window Name 
The Name is a description box used to help you identify what the window is used for without having to actually open 
the window and look at the contents. Up to 50 characters can be entered into this field with space characters 
allowed. 

Assigning the Window Number 
Although 1999 windows are available on the HMI5000P/L Series, two are specifically reserved for the Common 
Window and the Fast Selection window and several are reserved for internal use. Therefore, you can assign #10-1999 
to any window you create. When you initially create a window, EZwarePlus will automatically assign the lowest 
available number to the window. However, once you create the window you can go back into the Window Settings 
and reassign it to any number within the allowed range. In this manner, you can group windows together that may 
share some common traits. 

Assigning Size of Window 
You can vary the size of a new window to create full screen or popup windows. Popup windows are most often used 
to display data that does not need to be on the HMI display all of the time. For example, you might want to configure 
an instructional message in a popup window that can be moved aside or closed when not needed. The message can 
be triggered to pop up when needed or appear with a keypress.  

Assigning a Position 
This is the starting position that the window goes to when it is initially called onto the HMI screen as a popup window. 
The starting position is labeled Start Pos: in the Window Setting Dialog box. The X and Y positions refer to the pixel 
location of the HMI display at which the upper left-hand corner of the window is to be displayed. 

The default setting is X=0 and Y=0 which is the upper left-hand corner of the HMI display. The X-axis refers to the 
horizontal location and the Y-axis refers to the vertical location.  

Monopoly Feature 
The monopoly feature is used to ‘monopolize’ all touchscreen action that can occur on the HMI screen. For instance, 
suppose the HMI display is currently showing a full screen window with several objects. If a popup window is 
displayed that does not have the monopoly feature enabled, the HMI operator is able to press and activate any 
objects on the popup window or the full screen window since objects on both screens are active. 

If another popup window is displayed that does have the monopoly feature enabled, then the objects on the full 
screen window will not respond when pressed. 

Please note that the monopoly feature only disables touchscreen objects on the full screen window. Objects on other 
popup windows can still be activated. 

The monopoly feature can be used to display a popup window with some action that the HMI operator must perform 
before being allowed to do some other action on the HMI. For example, you might construct a dialog box that asks 
the HMI operator if some step in the control process has been performed. The dialog box would have Yes and No 
function key options which, with the monopoly feature enabled, the HMI operator must press before continuing. 
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Assigning Underlay Windows 
An Underlay Window is a Base Window that is displayed at the same time as the Base Window that calls it. Each full-
size Base Window can display up to three underlay windows. A popup window cannot display any underlay windows. 
There may be times when it is desirable to place the same information on multiple (but not all) windows. Underlay 
windows provide a means to accomplish that without the overhead of a Direct or Indirect Window, and without using 
the Common Window (which makes the information visible on all windows). Underlay windows also eliminate the 
need to actually place the same objects on multiple windows, which increases the memory required for the project. 
Each base window can display up to three underlay windows, which are called Bottom, Middle, and Top. 

How to Display Underlay Windows 
When you have common objects to display on multiple screens, use the underlay window feature to store these on 
underlay windows attached to a base window. This decreases the amount of memory required for the project. The 
base window “calls” the underlay window. Each full-size base window can display up to three underlay windows, 
which are called Bottom, Middle, and Top. Objects on the underlay windows cannot be edited from the base window 
on which they are displayed. 

 It may be desirable to use Underlay Windows but temporarily hide them when developing the project. 

The  button on the Standard Toolbar toggles the visibility of objects on Underlay Windows. 

 

 A popup window cannot display any underlay windows. 

To assign underlay windows to a base window, you must first create the underlay windows. Underlay windows are 
created the same way base windows are created. Then you can assign the underlay windows to the base window. 

To assign underlay windows to a base window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Highlight the base window you wish to use. 

3. Click the Settings… button. The Window Setting dialog box appears. 

4. Click the pull-down list box for each Underlay window selection to assign the underlay window screens to the 
base window. 

5. Click OK. Click Close on the Window Setting dialog box. 

Rules That Apply to Underlay Windows 

• Only the objects of an underlay window are displayed on the base window. All background 
information about the underlay window (i.e. background color, frame color and size, etc.) are not 
displayed on the base window. 

• Active objects can be ‘overlaid’ on top of each other over two or more underlay windows. For 
example, a Set Bit object that is configured to set an HMI local bit LB0 is located at X=20, Y=50 for 
Underlay Window #1. Another Set Bit object that controls LB1 is placed on Underlay Window #2 at 
the same location. When the Base Window displays these two windows, both objects will be active 
so that when they are pressed both LB0 and LB1 will be set. 

• Static objects may be overlaid using underlay windows. However, any static object that is on the 
Base Window has the highest precedence and will be displayed over any static objects that are on 
the underlay windows. Active objects have higher precedence over static objects. 

• Popup windows cannot display underlay windows. 
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• Underlay windows are always positioned from the top left corner of the screen. Any position 
settings you make when creating the underlay window are ignored when the window is displayed 
by a Base Window as an underlay window. 

For more information and an example of how to use underlay windows, consult the EZwarePlus Help files. 

Creating a Frame 
The Window Settings dialog provides the option of having a frame around any window that you create. You can 
create a frame from 0-16 pixels wide in any of the EZwarePlus 65K available colors. 

Window Background 
You can also select a different background color for each window created. The default setting is black. 

To select a different background color: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Click on the window that you wish to change the background color. Click Settings. The Window Setting dialog 
box appears. 

3. In the Background section, check the Filled box. 

4. Click the pull-down arrow of the Color box. The Color dialog box appears. 

5. Select from one of the basic colors or add new colors from the customized list of colors. To create a 
customized color, click on the Custom button at the bottom of the Color dialog box.. 

6. The color table dialog box appears allowing you to select or modify one of the colors available. 

7. Click OK in the Color dialog box to go back to the Window Setting dialog box. Click Close to return to the 
EZwarePlus main screen. 

Instead of using a solid background color, you can select a pattern that is displayed in the background of a window. 

To select a background pattern: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Click on the window that you wish to change the background pattern. Click Settings. The Window Setting 
dialog box appears. 

3. In the Background section, check the Filled box. Select a background color as described above. 

4. Click the pull-down arrow of the Pattern box and select a pattern, then click OK.  

5. Click the pull-down arrow of the Pattern color box and select a color. 
 To use the background pattern, the color selected for Pattern color must be different then the color 
selected for the Background color. 

6. Once a pattern color is selected, click OK in the Color dialog box to go back to the Window Setting dialog box. 

7. Click Close to return to the EZwarePlus main screen. 

Deleting a Window 
Before any window can be deleted from a project, the window must be closed. To close a window, see the section 
earlier in this chapter on opening and closing windows. 

To delete a window: 
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1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Highlight the window that you wish to delete. 

3. Click the Delete button. A dialog box appears asking if you want to delete this window. 

4. Click Yes. The dialog box disappears and the selected window is deleted. 

5. Click Close in the Open Window dialog box to go back to the EZwarePlus main screen. 

 If the Delete button does not appear when the window is highlighted, this means that this is a Window that can't 
be deleted. Typically, if you are unable to delete a window, it is because it is one of the predefined windows discussed 
earlier in this chapter or the window is still open. 

Using Base Windows 
Of the four types of windows, base windows are the most commonly used. A base window is used to create a full 
screen window or a popup (partially sized) window. Popup windows can also be moved about on the HMI display and 
can overlap each other. The number of objects that can be placed onto each base window is limited only by the total 
amount of memory available within the HMI. 

How to Display Base Windows 
Base windows can be displayed on the HMI screen by using a function key to display the window or by using the PLC 
to call up the window. 

Using a Function Key 
The Function Key Object is a graphic touch object that is placed onto a window to perform an action. Function keys 
have many purposes, but two actions that a function key can perform are: 
•  Calling a full screen window 
•  Calling a popup window 

Calling a full screen window 

If a function key object is created to call a full screen window, the window that is displayed replaces all other windows 
that are on display regardless of how many are open; therefore, think of calling a full screen window as performing 
two actions -- closing any open windows and displaying a full screen window. 

 

To call a full screen window using a function key object: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box appears. 

2. In the General tab, click the Change full-screen window option button. 

3. In the same section, enter the Window No. you want to call. 

4. Select the Shape tab, click the Use shape or Use picture checkbox, and then click the Shape Library button 
or Picture Library button. Select the shape or bitmap you wish to use to represent the function key and click 
OK. 

5. Select the Label tab and check Use label and create a label for the function key. 

6. Click OK to return to the main screen of EZwarePlus. 

7. Place the function key object where you want it on the window you are editing. You must select a window 
that is full size when using the Change Window function. 
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Calling a popup window 

If a function key object is created to call a popup window, the window that is displayed is generally overlaid over all 
other windows that are on display. Think of calling a popup window as opening another active window for display. 

To call a popup window using a function key object: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box appears. 

2. In the General Tab, check the Display popup window option button. Note that the Close this popup window 
when parent window is closed checkbox will cause the popup to close automatically whenever the base 
window changes. 

3. In the same section, enter the Window No. you want to call. 

4. Select the Shape tab, click the Use shape or Use picture checkbox, and then click the Shape Library button 
or Picture Library button. Select the shape or bitmap you wish to use to represent the function key and click 
OK. 

5. Select the Label tab and check Use label and create a label for the function key. 

6. Click OK to return to the main screen of EZwarePlus. 

7. Place the function key object where you want it on the window you are editing. You must select a window 
that is less than full size when using the Popup Window function. 

To display a full screen or popup window, press the touchscreen where the function key object is located. The 
window displays in the location on the HMI display as determined by the X and Y position in the Window Settings box 
for that window. 

Using the PLC 
Three objects are used by the PLC to call or display a base window. The PLC Control Object is used by the PLC to 
display full screen windows. The Direct and Indirect Window Objects are used by the PLC to display popup windows. 

The PLC Control Object 

The PLC can display a full screen window by using the PLC Control Object. This object allows the HMI to continuously 
scan a PLC register to display a full screen window, which corresponds to the number in the PLC register. 

Once the HMI displays a window that is requested by the PLC Control Object, the HMI will automatically write the 
number of the requested window to the next consecutive register. For example, if you assign a Modbus holding 
register 4x10 to a PLC Control Object/Change Window and the number 3 is placed into this register, then the HMI will 
display Window #3. Finally, it will put the number 3 into 4x11. This allows the PLC to confirm that the window has 
been properly displayed by the HMI. 

You can create as many PLC Control Objects as you need -- each object is universal and is not dependent upon which 
HMI window is currently on display. 
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To call a full screen window using the PLC Control object: 

1. From the Objects menu, select PLC Control. The PLC Control Object dialog box appears. 

 

2. Click New.... The PLC Control dialog appears. 

 

3. Select Change window from the Type of control drop-down box in the Attribute section. 

4. Click the Setting… button in the Trigger address section and select the Device type and Address for the 
actual PLC address you wish to monitor. 
 The HMI will write the number of the newly-displayed window to the next consecutive address after the 
address specified in this step. 

5. Select the format from the drop down menu (e.g., 16-bit or 32-bit unsigned, signed or BCD). 

6. Click OK to return to the PLC Control dialog box. Click OK again to return to the PLC Control Object dialog box. 

7. You will see a new entry that lists the PLC address that is monitored by the HMI. 
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The PLC must only enter window numbers that represent full-size windows when using the PLC Control Object 
function. The HMI automatically closes any open windows before the window called by the PLC Control Object is 
displayed. 

The Direct and Indirect Window Objects 

If you want the PLC to call up a popup window that is to be overlaid on top of other windows already open, then 
there are two methods used to do this: 
•  Direct Window Object 
•  Indirect Window Object 

 Unlike the PLC Control Object, the Direct and Indirect Window Objects are only active for the windows into which 
they are placed. 

The Direct Window Object is used to display a popup window using a PLC coil. The HMI continuously reads the value 
of the PLC coil to determine its state. If the trigger state is detected, then the designated popup window is displayed 
within the frame of the Direct Window Object.. 

The Indirect Window Object is used to display a popup window using a PLC data register. Similar to the PLC Control 
Object, the HMI continuously monitors the selected PLC data register. It will display any popup window that 
corresponds to the number placed into the PLC data register by the PLC. 

The PLC must reference a window that is less than full size when using the Direct Window and Indirect Window 
objects. 

To call a popup window using the Direct Window Object: 

1. From the Objects menu, select Direct Window. The New Direct Window Object dialog box appears. 

 

2. Select the trigger state in the Trigger drop-down box (ON or OFF). 

3. Click the Setting… button in the Read address section and select the PLC address according to Device type 
selected from the drop down menu and then enter the address. 

4. Select the format from the drop down menu and click OK. 

5. Select the Window No. you want to call from the drop down menu under the Attribute heading. 
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6. Click OK to return to the main screen of EZwarePlus. The mouse cursor will have a square object that 
represents the size of the popup window. 

7. Place the Direct Window object where you want the popup window to appear. 

8. The Direct Window object should be the same size as the popup window it is calling. You can resize the 
object after you have placed it by clicking on the object and dragging on the sizing handles or selecting the 
Profile tab in the Direct Window Object’s Properties window and adjusting the Width and Height settings. 

To call a popup window using the Indirect Window Object: 

1. From the Objects menu, select Indirect Window. The New Indirect Window Object dialog box appears. 

 

2. Select Click the Setting… button in the Read address section and select the PLC address according to Device 
type selected from the drop down menu and then enter the address. 

3. Select the format from the drop down menu and click OK. 

4. Click OK to return to the main screen of EZwarePlus. The mouse cursor will have a square object that 
represents the size of the popup window. 

5. Place the Indirect Window object where you want the popup window to appear. 

6. The Indirect Window object should be the same size as the popup window it is calling. You can resize the 
object after you have placed it by clicking on the object and dragging on the sizing handles or selecting the 
Profile tab in the Indirect Window Object’s Properties window and adjusting the Width and Height settings. 

 

 

 

  

1010-1015, Rev. 03 



EZwarePlus Programming Manual  137 

Tips and Suggestions 

Having trouble deciding which method to use to display a base window? Here are some suggestions: 

• If you want to clear the HMI display of all open windows and display a new full screen window, then use the PLC 
Control Object function or select the Change Window option in the Function Key Object. The PLC Control Object is 
global (meaning it does not matter which windows are currently on display), so the HMI will always monitor the PLC 
address that you have selected. The Function Key Object can be made local to one or more windows by placing the 
object on only those windows. It can also be made global (meaning the HMI operator can always change to this 
window no matter which window is currently displayed), by placing the Function Key Object on the Common Window 
or the Fast Selection Window. 

• If you want to display a popup window on one particular full screen window, then try using the Popup Window 
option in the Function Key Object. This is particularly useful if you want the HMI operator to control the ability to 
display the popup window. If you want the PLC to determine when to display the popup window, then use the Direct 
Window object. 

• If you want to display a popup window that can be shown on any full screen window, then try using the Popup 
Window option in the Function Key Object. You should place the Function Key Object on the Common Window or in 
the Fast Selection Window. This will allow the HMI operator access to that popup window regardless of which full 
screen window is displayed. If you want to display the popup window only when some condition in the PLC has 
occurred, then use the Direct Window object on the Common Window. 

• If you want to display one of many possible popup windows on any full screen window, then try using the Indirect 
Window object on the Common Window. You can then let the PLC determine which popup window should be 
displayed or you can create several Set Word objects to allow the HMI operator to select which window to look at. 

Returning to a previous window 

You can configure a function key to display the full-sized base window that was on the HMI screen before the 
currently shown window. 

Create a function key to return to previous window: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box is displayed. 

2. Select the Return to previous window option button. 

3. Configure the rest of the function key, and then click OK. 

4. Place the function key object onto the full-sized base screen. 

 Placing a Return to previous window function key onto a popup window will not work. 

Using a function key to close a window 

You can configure a function key to close any popup window that is currently displayed on the HMI screen, and was 
called by a function key. 

Create a function key to close a window: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box is displayed. 

2. Select the Close window option button. 

3. Configure the rest of the function key, and then click OK. 

4. Place the function key object onto the popup window. 

 Placing a Close window function key onto a full-size base screen will not work. To close a direct window, turn 
off the controlling bit. To close an indirect window, write a 0 to the controlling register. 
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Using the Common Window 
Your project might require that some data be displayed on the HMI screen at all times, regardless of which window(s) 
are displayed. For example, you may want to display a company logo on the HMI screen at all times, or you may want 
to display some critical data or an alarm message which should be seen no matter what windows are displayed. 

Using base windows to display this information requires that you configure every full screen base window with the 
same graphics object. The common window however, is a predefined window in the HMI that you can enable to 
display this information. When created, the common window always operates in the background as a full screen 
window that overlays any full screen base window displayed. 

 It may be desirable to use the Common Window but temporarily hide it when developing the project. 

The  button on the Standard Toolbar toggles the visibility of objects on the Common Window. 

Whenever you create a new project, the common window (Window #4) is automatically created. 

To access the common window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

 

2. Highlight Window #4, Common Window and click Settings. The Window Setting dialog box appears. 
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3. As you can see, some of the parameters for a common window are disabled and cannot be changed. 
Window #4 is always reserved for the Common Window. Although the Background settings are active, none 
of these settings affects the operation of the common window. 

4. Click OK. The Open Window dialog box reappears with the Common Window selected. 

5. If you wish to open the common window, click Open. Otherwise, click Close to return to the main screen of 
EZwarePlus. 

Displaying the common window above/below the base window 
This setting resolves the conflict that can occur if a graphics object on the common window occupies the same space 
on the HMI display as a graphics object on a base window. Using the Above base window attribute forces the 
graphics object on the common window to cover the base window graphics object. Using Below base window has the 
opposite effect. 

 

Base Window 

 

Common Window 
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When Above base window is set, the result is: 

 

When Below base window is set, the result is: 

 

To set the Above/Below base window option for a common window: 

1. From the Edit menu, select System Parameters. The System Parameter Settings dialog box appears. 

2. Select the General tab. In the Options section next to Common window, select either Above base window 
or Below base window. 

3. Click OK to return to the main screen of EZwarePlus. 

 Active graphics objects (objects that display information or graphics according to a data value in a PLC 
register or coil) take precedence over passive graphics objects (objects such as circles, lines, rectangles, etc.). 
Therefore, a Set Word Object on a base window will cover a Rectangle Object on a common window that 
occupies the same space even with the Above base screen attribute enabled. 

Changing the Active Common Window 
Although only one common window can be on the HMI display at one time, you do have the ability to create multiple 
common windows by using base windows as common windows. Then, with the help of a Function Key object (using 
the Change common window checkbox), the HMI operator can change the active common window. 

The ability to change the common window adds more flexibility to your project should you need it. For example, you 
may have a series of full screen windows which all need a keypad for entry. Another series of full screen windows may 
require a common alarm message. By changing the common window with each series of windows, you can customize 
each common window to contain only the graphics objects that are needed. 
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To change the active common window: 

1. Create a new project. The Common Window (Window 4) is automatically created. 

2. Create a base window that is full screen. This will be used as another common window. 

 Note that when a base window is used as a common window, the Start Pos:, Style, Frame, and 
Background settings are ignored by the HMI. For this example, let’s use Window #30 as the alternate 
common window. 

3. Create another full screen base window that can be displayed along with the common windows, (such as a 
startup window). Let’s use Window #10, the initial window, for our example. 

4. On Window #10, create a Function Key object that is used to change the common window. From the Objects 
menu, click Function Key. The New Function Key Object dialog box appears. 

5. On the General tab, select the Change common window option button. 

6. In the same section, select 30 from the Window no. drop down menu. 

7. Click the Shape tab. Click Use Shape... and then click on the Shape Library… button. Select Shape #1 from 
the button1 library. Click OK to return to the Create Function Key Object dialog box. 

8. Click the Label tab. Click the Use label checkbox. 

9. For our example, type CCW (meaning Change Common Window) into the Content box. Click OK to exit the 
Create Function Key Object dialog box and go back to the EZwarePlus main screen. 

10. Place the new Function Key object somewhere on Window #10. 

Below is an illustration of what the default common window, Window#30 (alternate common window), and 
Window#10 (startup window) might look like: 

 

Default Common Window #4  Alternate Common Window #30  Initial Window #10 
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When the HMI initializes, it displays the startup screen (Window #10) and the default common window. 

 

To change common windows, we press the CCW function key that has been configured to change the common 
window to Window #30. 

 

Window #30 remains the common window until another function key object is pressed that changes the common 
window or until the HMI is reset. 

Using the Fast Selection Window 
In the last section, you read that common windows are great for displaying information that should be displayed all 
the time, regardless of which base windows are active. You may also create projects that require a window that is 
always accessible (like a common window) but not always displayed. For example, you may want a numeric keypad 
available for any data entry; however, a keypad takes precious space on the HMI display. Ideally it should appear on 
screen only when a key was pressed and then, by pressing another (or the same) key, the keypad should disappear. 

This is essentially the purpose of the Fast Selection window. The Fast Selection window can also be used as a menu 
key that allows the HMI operator to rapidly switch screens. 

Whenever a new project is created, the fast selection window (Window #3) is automatically created (except when 
Portrait mode is selected; you can create a Fast Selection window using the Window > Open Window > New… > Fast 
Selection command). 
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To open a fast selection window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

 

2. Highlight the Fast Selection Window and click Settings. The Window Setting dialog box appears. 

 

3. The Name: and Window No.: are reserved to identify the Fast Selection window. The other parameters can 
be modified, (see the Window Settings section earlier in this chapter for more information). Notice that the 
default size is Width = 100 and Height = 450. The default was selected to create a ‘sidebar’ that contains 
function keys to display other windows on the HMI5070P. The example below illustrates how the Fast 
Selection Window can be used for this purpose. 

4. Press OK. The Open Window dialog box reappears with the Fast Selection window selected. 

5. If you wish to open the fast selection window, click Open. Otherwise, click Close to return to the main screen 
of EZwarePlus. 
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Using the Fast Selection Button 
The fast selection button is used to display the Fast Selection window.  
Pressing the button again causes the Fast Selection window to close. 

Creating the Fast Selection Button 

The fast selection button must be activated in the System Parameters in order  
to have it display on the HMI. When enabled, the fast selection button is always  
visible on the screen. 
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To display the fast selection button: 

1. Select Edit > System Parameters. The System Parameters Setting Dialog  
appears. Select the General tab. 

 

2. In the Fast selection button section, select Enable from the Attribute drop-down menu. 

3. Select either Right or Left from the Position drop-down menu to select whether the button will appear in the 
right-lower corner or left-lower corner of the screen. 

4. Click Settings... Click the Use shape checkbox, and then click the Shape Library… button. 

5. Select a shape for your fast selection button and click OK. 

6. Click OK. 

 The Fast Selection window can only call full screen windows, not popup windows. Therefore, you cannot use 
Function Key Objects configured to Display popup window in Fast Selection windows. 
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System Message Windows 
EZwarePlus has four Windows designated as System Message windows. Window #5 is designated as the PLC 
Response Window that pops up automatically when the HMI loses communications with the PLC. 

 

Window #6 is designated as the HMI Response window, which will pop up automatically with the HMI loses 
communications with another HMI that is remotely connected. 

 

Window #7 is designated as the Password Restriction Window, which will pop up when access is attempted on a 
protected object without the proper password. The Display warning message if access denied checkbox must be 
enabled in the Security tab > User restriction section of the object. 

 

These windows have been pre-configured with automated messages and a function key to close the window, so no 
changes are necessary, though you may customize them for your own application if desired. 

Window #8 is designated as the Storage Space Insufficient Window, which will pop up when the available memory in 
the HMI, USB Flash drive, or SD card is running low. The following Reserved Local Bits indicate insufficient memory 
conditions: 

LB9035 HMI free space insufficient alarm (when ON) 

LB9036 SD Card free space insufficient alarm (when ON) 

LB9037 USB free space insufficient alarm (when ON) 
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The amount of available memory is indicated by the following Reserved Local Words: 

LW9072 HMI free space available in KB (32-bit) 

LW9074 SD Card free space available in KB (32-bit) 

LW9076 USB free space available in KB (32-bit) 

 

 The default trigger value for the insufficient memory warning is 16MB, and is stored in LW9070 (in MB). This is a 
“read-only” register and cannot be modified. 
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Chapter 8 – Creating and Using the Tag Library and Label Library 
 
EZwarePlus includes the ability to create and use both a Tag Library and a Label Library. The Tag Library is a database 
of PLC register addresses. Once created, the tag database provides a method for assigning addresses to individual 
objects from the Tag Library. The Label Library is a database of text labels. Once created, the label database provides 
a method for assigning labels to individual objects from the Label Library. The Label text may also be represented in 
up to eight languages, each selectable for display. 

Creating and Using the Tag Library 
The Tag Library is a database of register addresses, with each tag representing a single address. EZwarePlus gives you 
the option of using either Customized or System tags. Customized tags are tags that you build yourself. System tags 
are predefined tags that allow access to certain built-in functions and settings. You can select whether you will be 
using customized or system tags in the Address Tag Library dialog. The Tag listing does not contain display 
information, as display attributes are set when the individual object using the Tag listing is created. 

To create a Tag Database Library:  

1. From the Library menu, click Tag..., or click the Address Tag Library Manager button from the Library toolbar. 
The Address Tag Library dialog appears. 

 

2. To create a new Tag listing, click the New… button to display the Tag dialog. 

 

3. Enter the new Tag name. Tag names may be up to 100 characters, any character. 

4. Select the PLC name: as configured in the Device Table from the drop-down menu. 
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5. Select the Address type (Bit or Word). 

6. Select the Device type from the drop-down menu. 

7. Enter the Register Address. 

8. Click OK. 

9. Make additional entries to the database by repeating the procedure. 

To delete a tag: 

1. Open the Tag Library as directed above. 

2. Select the tag to delete. 

3. Click the Delete button. 

To modify a tag: 

1. Open the Tag Library as directed above. 

2. Select the tag to edit. 

3. Click the Settings... button. 

4. Edit as applicable and then click OK. 

Importing and Exporting the Tag Library 
This feature allows tags from the tag library to be saved into a .tgl file format. Once saved, the file can be loaded into 
another project. 

To save the tag library: 

1. Click on Save Tag File... The Open dialog box appears. 

2. Enter the name of the file where you wish to save the data. 

3. Click Open. 

To load the Tag Library from an existing .tgl file: 

1. Click on the Load Tag File...The Open dialog box appears. 

2. Browse for the .tgl file that contains the tags. 

3. Click Open. 

 The .tgl file format cannot be edited. 

The tag library can also be imported and exported using a comma-separated variable (.csv) file format or Excel (.xls) 
file format. These formats are very useful if you need to make several changes to the database; or, if creating a new 
project, it is easier and faster to create and edit the tags in a .csv or .xls file. 
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To export the tag library to a .csv file or .xls file: 

1. Click Export CSV or Export EXCEL. The Open dialog box appears. 

2. Enter the name of the file where you wish to save the data. 

3. Click Open. 

To import the tag library from a .csv file or .xls file: 

1. Click Import CSV or Import EXCEL. The open dialog box appears. 

2. Brows for the CSV or XLS file containing the tags. 

3. Click Open. 

Using the Tag Library 
Once the Tag Database has been created, individual objects can use the Library to assign a Tag to the object, 
referenced to the PLC register address. 

1. On addressable objects, once the Tag Database has been created, a User-defined tag checkbox is available. 
This box is not available if no tags have been configured in the Database Library. 

 

2. Check User-defined tag checkbox. The Device Type list will be filled with a list of available tags. Objects 
addressable as Register-type objects will display Tags configured as Word; Objects addressable as Bit-type 
objects will display Tags configured as Bit. 

 

3. Select the desired Tag from the Device Type list to address the Object to the referenced Register Address. 
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Creating the Label Library 
The Label library is a database of text Labels, for use with objects utilizing text labels descriptive of their status or 
condition. Each label can consist of multiple unique text strings (determined by the maximum number of states 
available per label), displayable in up to 24 separate languages. 

 The number of states for each label is determined by the number of languages selected. 
1 language = 256 states 
2 languages = 256 states 
4 languages = 192 states 
8 languages = 96 states 
16 languages = 48 states 
24 languages = 32 states 

To create a label text database library: 

1. From the Library menu, click Label..., or click the Label Library Manager icon from the Library toolbar. The 
Label Library dialog box appears. 

 

2. Create a label by clicking the New... button to display the Label dialog. 

 

3. Enter the Label name for the label, and how many states the new label requires. For example, a label titled 
“Start” requires 2 states to represent separate conditions, where condition one status is “START” and 
condition two is “STOP.” 
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4. Click the OK button, and the new label is added to the database. The Name will appear in a selectable listing 
of available Labels for use with objects that support text field labeling. 

 

5. The new label is still selected. Click the Settings… button to display the Label Tag Content dialog. In the State 
No. list pull-down box, select the state that the text is representing. 

 

6. In each Language box, as needed, enter the text representing that state in each language. 

7. If further text labeling is required to represent conditions or status in additional states, while still in the 
Settings... mode for Label Content Settings, select the state requiring text labeling. Enter the text in the 
Language boxes as above. 

 There is no inter-language conversion or translation capability. Entries must be made using the correct 
wording for the language designated, to display as entered. 

8. Continue to add state descriptive text labeling as required. 

9. When all text has been entered for all states desired, click OK. The Label is now contained in the Label 
Library and displayed when the Library is opened. View text labels for the various states of each label in the 
Library by selecting the State to display in the pull down box. 

10. Once a label text has been created and you wish to change the number of states, you may do so by double-
clicking on the desired label text. On the Label Tag Content dialog box, click the Change No of States... 
button, and then enter the No. of states desired for the label. 

  

1010-1015, Rev. 03 



EZwarePlus Programming Manual  153 

Setting Different Fonts for Different Languages 
If you would like to use different fonts for different languages, for instances, if the language you are using requires 
special characters or Unicode fonts, you can select a different font for each language using the label library. 

 

To set a different font for each language: 

1. From the Library menu, click Label..., or click the Label Library Manager icon from the Library toolbar. The 
Label Library dialog box appears.  

2. Select the Font tab. 

 

3. Select the font for each language from the drop down menu. Note that the fonts must be available to you in 
your Windows > Fonts folder. 

4. Click OK. 

Importing and Exporting the Label Library 
This feature allows you to save the labels from the label library into a .lbl file format. Once saved, the file can be 
loaded into another project. 

To save the label library: 

1. Click on Save Label File... The open dialog box appears. 

2. Enter the name of the file and where you wish to save the data. 

3. Click Open. 

To load the label library from an existing .lbl file: 

1. Click Load Label File... The Open dialog box appears. 

2. Browse for the .lbl file that contains the labels. 

3. Click Open. 

 The .lbl file format cannot be edited. 
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The label library can also be imported and exported using an Excel (*.xls) file format or comma-separated variable 
(*.csv) file format. These formats are very useful if you need to make several changes to the database. When creating 
a new project, it is easier and faster to create and edit tags in Excel or as *.csv files. 

To export the label library: 

1. Click Export EXCEL File… The Open dialog box appears. 

2. Enter the name of the file and where you wish to save the data. 

3. Select the type of file; *.xls or *.csv. 

4. Click Open. 

To import the label library: 

1. Click Import EXCEL File…. 

2. The Language count dialog box appears. Select the number of languages (1-8) you wish to use in the Label 
Library. Click OK. 

 

3. The Open dialog box appears. 

4. Select the type of file; *.xls or *.csv. 

5. Browse for the file that contains the labels. 

6. Click Open. 

Using the Label Library 
Once entries have been made to the Label Library, they can be used with any object that supports text field labeling. 

1. Select an object that supports text field labeling as required. On the Label tab for the object’s Attributes, 
check the Use label library checkbox. The Label Index list will be enabled, containing all of the labels in the 
database. 

2. Select the applicable label from the Label tag drop-down menu. The label will display on the object, 
representative for states and languages as entered in the Label Library dialog. 

3. Once created with Labels assigned, objects can be viewed displaying the various text labeling in each of the 
states detailed, in each of the languages utilized. To view, on EZwarePlus State and Test Toolbars, select the 
state and language for objects displayed on the window. The object’s text labeling display will change 
according to the state and language selected for viewing. 
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4. To use the multiple language feature of the Label Library to display object labels in languages other than the 
default language (Language 0), the function must be enabled. Enable the multiple language capability as 
detailed below. 

Using Languages with the Label Library 
The HMI5000P Series supports up to 24 languages for use with the Label Library text labeling. In order to use the 
multiple language feature, a label configured in multiple languages must be created and stored in the Label Library, as 
detailed above. The language displayed is selected through Internal Local Word Control, LW9134. 

1. Text Labels in any of up to 24 languages can be displayed, as configured in the Label Library. In LW9134, a 
value of 0 enables Language 1 as configured in the Label Library, a value of 1 enables Language 2, a value of 2 
enables Language 3, and a value of 3 enables Language 4, etc. 

2. The appropriate value must be written to LW9134 to enable a designated language to display. For example, a 
series of set word objects writing a value to LW9134 could be placed on a setup screen. Each set word might 
be labeled with the Language to be enabled, and the appropriate value addressed to LW9134. If Set Word #0 
enables English and English is the configured Language 0 in the Label Library, pressing the English Set Word 
Object writing a 0 to LW9134 will enable label text to display in English. If Set Word #1 enables French and 
French is the configured Language 1 in the Label Library, pressing the French Set Word object writing a 1 to 
LW9134 will enable text to display in French. Continue for all languages configured in the Label Library. 

 

 LW9134 is the System Tag Language Mode. 

Note: Although up to 24 languages can be created in the Label Library, only eight languages can be selected and used 
in a project at one time. 

 

 

 

 

 

  1010-1015, Rev. 03 



156  EZwarePlus Programming Manual 

Chapter 9 – Creating and Using Keypads 
 
The HMI operator must have a keypad available to enter new data when using the Numeric Input Object or the ASCII 
Input Object. EZwarePlus includes group libraries that contain sample keypads to be placed onto a window screen. 
You can also create your own custom keypads. This chapter focuses on how to create keypads, display them on the 
window screen, and use them for entering data into PLC registers. 

How to Create a Keypad 
Any keypad that you create is actually composed of keys using the Function Key Object. The Function Key Object can 
create alphanumeric keys as well as control keys, (i.e., Delete, Enter, Clear, etc.) 

To create a Function Key Object:  

1. From the Objects menu, click Button > Function Key or click the Function Key icon in the Object 1 toolbar. 
The New Function Key Object dialog box appears. 

 

2. Use the Description: box to enter a title for the Function Key part. A description is not necessary but does 
help you identify the purpose of the part. 

3. In the ASCII/UNICODE mode section, there are seven control key options. Control keys are used during data 
entry to perform a specific function. 
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Function Description 
[ENTER] Configures the Function Key as an Enter key. When pressed, it will write the alphanumeric 

characters entered into a Numeric Input Object or ASCII Input Object to the target PLC register. 
[BACK SPACE] Configures the Function Key as a Delete key. When pressed, it will delete the alphanumeric 

character to the left of the cursor in the Numeric Input object. 
[CLEAR] Configures the Function Key as a Clear key. When pressed, it will clear the data displayed in the 

Numeric Input Object or ASCII Input Object. Note: this key does not clear the actual target PLC 
register until the Enter key is pressed. 

[ESC] Configures the Function Key as an Escape key. When pressed, it will exit the editing mode. 

[Delete] Configures the Function Key as a Delete key. When pressed, it will delete the alphanumeric 
character to the right of the cursor in the Numeric Input object. 

[Left] Configures the Function Key as a Left Arrow key. Moves the cursor in the Numeric Input object 
to the left one space. 

[Right] Configures the Function Key as a Right Arrow key. Moves the cursor in the Numeric Input object 
to the right one space. 

 

4. Just below the four control key options, is the ASCII/UNICODE checkbox. Select this when you want to 
configure the Function Key to enter an alphanumeric character. When this checkbox is selected, the 
character box is activated. Use this box to enter the ASCII character you want to use. 

5. Click the Shape tab to select either a shape or bitmap to represent the Function Key.  

6. Click the Label tab to display the Label for the Function Key. Click the Use label checkbox to use a label. 

7. Click OK. The New Function Key Object dialog closes and the main screen of EZwarePlus appears with the 
cursor tied to a rectangular outline of the part you just created at the upper left corner of the screen. Move 
the part to the desired location on the window and click the mouse to place it. 

8. Once the part is placed onto the window, you can adjust the location of the label inside the part by clicking 
once on the label. This will highlight the entire object. Now click on the label again. Now only the label is 
highlighted, allowing you to move it without moving the part.  

9. Create a Function Key for each number, Enter, Back Space, Clear, and Escape key. 

10. Add a display to the keypad by selecting Objects > Numeric/ASCII > ASCII Display. Configure the ASCII 
Display with a Read Address of LW9150, and six words (No. of words). Place the ASCII Display above the 
Function Keys to complete the keypad. 

To create a custom keypad, group all of the keypad objects together on a window. You can then save the keypad to a 
group library for later use in other projects. Several predefined keypads are included with EZwarePlus. To use these 
keypads, click Library > Group > Call up Library in EZwarePlus and access the keypad library. 

Alternately, you can create a custom keypad in a graphics program such as Paint and import it into the Picture 
Library. Place the picture on a window using the Draw > Picture tool, and overlay the Function Keys and ASCII Display 
on top of the picture. The computer.flb library has some keypad pictures you can use (picture no. 35 and 36). 

Displaying and Using a Keypad 
Let’s go through a sample project that uses one of the predefined keypads included in EZwarePlus to enter values in a 
Numeric Input Object and an ASCII Input Object. This example will show you how to place these objects on a window 
screen, and then use the keypad to edit the data registers. 
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To create a sample keypad entry screen: 

1. Start a New project file in EZwarePlus. 

2. From the Objects menu, select Numeric/ASCII > Numeric Input. The New Numeric Input Object Properties 
box appears. 

3. Create a Numeric Input Object with the following parameters: 

 

Tab Section Parameter Value 

General Description  Numeric Input Object 

Read Address PLC Name: Local HMI 

Device Type: LW 

Address: 0 

Data Entry Keyboard 
(Select Use a popup 
keypad) 

Window No. 60: ASCII Middle 

Popup position Lower, right-hand column 

Numeric Format Display Data Format 16-bit signed 

Number of Digits Left of Decimal Pt. 5 

 

4. Create an ASCII Input Object with the following parameters: 

Tab Section Parameter Value 

General Description  ASCII Input Object 

Read Address PLC Name: Local HMI 

Device Type: LW 

Address: 1 

No. of words: 12 

Data Entry Keyboard 
(Select Use a popup 
keypad) 

Window No. 60. ASCII Middle 

Popup position Lower, right-hand column 

 

5. Create two text boxes; one to identify the Numeric Input register, and one to label the ASCII Input register. 
Place the text boxes and the Numeric Input and ASCII Input objects near the top of the window. 
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Editing data registers using a keypad: 

1. Save and compile the new project, then test the operation of the keypad by either running in Simulation 
mode or by downloading the project to the HMI. 

2. The following screen will appear: 

 

3. Change the value of the Numeric Input register. Touch the Numeric Input Object to activate the edit mode. 
The keypad will pop up. 

4. Using the keypad, enter digits 1, 2, 3, 4, and 5. As you enter the digits, each one should appear in the 
Numeric Input Object box. 

5. Press the Backspace key to delete digit 5. 

6. Try pressing any of the alpha characters (A-Z). Notice that alpha characters are not accepted into a Numeric 
Input Object register. 

7. Press the Clear key. Notice that the entire register is cleared to 0. 

8. Enter digits 5, 4, 3, 2, 1, and then press the Enter key. The keypad closes but the value was not accepted. 
This indicates that the value entered is out-of-range. Touch the numeric input object again. Press the Clear 
key and enter 32767. Press the Enter key. Notice that this value is accepted and blinking stops. 

9. Touch the Numeric Input Object register again to activate editing mode. Enter five more digits then press the 
Esc key. Notice that the entry is cancelled and the previous number 32767 is restored. 

10. Change the value of the ASCII Input register. Touch the ASCII Input Object to activate the edit mode. 

11. Using the keypad, enter the character string “HELLO WORLD”. As you enter the characters, each one should 
appear in the ASCII Input Object box. Press the Enter key to send the characters to the HMI internal data 
register. 

The above example uses a popup keypad that can be moved onscreen by touching the title bar and dragging it 
around. You can create a fixed keypad without a title bar by selecting Hide title bar in the Numeric Input or ASCII 
Input object’s Data Entry tab. 

To create a fixed keypad on a window instead of using a popup keypad or Direct Window: 

1. In the above sample project, create a new Numeric Input Object and deselect Use popup keypad on the 
Data Entry tab. Click OK to close the Properties window. 

2. Copy your custom keypad into the window, or open Window 50 and copy the keypad over to Window 10. 

3. You must click or touch the Numeric Input Object first to activate it, enter a number using the keypad, then 
press Enter on the keypad to write the value to the register. 
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Chapter 10 – Bar Graphs and Meters 
 
This chapter focuses on two special graphic objects, which can be used to display PLC data registers. You’ve learned 
how to use shapes and bitmaps to represent the data in PLC registers as states. You’ve also learned how to use 
alphanumeric data fields to display the contents of PLC registers as either numbers or ASCII characters. We now 
introduce two more options to display the data in PLC registers: Bar Graphs and Meter Display. In Chapter 11 we will 
introduce the Trend Display, another method of displaying data in PLC registers. 

Creating Bar Graphs 
The Bar Graph Object is used to represent the data in a 16-bit or 32-bit PLC register as a bar graph. You can configure 
the bar graph to move up, down, right, or left. The bar graph can be configured with any base number that represents 
0 level and any span range. You can create the bar graph with an alarm low and high setting to indicate to the HMI 
operator that an underflow/overflow alarm condition exists. In addition, you can set the alarm low and high limits to 
be controlled by two additional PLC registers so that the low and high limits are variable. Bar graphs can even be 
constructed with a shape or bitmap overlaying the bar graph to create flow tanks, temperature gauges, etc. 

To create a Bar Graph Object:  

1. From the Objects menu, click Bar Graph, or click the Bar Graph icon in the Object 2 toolbar. The New Bar 
Graph Object dialog box appears. 

 

2. Use the Description: box to enter a title for the Bar Graph object. A description is not necessary but does 
help you identify the purpose of the part. 

3. Click the Setting… button in the Read address frame. Select the device type from the drop down menu, and 
then indicate the PLC register address. Select the data format. 

4. Click on the Outline tab to display the outline form. 
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5. In the Attribute section, select how the Bar Graph is to operate. 

Function Option Description 
Type Normal The bar starts at one end of the object, and moves to the other end. 

Offset The bar starts at some non-zero point defined by the Origin, and moves through the 
origin as the value changes. 

Zero  The PLC Register values corresponding to an unfilled bargraph. 
Origin  The starting point of the bar when the Type is set to Offset. 
Direction Up The bargraph starts at the bottom of the object, and moves up as it fills. 

Down The bargraph starts at the top of the object, and moves down as it fills. 
Right The bargraph starts at the left of the object, and moves right as it fills. 
Left The bargraph starts at the right of the object, and moves left as it fills. 

Span  The PLC Register values corresponding to a completely filled bargraph. 
Bar Width 

  

 The percent of the object’s width that the bar occupies. 

6. The Bar color/style determines the appearance of the Bar Graph. 

Function Description 
Frame Set the color of the outside of the bar 

 Bar Set the color of the filled part of the bar. 
Background Set the color of the unfilled part of the bar. 
Bar Style Set the pattern of the filled part of the bar. 
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7. Set up the Target indicator. This selects the color of the filled part of the bar when it reaches a preset value. 

Function Description 
Enable When checked, the Target Indicator is active. 
Color Set the color to change the bar when the value is equal to the Target Value. 
Target Value The value at which to change the color of the bar. 
Tolerance Set a tolerance for the Target Value. When the value is less than or greater than the Target Value 

by this value, the bar will remain in the selected color. 
 

8. Select the Alarm indicators colors. 

Function Description 
Low Limit The value at which the bar will change to the Low Color. 
Low Color The color to change the bar when the value reaches the Low Limit. 
High Limit The value at which the bar will change to the High Color. 
High Color The color to change the bar when the value reaches the High Limit. 

 

9. Set up Target/alarm/zero (span) dynamic address. When checked, this option allows certain alarm limits to 
be read from the PLC / Controller. The Target value, and Low limit, and High limit fields are disabled. When 
Dynamic zero/span is checked, the Zero and Span fields are disabled. Data is read from the PLC as follows: 

Specified Address Low Limit 
Specified Address + 1 High Limit 
Specified Address + 2 Target Value 
Specified Address + 3 Zero Value 

 
Specified Address + 4 Span Value 

 

10. Once the part is placed onto the window, you can adjust the attributes of the Bar Graph by double-clicking 
on the part. 
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Creating Meter Displays 
The Meter Display Object is used to represent the data in a 16-bit or 32-bit PLC register as a scaled meter. The meter 
can be easily customized to the look that you want. 

The Meter Display can be configured with any base number that represents 0 level and any span range. 

To create a Meter Display Object:  

1. From the Objects menu, click Meter Display, or click the Meter Display icon in the Object 2 toolbar. The New 
Display Meter Object dialog box appears. 

 

2. Use the Description: box to enter a title for the Meter Display object. A description is not necessary but does 
help you identify the purpose of the part. 

3. Click the Setting… button in the Read address frame. Select the Device type from the drop down menu, and 
then specify the PLC register address. Select the data format. 

4. Click the Outline tab. This is where you will configure all of the attributes of your meter. 
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5. In the Degree section, you can select the range of your meter, where the range is 0 to 360. The Start degree 
0 is at 12:00. Below are four examples of start and end degrees for different meters: 

 

 Note that meters can have any start and end degree between 0 and 360. 

6. The Background section allows you to select background options for the meter. The following illustrations 
show how your meter will appear with different options checked: 

 

7. The Tick marks section allows you to configure the length, scale and sub-scale of the tick marks. 
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8. In the Pointer section, select arm style, color, length, and width. 

9. The Pin point section allows you to adjust the style and size of the pinpoint. See the illustration above to see 
the pinpoint (the center of the meter). 

10. Select the Limits tab. In this section, you can configure a scale that goes on the face of the meter that shows 
by a color indication when high and low limits have been exceeded. If you look at the above examples, you 
will see this is represented on the face of the meter as a red, yellow and green strip.  

 

11. In the Value section, select the Zero and Span values. These are the PLC register values that represent the 
zero and full-scale deflection of the meter’s arm. 

12. In the Range limits section, click the enable check box to enable the limits. Select the colors for low, mid and 
high. Select the width, in pixels, of the color band. The values from zero to low limit will be on the 'low' color 
band; values from low limit to high limit will be on the 'mid' color band; and values greater than high limit 
will be on the 'high' color band. 

13. Select the Low limit and High limit. These are the values used for the range limit color bands. Click the 
Dynamic limits check box to allow PLC registers to determine the low and high limits. The low limit is the 
specified register, and the high limit is the next consecutive register. 

14. The Scale label section allows you to enable labeling on the “main scale tick marks” inside the meter. You 
can select the font, color, size, and number of digits to the right of decimal point. 

15. If you'd like a background shape to appear with your meter, click the Shape tab and select a shape. 

16. Click OK. The meter appears on the work area of EZwarePlus. Click to drag and place your meter on your 
work area. If you need to reconfigure any of the properties, deselect the meter and then double click on it 
and the properties dialog box will reappear. 
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Chapter 11 – Data Sampling, Trend Displays, and History Data 
Displays 

Creating Data Sampling Objects and Trend Displays 
Data Sampling objects can be used to log historical data. Once data is historically logged, it can be saved to the HMI's 
internal memory, or to an external memory source such as USB, an SD card, or backed up to a PC. 

The Trend Display Object is used to display the sampled data in single or consecutive PLC registers and plot this data 
on a time graph. You can display a maximum of 64 channels with varying pen colors to distinguish the channels. Data 
can be displayed in Real-time mode or in History mode, which provide the option of displaying previous days’ data. 
Finally, a hold feature allows you to ‘freeze’ the graph, and a Watch line allows you to display the data at a particular 
point in time. 

In order to create a Trend Display object, you must first create one or more Data Sampling objects from which to 
display the trends. 

 

To create a data sampling object: 

1. From the Objects menu, select Data Sampling. The Data Sampling Object Dialog appears. 

 

  

1010-1015, Rev. 03 



EZwarePlus Programming Manual  167 

2. Click New… to create a new data sampling object. 

 

3. Description: Enter a name for the object. This isn't necessary, but will help in later identification of the Data 
Sampling object when configuring the Trend Display. 

4. Sampling Mode: This can be either Time-based or Trigger-based. With Time-based selected, the sampling 
interval can range from 0.1 seconds to 120 minutes. With Trigger-based selected, a PLC bit-address can be 
configured to trigger each sample. The Mode can be OFF > ON, ON > OFF, or OFF <-> ON (toggle). 

5. The Read address is the PLC register being sampled. Click the Setting… button to select the Device Type and 
Address for the Data Sampling Object. 

6. Max data records: Sets the maximum number of records to display in the Event Display (Real-time mode), 
up to 86,400 (1 sample/sec * 24 hr). If Auto. stop is selected, data sampling automatically stops when the 
number of records in Max data records has been reached. Otherwise, the existing logged data will continue 
to be recorded in the datalog file beyond the number of records (samples) configured in the Max data 
records field. 

7. Click the Data Format... button to configure the format of each logged item. The Data Format dialog 
appears.  
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8. Click New... to call the configuration dialog. 

 

9. Enter a Description for the data format and then select the Data type. Click OK to return to the Data 
configuration dialog and then Exit to return to the Data Format dialog. 

 Note: You must have at least one Data type configured in the Data Format list. If you want to display 
multiple channels in a Trend Display, you must configure multiple Data types in the Data Format list, one for 
each channel. The Data Sampling Object will sample data in consecutive registers starting with the register 
configured in the Read address of the Data Sampling Object, with the number of consecutive registers 
determined by the number of Data types in the Data Format list. 

10. Click the Enable check box in the Clear address section if you would like the data samples to be cleared 
when the bit is momentarily set. If enabled, click the Setting… button and specify the PLC address and device 
type. 

11. Click the Enable check box in the Hold address section if you would like to pause the data sampling as long 
as the specified bit is set. If enabled, click the Setting… button and specify the PLC address and device type. 

12. In order to display history data files in a Trend Display or History Data Display, the sampled data must be 
saved to memory. Select the type of memory to which you would like to save the data files, and then specify 
the folder in which the data will be saved. The Preservation limit option allows you to specify the number of 
days of data files to save before they are deleted from memory. 

13. Click OK. 

14. Follow steps 2-13 to create additional Data Sampling Objects. 

15. Click Exit to exit the Data Sampling Object. 
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To create a Trend Display Object:  

1. From the Objects menu, click Trend Display, or click the Trend Display icon in the Object 2 toolbar. The New 
Trend Display Object dialog box appears. 

 A Data Sampling Object must be configured before you can create a Trend Display. 

 

 

2. In the Data Sampling Object Index, select the data sampling object from the drop down menu whose data is 
to be displayed. 

3. For Trend type, select whether the data showing will be historical data or real-time data. 

4. The Distance between data samples option allows you to configure how the data is displayed in the X-axis 
on the Trend Display. When Pixel is selected, enter the number of pixels between data samples in the 
Distance field. When Time is selected, enter the number of seconds from left to right on the X-axis in the 
Distance field. 

5. Check the Enable checkbox in the Hold control section (Real-time mode only) if you'd like the trend to pause 
when a specified bit is set, and then configure the PLC address and device type. 

6. Configure the History control section (History mode only) to designate a register used to select the data log 
file to display in the Trend Display Object. 

7. Click the Enable checkbox in the Watch line section if you'd like to place a watch line on the trend that 
writes the value at that point to a specific register or registers, and then configure the PLC address and 
device type. If the selected Data Sampling Object is sampling two or more consecutive registers, the watch 
line will reserve the same number of consecutive registers as the number of registers being sampled, 
beginning with the specified register. 
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8. Click on the Trend tab to display the Trend dialog box. 

 

9. Select the Frame color and the Background color for the trend from the drop down menus. 

10. Check the Show scroll controls checkbox to enable the left and right scroll controls on the Trend Display. 

11. Check the Transparent checkbox to allow the Trend Display to be transparent. This allows you to overlay two 
Trend Displays, one on top of the other, and see the channels in both displays. By stacking Trend Displays, 
you can show data from non-consecutive registers on one display. 
Note: The scroll controls are not linked when stacking Trend Displays. 

12. Check the Enable checkbox in the Grid section if you would like the trend to display a grid. The Horiz.: 
division(s) determines the number of divisions from bottom to top. The Verti. interval: second(s) 
determines the number of divisions from left to right. For example, if the X-axis is configured for time = 100 
seconds, setting the Verti. interval to 10 seconds creates 10 divisions from left to right on the Trend Display. 

13. Check the Time scale Enable checkbox (only visible when the X-axis time range is set to Time) to display a 
time stamp at each division along the X-axis. Select the Format (HH:MM or HH:MM:SS) and the Font, Size, 
and Color. 

14. Check the Time and Date checkboxes in the Time/Date section to display the current time and date in the 
upper-left corner of the Trend Display, and then select the format in which you'd like the time and date 
displayed. 

15. Click on the Channel tab to display the Channel dialog box. 
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16. In the Data sampling object section, select the channels you want to display by clicking the checkboxes 
under Display. Select the pen properties for the selected channel in the Channel section.  

17. Next, select the value at which the pen will be at the bottom of the display (Zero) and where the pen will be 
at the top of the display (Span). If Dynamic limits is selected, the Zero and Span values are read from the 
designated register and the next consecutive register, respectively. 

18. The Channel Visibility control allows individual trend lines to be shown or hidden at runtime.  Each bit of the 
word in the specified register corresponds to a channel in the Trend Display.  Bit 0 corresponds to Channel 0, 
bit 1 to Channel 1, etc.  Bit 0 in the next consecutive register corresponds to Channel 16, etc.  Channel 
visibility can be configured to show the trend line when the corresponding bit is on or off. 

19. Click the Shape tab to configure a different frame style or color for the display, if desired. 

20. Click OK and place the Trend Display on the EZwarePlus work area. If you'd like to reconfigure any of its 
properties, double-click on the trend to display the Trend Display Object's Properties Dialog. Click the Profile 
tab if you'd like to resize or re-position your trend using the Width/Height and X/Y position  boxes instead of 
dragging and placing it in the work area. 
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History Data Display 
The History Data Display shows data captured by the Data Sampling object. 

Data is displayed in tabular format with the option to show the time and date of when data was captured. A control 
register is used to determine which historical data record is displayed (i.e., most recent, yesterday, two days ago, etc.) 
based upon date of capture. 

 

The HMI reads from the Sampling Object datalog file (*.dtl) immediately after the screen that contains the History 
Data Display object is displayed.  

 The data is only read and updated whenever the screen is first displayed. Data recorded to the datalog file (*.dtl) 
after the History Data Display object is shown will not appear on the History Data Display object until the screen is 
refreshed (closed, then opened again). A maximum of 64 channels can be displayed. 

To create a History Data Display Object: 

1. From the Objects menu, click History Data Display, or click the History Data Display icon in the Object 2 
toolbar. The New History Data Display dialog box appears: 
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2. Data Sampling Object index: Select from drop-down list which data file to use. Data files are created using 
the Data Sampling object. 

3. Grid: Displays grid lines on the data table.  

a. Enable: Check to enable grid lines. 

b. Color: Select color used for grid lines. 

c. Column Interval: Enter the number of pixels that separate each column of data. 

4. Profile color: Determines the color of the background of the object. 

a. Transparent: Enable if you do not want a background color or frame to appear. 

b. Frame: Color for the perimeter frame. 

c. Background: Color for the background of the object. 

5. Text: Select the font and size for all text that appears. 

a. Font: Select the True type font for the text. 

b. Size: Select the size of the font. 

6. Time: Enable to display the time when the data was captured by the Data Sampling object.  

a. Style: Select from HH:MM:SS, HH:MM, DD:HH:MM, or HH. 

b. Color: Determines the color used to display the time. 
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7. Date: Enable to display the date when the data was captured by the Data Sampling object.  

a. Style: Select from MM/DD/YY, DD/MM/YY, DD.MM.YY or YY/MM/DD. 

b. Color: Determines the color used to display the date. 

8. Sequence no: Enable to display a sequence number of when the data was captured by the Data Sampling 
object.  

a. Color: Determines the color used to display the sequence number. 

9. Time ascending or Time descending: Determines the order in which the data is displayed. 

10. History Control: Use to select the target PLC or internal HMI register that is used to determine which data 
log file is displayed. 

For example, suppose we have data log files that were recorded during a four day period- 20090615.dtl 
(June 15th), 20090616.dtl (June 16th), 20090617.dtl (June 17th), and 20090618.dtl (June 18th). 

We choose to use internal HMI memory address LW100 for the History Control address. If the value in 
LW100 = 0, then the History Data Display object will display the most recent data log record- in this example, 
20090618.dtl (June 18th). If the value in LW100 = 1, then 20090617.dtl (June 17th) is displayed, and so on. 

Note: The Option List can be used to select the data log file to display in the History Data Display by its date. 
Select Dates of historical data for the Source of item data attribute in the Option list tab and assign the 
Option List Monitor address to the same register as the History Control register in the History Data Display. 
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Data Format tab: Used to configure how the data appears for each column: 

 

1. Channel: Channels are configured in groups of eight (maximum of 64 channels). Use this pull-down box to 
select each group. 

2. Channel #0-63 (description in parentheses tells you what format is used for that data variable). 

3. Display checkbox: Check to enable viewing that data variable. 

4. Left of decimal Pt.: Determines the number of digits that can be displayed to the left of the decimal point. 

5. Right of decimal Pt.: Determines the number of digits that can be displayed to the right of the decimal point. 
 If 0, then no decimal point is displayed. 

6. Alignment: Options are center, right, and left justified. 

7. Leading zero: Check to display leading zeroes 

8. Color: Select the color used to display the data. 
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Title tab: Used to configure a title bar or legend at the top of the data columns: 

 

1. Use title: Check to use the Title bar option. 

2. Title background: Determines color of background on title bar.  

a. Transparent: Check to remove background color. 

b. Color: Select from drop-down color box. 

3. Title name: Default name of each column. 

4. Title: Name assigned to appear at the top of each column. 

5. Label library: None = not used, Used = Label Library used instead of direct text entry. To assign a Label Tag, 
highlight the channel you wish to modify and click on the Setting… button.  
 For more information on using Label Libraries, see “Chapter 8 – Creating and Using the Tag Library and 
Label Library”. 

6. Label tag: Blank = not used, or the particular name of the label tag used.  

Shape tab: Use to configure the frame and background color of the display. 
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Chapter 12 – Capturing Alarms and Events 
 
This chapter looks at how the HMI5000P Series uses alarms and events. 

Using Alarm/Events 
EZwarePlus has four parts that are used to perform alarm/event functions: the Event (Alarm) Log object, the Alarm 
Display object, the Alarm Bar object, and the Event Display object. The Event (Alarm) Log object monitors 
alarm/event conditions and alerts the Alarm Display object, the Alarm Bar object, and the Event Display object when 
an alarm/event condition occurs. Use the Alarm Display object if you want to display a scrollable list of all 
alarm/events that are active. Use the Alarm Bar object to display all active alarm/events on a single horizontally 
scrolling line (like a marquee). Use the Event Display object to display all alarm/events and their status (active 
alarm/events, acknowledged alarm/events, returned to normal alarm/events), 

Note: Alarms and events are handled in the same way by EZwarePlus, so reference will be made to alarms only rather 
than alarm/events for the remainder of this chapter, except for reference to the Event (Alarm) Log. 

Monitoring Alarms with the Event (Alarm) Log 
The Event (Alarm) Log continuously monitors PLC coils and registers to determine if an alarm condition has occurred. 
Once an alarm is active, the Event (Alarm) Log directs a string of characters associated with that alarm to the Alarm 
Display object, the Alarm Bar object, and the Event Display object for display on the HMI screen. 

To create an Alarm/Event Log:  

1. From the Objects menu, select Alarm > Event (Alarm) Log, or click the Event (Alarm) Log icon in the PLC 
toolbar. The Event (Alarm) Log dialog box appears. 

 

2. Click the New... button. The Alarm (Event) Log Properties dialog appears. 
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3. On the General tab, set the Category for the alarm. The Alarm Bar, Alarm Display, and Event Display can 
filter the alarms based on the category selected (range 0-255). 

4. Select a Priority level from the drop-down menu (Low, Middle, High, Emergency). The alarms are sorted by 
priority in the Alarm Bar and the Alarm Display with the highest priority shown on top (or first, in the case of 
the Alarm Bar). 

5. Select either bit or word from the Address type drop-down menu. 

6. Click Setting… and select the PLC name, device type and read address, as well as the numeric format in the 
Read address section. 

7. Click the Enable checkbox in the Notification section to have a specific bit set or cleared when the alarm 
condition is reached. 

8. Set the Condition to trigger the alarm (depends on Word or Bit selected for Address type). 

9. Click the Message tab to display the Message dialog. 
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10. Enter the message to display when the alarm or event is triggered in the Content box. If you would like to 
configure the message in different languages, click Label and follow the instructions in “Chapter 8 - Creating 
and Using the Tag Library and Label Library.” Select the Font and Color to use for the message being 
displayed. 

11. In the Write value window, enter the window number to display once the alarm or event is acknowledged. 
This value is entered into the register configured in the Event Display’s Write address on the General tab. 

12. Click the Enable checkbox in the Sound section to have the HMI play a sound when the alarm is triggered. 
Click the Sound Library... button to select a sound from the sound libraries. If no sound is selected, the 
default sound is a beep. Click Play to preview the sound. 

13. If a local printer has been enabled in the System Parameters > Model tab, you can send the alarm message 
to a printer. Click the On trigger box to print when the alarm is triggered, and Return to normal box to print 
when the alarm condition has been resolved. 

14. Multi-watch: The values of up to four data registers can be displayed in an Alarm/Event Message. Select the 
number of registers to be displayed. Click the Syntax… button to display a dialog explaining the syntax of 
embedding watch registers in an Alarm/Event Message. 

15. Click the e-Mail tab to display the e-Mail dialog. 
 The e-Mail tab is not visible unless e-Mail has been enabled in the System Parameters > e-Mail tab. 
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16. Select Send when event triggered to send an email when the event/alarm is triggered, and select Send 
when event is cleared to send an email when the event/alarm is cleared. The settings for Send when event 
is triggered and Send when event is cleared can be set independently by selecting one or the other at the 
top of the e-Mail dialog. 

17. Under Recipients, select the e-Mail Group you wish to send the email to. You can send the e-Mail to multiple 
groups under the category of To, Cc, and Bcc. 
Select As recipients of triggered mail settings to send the event cleared e-Mail to the same recipients as the 
event triggered e-Mail. If unchecked, the event cleared e-Mail can be sent to different recipients. 
 E-Mail Groups are configured in the System Parameters > e-Mail tab. 

18. Under Subject, select Use event content as subject to use the event/alarm message that appears in the 
Alarm Display in the subject line of the e-Mail. If unchecked, enter a custom subject line message. 

19. Under Message, enter the Opening message and the Ending message for the e-Mail. Check Use label library 
if the messages are already preconfigured in the Label Library, or click the Label Library button to enter the 
messages directly in the Label Library. 

20. Under Attach, select Contains a screenshot of window to include a screenshot of the alarm window with the 
e-Mail. This only available for the event triggered e-Mail. 
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21. Click OK to return to the Alarm (Event) Log dialog. You may select a location to save History files by selecting 
one of the check boxes. You may also configure additional Event (Alarm) Log items here. If a printer has been 
enabled in the System Parameters > Model tab, you can choose the items to include in the printed message 
when an alarm triggers a print command (configured on the alarm’s Message tab).  

22. Click Exit when you are finished. 

Displaying Alarms using the Alarm Display Object 
Though the Event (Alarm) Log object continuously monitors the PLC for alarms, it cannot display the alarms without 
the Alarm Display object, the Alarm Bar object, or the Event Display object. The Alarm Display object takes the alarm 
strings sent to it from the Alarm (Event) Log object and displays them on a window screen as a list. The list contains 
all of the active alarms occurring with the most recently activated alarm, and highest priority, at the top of the list.  

To create an Alarm Display Object:  

1. From the Objects menu, click Alarm > Alarm Display or click the Alarm Display icon in the Object 2 toolbar. 
The New Alarm Display Object dialog box appears. 

 

2. Enable acknowledge function: Select this to enable the acknowledge feature for the Alarm Display. The 
Write address is the register where the alarm or event writes the window number used to pop up an 
acknowledgement Indirect Window when the operator touches the Alarm Display to acknowledge the alarm 
or event. 

3. Click the Alarm tab to configure the parameters for the Alarm Display. 
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4. Include categories: To include all categories, set this at 0 to 0. 

5. Acknowledge style: Select either Click or Double click for the acknowledge style. 

6. Select the Frame and Background colors from the drop-down menus. Select Transparent for no frame or 
background. 

7. Select the sort order in which the alarms will appear, either Time ascending or Time descending. 

8. Check the Event trigger date, Event trigger time, and Event message checkboxes to include them in the 
Alarm Display. Use the Display order list to arrange the order in which the selected event information is 
displayed. 

9. Select the format for how the date and time is displayed in the Date: and Time: drop-down boxes. 

10. Click the Shape tab to configure a background shape, if you'd like one. 

11. Click the Font tab to configure the size of the font. 

12. Click OK and click in the work area of EZwarePlus to place the Alarm Display. Drag it to place it in the desired 
location. 

  

1010-1015, Rev. 03 



EZwarePlus Programming Manual  183 

Displaying Alarms using the Alarm Bar Object 
The Alarm Bar Object displays alarms scrolling horizontally along a single line. The alarm bar continuously scrolls each 
alarm until the alarm is no longer active. If more than one alarm is active, the Alarm Bar Object appends each alarm 
to the string of characters scrolled. This part can be used on window screens where space is very limited. It also 
allows you to display long alarm text strings that are too long to be shown in the Alarm Display Object. 

To create an Alarm Bar Object:  

1. From the Objects menu, click Alarm > Alarm Bar or click the Alarm Bar icon in the Object 2 toolbar. The New 
Alarm Bar Object dialog box appears. 

 

2. Include categories: To include all categories, set this at 0 to 0. 

3. Select Scroll speed from the drop-down menu to adjust the speed at which the message scrolls across the 
alarm bar. 

4. Select the Frame and Background colors from the drop-down menus. Select Transparent for no frame or 
background. 

5. Select the sort order in which the alarms will appear, either Time ascending or Time descending. 

6. Check the Event trigger date, Event trigger time, and Event message checkboxes to include them in the 
Alarm Bar. Use the Display order list to arrange the order in which the selected event information is 
displayed. 
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7. Select the format for how the date and time is displayed in the Date: and Time: drop-down boxes. 

8. Click the Shape tab to configure a background shape, if you'd like one. 

9. Click the Font tab to configure the size of the font. 

10. Click OK and click in the work area of EZwarePlus to place the Alarm Bar. Drag it to place it in the desired 
location. 

Displaying Alarms Using the Event Display Object 
The Event Display Object takes the event strings sent to it from the Event (Alarm) Log Object and displays them on a 
window screen as a list. The list contains all of the events that have occurred with the most recently triggered event 
at the top of the list. You do not have to display the entire list of events on a window screen. You can limit the 
viewable events to a ‘scrollable window’ that displays a given number of lines. An acknowledge feature allows the 
HMI operator to touch an event recorded in the event list to display a popup window. The popup window can then be 
used to display further instructions to the HMI operator or to perform some operation. 

To create an Event Display Object:  

1. From the Objects menu, click Alarm > Event Display or click the Event Display icon in the Object 2 toolbar. 
The New Event Display Object dialog box appears. 

 

2. Use the Description: box to enter a title for the Event Display object. A description is not necessary but does 
help identify the purpose of the part. 

3. Select either Real-time or History as the mode for the events to be displayed. 
In Real-time mode, the Write address is the register where the alarm or event writes the window number 
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used to popup an acknowledgement Indirect Window. 
In History mode, the History control address is the register used to select the history file to display, where 0 
displays the most recent events, 1 displays yesterday’s events, 2 displays the events from two days ago, etc. 
Select Enable reading multiple histories to display more than one history file at a time. 

4. Select Enable event management to configure a register to control the events that are displayed (see Event 
Display on pages 71-72 for more information). 

5.  Click on the Event Display tab to display the Event Display dialog. 

 

6. Include categories: To include all categories, set this at 0 to 0. 

7. Select Click or Double-click in the Acknowledge style drop-down menu to acknowledge an event with a 
single or double touch. Then select the maximum number of events to display in the Event Display (applies 
to Real-time mode only). The valid range is 10-1000.  

8. Select colors for Background, Frame, Select box, Acknowledge, and Return to normal. 

9. Select the order in which events will be sorted, Time ascending or Time descending. 

10. Check the Sequence no. check box to add a unique serial number to each event. Select the Event trigger 
date and Event trigger time to have the date and time the event is triggered added to each event. Select 
Acknowledge time and Return to normal time to have those times added to each event, and select Event 
message to include the message defined for the alarm/event appear in the display. 

  1010-1015, Rev. 03 



186  EZwarePlus Programming Manual 

11. Use the Display order list to arrange the order in which the selected event information is displayed, and 
select the format for how the date and time is displayed in the Date: and Time: drop-down boxes. 

12. Click the Shape tab to configure a background shape (if desired). Click the Font tab to configure the size of 
the font. 

13. Click OK and click in the work area of EZwarePlus to place the Event Display. Drag it to place it in the desired 
location. Click and drag the corners to resize it. 
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Chapter 13 – Security 
The security feature in EZwarePlus allows you to create up to 12 users with individual passwords and assign different 
access levels to each user. Access to windows and even individual objects can be secured so only individuals logged in 
with the correct access levels can operate certain functions. 

System Parameter Settings Security tab 
The security feature is enabled in the System Parameters. Open the System Parameter Settings (Edit > System 
Parameters) and click on the Security tab. Check the Enable box for each user you want to configure with security 
access. Enter a password for each user and check the boxes for the access level assigned to each user. 

 

 

Note: There is no priority in assigning access levels. For example, access level F doesn’t automatically provide access 
to levels A-E. In many cases, you will want higher security levels to include access to lower security levels. In the 
screen shot above, Users 1 – 6 are assigned increasingly higher security levels, with each security level including 
access to the security levels below it. 
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There are two security modes in EZwarePlus, General mode and Enhanced Security mode. General mode operates 
the same as the security feature in EasyBuilder-5000, so projects created in EasyBuilder-5000 will default to the 
General mode when opened in EZwarePlus. Enhanced Security mode provides additional features and user account 
management for improved security and runtime editing of user accounts. 

General Mode 
When General mode is selected, up to 12 users can be individually enabled, and each has a unique password and 
combination of any six access classes (A-F). Only numbers are allowed for passwords. When an object is created, it 
can be assigned an access class. When that object is activated (for example, a button is touched), the HMI compares 
the access classes allowed for the currently logged-in user to the access class specified for the object. If the access 
class of the object is within the classes allowed, the object’s action is executed. 

In order for a user to login, they must first enter their user number into reserved local word LW9219. Then they must 
enter their password into reserved local word LW9220 (32-bit unsigned). 

There are several other reserved local words and bits that can add functionality to your security implementation. 

Reserved Local Memory Function 

LW9222 Displays the access levels assigned to the currently logged-in 
user in binary format (16-bit binary) 
Bit 0: A, Bit 1: B, Bit 2: C, Bit 3: D, Bit 4: E, Bit 5: F 

LW9500-LW9523 (32-bit unsigned) Stores user passwords 1-12 

LB9050 Logs out user and resets password to zero when bit is set (HMI 
resets bit to zero) 

LB9060 Indicates when an invalid password has been entered (bit 
resets to zero when valid password is entered) 

LB9061 Set to update user passwords when changed locally  
(LW9500-LW9523) Use momentary style 

 

Refer to the Security Sample Project on our website to see how to employ the above reserved local memory bits and 
registers in a security implementation. 
(http://www.maplesystems.com > Support Center > Sample Projects > HMI5000 Series > Sample Prj: Security) 
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Enhanced Security Mode 
When Enhanced security mode is selected, up to 11 users can be enabled along with a default Administrator. Each 
user can be assigned up to twelve access classes (A-L). The Administrator has full access (all access classes). 
Passwords and User Names can be alphanumeric, which are stored in local memory as assigned by the Control 
address (see below for a description of the Control address). The Option List object can be configured to display the 
User Names, providing a quick way to select a user to log-in. 

 

Use existing user accounts on HMI: User accounts can be created and stored on a USB flash drive or SD card using 
the Administrator Tools and imported into the HMI via a Function Key. Check the Use existing user accounts on HMI 
checkbox to use the user accounts already stored in the HMI. This disables the user selection capability in the Security 
tab. 

When Use existing user accounts on HMI is unchecked, you can enable users by selecting the Enable checkbox for 
each user. Enter the User name and Password, and select the access classes for each user. User names and 
passwords can be alphanumeric, up to 16 characters long, and are stored in the HMI’s local memory as defined by the 
Control address. Passwords are case sensitive. 

Selecting Secret user will hide the User name from being displayed in the Option List. The User name would then 
have to be manually entered to log in that user. (Note: The Option List does have a Secret User override.)  
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The access classes can be assigned descriptions, which appear in the Object class drop-down when enabling the User 
restriction on an object’s Security tab. 

 

Administrator: The administrator’s user name is admin by default and cannot be changed. Enter the administrator’s 
password and select Secret user to hide the admin user name in the Option List. 

Control Address: The control address defines the area of memory containing the control registers and user account 
data. This reserves 20 consecutive registers beginning with the register designated in the Control address area. The 
addresses are allocated as follows: 

Address Length (Words) Description 

Control Address 1 Command (see below) 

Control Address + 1 1 Command result (see below) 

Control Address + 2 1 Selected Item Index (used with the Option List object) 

Control Address + 3 1 Privilege (bit 0 = Class A; bit 1 = Class B; bit 2 = Class C; 
etc. 

Control Address + 4 8 User Account Name 

Control Address + 12 8 Password 

 

Command 
(Control Address)1 

Function 

1 Log in with current name (Control Address + 4) and password (Control Address + 12). 

2 Log in with current index from the Option List (Control Address + 2). 

3 Log out. 

4 Change password of currently logged-in user account. The new password must be 
written to Control Address + 12 prior to execution. 

5 Add a new permanent user account, with the new name in Control Address + 4 and 
password in Control Address + 12. 

6 Add a new temporary user account, with the new name in Control Address + 4, password in 
Control Address + 12, privilege in Control Address + 3, and duration of account in minutes in 
Control Address + 2. If duration is 0, the new temporary account will be active until the next 
HMI power cycle. 
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7 Delete user account by name selected in Control Address + 4.  
Note: The currently logged-in user account cannot be deleted. 

8 Delete user account by Option List index (Control Address + 2). 
Note: The currently logged-in user account cannot be deleted. 

9 Change the privilege level of the selected user account by name (Control Address + 4). 
The new privilege value must be entered in Control Address + 3 prior to execution. 

10 Change the privilege level of the selected user account by Option List index (Control 
Address + 2). The new privilege value must be entered in Control Address + 3 prior to 
execution. 

11 Change the password of the selected user account by name (Control Address + 4).  The 
new password must be entered in Control Address + 12 prior to execution. 

12 Change the password of the selected user account by Option List index (Control 
Address + 2).  The new password must be entered in Control Address + 12 prior to 
execution. 

13 Read user account privilege by account name in Control Address + 4. Result is returned 
in Control Address + 3. 

14 Read user account privilege by Option List index in Control Address + 2. Result is 
returned in Control Address + 3. 

1Note: The Control Address is reset to 0 when the command is completed. 

 

Result 
(Control Address + 1) 

Description 

1 Success 

2 Command error 

4 Account already exists (when adding a new account) 

8 Account does not exist 

16 Password error 

32 Current command cannot be executed 

64 Invalid account name 

128 Invalid account password 

256 The imported data is invalid 

512 Not within the effective time limit (when using the USB Security Key to log in) 
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To log in from a keypad: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User Name. 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the Password. 

3. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 1. 

4. When the project is run, enter the User Name and Password, then touch the Set Word object. 

To log in from an Option List: 

1. Create an Option List with User account selected for the Source of item data. Configure the Monitor 
Address as ([Control Address] + 2). 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the Password. 

3. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 2. 

4. When the project is run, choose the desired User Name from the Option List, enter the Password, then touch 
the Set Word object. 

To add a permanent user at runtime: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User Name. 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the Password. 

3. Create 12 Toggle Switch objects, addressed to ([Control Address] + 3), bits 00 to 12. 

4. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 5. 

5. When the project is run, enter the User Name and Password, set the appropriate bits for the Access Class 
privileges, then touch the Set Word object. 

To add a temporary user at runtime: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User Name. 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the Password. 

3. Create a Numeric Input object, addressed to ([Control Address] + 2), 1 word, 16-bit Signed, for the Duration. 

4. Create 12 Toggle Switch objects, addressed to ([Control Address] + 3), bits 00 to 12. 

5. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 6. 

6. When the project is run, enter the User Name, Password, and Duration, set the appropriate bits for the 
Access Class privileges, then touch the Set Word object. 

To delete a user by name: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User Name. 

2. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 7. 

3. When the project is run, enter the User Name, then touch the Set Word object. 
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To delete a user by Option List: 

1. Create an Option List with User account selected for the Source of item data. Configure the Monitor 
Address as ([Control Address] + 2). 

2. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 8. 

3. When the project is run, select the desired User Name from the Option List, then touch the Set Word object. 

Object Security 
Many objects in EZwarePlus can be secured using the Security tab in the object’s properties window. For example, a 
Function Key can be secured so that only user’s with a specified access class can operate the Function Key and open a 
particular window. 

User Restriction 
The User restriction area is where the security class for the object is set. 

 

Once an Object class is selected in the User restriction area, three options become available. With no option checked, 
the object simply will not operate when touched unless a user with the correct access class is logged in. 
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Disable protection permanently after initial activation: This option removes the user restriction from the object 
once the object has been activated by a user with the correct access class, even after that user logs out. The 
protection is disabled until the HMI is rebooted. 

Display warning message if access denied: This option causes the message in Window 7 (Password Restriction) to 
popup when a user with an incorrect access class attempts to activate the object. 

 

Make invisible while protected: This option causes the object to be invisible on the screen until a user with the 
correct access class is logged in. 

Safety Control 
The Safety control area is used to prevent an operator from activating a button or switch by accidentally touching it. 

 

Min. press time (sec): This sets the minimum amount of time in seconds that the object needs to be pressed in order 
to activate it. 
 This option is not available when Display confirmation request is enabled. 

Display confirmation request: When enabled, the HMI will display a confirmation window before executing the 
action. The message in the confirmation window is configured in Message 0 of the System Message object (Objects > 
System Message). 

Max. waiting time (sec): This sets the maximum amount of time in seconds that the confirmation window stays on 
the screen. If the time expires, the confirmation window closes and the action is not executed. 
 This option is available only if Display confirmation request is enabled. 

Interlock 
The interlock feature uses the state of a bit to enable or disable the action of the object. 

 

When Interlock is enabled, the following options are available: 
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Hide when disabled: When this box is checked, the object is invisible on the screen until the designated bit is in the 
enable state. 

        

Disabled    Enabled 

Grayed label when disabled: When this box is checked, the object’s label is grayed out until the designated bit is in 
the enable state. 

                 

Disabled    Enabled 

Enable when Bit is ON/Enable when Bit is OFF: Choose the state of the designated bit that will enable the action of 
the object. 

 

Sound 
Enable the Sound option to play a sound when the object is activated.  

 

The default sound is the HMI’s beep. For models equipped with an audio output jack, you can select other sounds 
from the sound libraries to play when the object is activated. 
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Auto logout 
There is an Auto logout feature in the System Parameters on the System Setting tab (Edit > System Parameters > 
System Setting). 

 

 

When this feature is enabled, you can select the number of minutes of inactivity before the HMI will automatically 
logout the user. This avoids a situation where a user logs in and forgets to log out before leaving the HMI (use LB9050 
to manually logout a user). 

 

Additional Security Features 

Project Password (MTP file) 
Enable the Project Password in the System Parameter settings (Edit > System Parameters > Security tab). This secures 
a project and prevents it from being modified without the proper password. When the Project Password is enabled, 
you must enter the correct password in order to open the project in EZwarePlus. 
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Project Protection 
Enable Project Protection in the System Parameter settings (Edit > System Parameters > General tab). Use the Project 
Protection feature to set a unique password (Project key) in the project that will cause the project to run only on 
specific HMIs that have a matching password (HMI key). 

 

A developer can set the HMI key in the reserved local memory of the HMI (LW9046 configured for 32-bit unsigned 
numeric format). This value is stored in non-volatile memory, and once it is set, the value is hidden and cannot be 
read using a numeric display. In this way, only HMIs with the correct HMI key will be able to run the project. If the 
Project key does not match the HMI key, local bit LB9046 is set and the driver is disabled and will not communicate 
with the PLC. 

 

 The HMI must be rebooted in order for the HMI key setting to take effect. 
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Disable Upload Function 
Activate the Disable Upload Function in the System Parameter settings (Edit > System Parameters > System Setting 
tab). Alternately, you can set LB9033 in the local reserved memory of the HMI to disable the upload function and 
prevent a project from being uploaded from the HMI. 

 

 The HMI must be rebooted after downloading the project in order for the Disable Upload Function to take effect. 
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XOB Password 
A project (*.mtp) must be compiled (*.xob) before it can be downloaded to an HMI. When compiling a project, you 
have the option to change the default password (111111) to a unique number. 

 

You must enter the correct password before you can decompile the file and open it in EZwarePlus or you will get a 
decompiling error. 
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Decompiling Prohibited 
Click the Decompilation is prohibited checkbox in the Compiling window to prevent the compiled project from being 
decompiled. 

 

 Once a project is compiled with the Decompilation is prohibited option checked, it cannot be decompiled. There is 
no “backdoor” password to override it. 
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System Passwords 
The System Setup Toolbar in the HMI has the option of changing several passwords from their default setting of 
111111 to another number. 

Open the System Setup Toolbar and click the System Settings icon. 

 

    

A dialog will be displayed requesting the Local password. The default password is 111111.  

 

 You may have to move windows around a bit to gain access to the virtual keyboard. You may also have to click 
inside the password field again.  

Once the correct password has been entered, the System Settings dialog is displayed. Click on the Security tab to 
display the security settings dialog. Here, you can select and modify your system passwords.  
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To change a system password, the new password must be entered, and then entered again to confirm. As the 
password is entered into the confirm field, an indicator will show if the two passwords match.  

 

 

 

Local Password: The password required to enter local setup on the HMI. 
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Upload Password: The password required to upload data from the HMI to a PC or memory module. 

 

Upload to a PC using Utility Manager 

 

Upload to a USB Flash or SD Card 
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Download Password: The password required to download data to the HMI from a PC or memory module. 

 

Download from a PC to an HMI 

 

Download from a USB Flash or SD Card 
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Upload (History) Password: The password required to upload history files from the HMI to a memory module. 

 

Upload to a USB Flash or SD Card 
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Chapter 14 – Administrator Tools 
The Administrator Tools is a separate utility that allows storing data to a USB flash drive or SD card for specific 
functions including User Accounts, USB Security Key, e-Mail SMTP Server Settings, and e-Mail Contacts. The stored 
data can then be loaded into an HMI. 

To open the Administrator Tools, click Tools > Administrator Tools in EZwarePlus. 

User Accounts 

 

 The project in the HMI must have Enhanced Security mode selected in the System Parameters > Security tab for 
the User Accounts data to be implemented in the HMI. 

Selecting User Accounts allows creating and saving new user accounts to the HMI during runtime, without having to 
change the project in EZwarePlus and download it to the HMI. Use the Add button to create new user accounts. Up to 
127 new accounts can be added in this way. Check the Effective Time: Restrict the using terms checkbox to put a 
time limit on when the data can be uploaded to the HMI. Once the data is uploaded, the account data is permanent 
in the HMI. If not checked, the data can be uploaded at any time. 

Click the Export button to save the User Accounts in a EUA (EZware User Accounts)  file. Click the Import button to 
import a list of User Accounts from a EUA file. 

Select Save to USB to save the User Account data to the USB flash drive or SD card.  Navigate to the USB flash drive or 
SD card connected to your PC and click Create. 
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To upload the data to the HMI, you must have a Function Key configured to import the user data. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the Settings button. 
Select Import user accounts under Function mode. Select the Data position (SD card or USB disk) and the Account 
import mode (Overwrite or Append). Select Delete file after importing user accounts to delete the file from the SD 
card or USB flash drive after importing the data to the HMI. Click OK and select an appropriate shape and label for the 
Function Key. Pressing the Function Key on the HMI during runtime will import the User Account data from the USB 
flash drive or SD card connected to the HMI. 
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USB Security Key 

 

 The project in the HMI must have Enhanced Security mode selected in the System Parameters > Security tab for 
the USB Security Key data to be implemented in the HMI. 

Selecting USB Security Key allows a user to log-in automatically by pressing a Function Key that is configured to Use 
[USB Security Key] to Login. Enter the User name and Password of the user account. The User name and Password 
must match an existing account in the HMI. Check the Effective Time: Restrict the using terms checkbox to put a 
time limit on when the USB Security Key data can be used. 

Select Save to USB to save the USB Security Key data to the USB flash drive or SD card.  Navigate to the USB flash 
drive or SD card connected to your PC and click Create. 
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To log-in the user, you must have a Function Key configured to Use [USB Security Key] to Login. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the Settings button. 
Select Use [USB Security Key] to Login under Function mode. Select the Data position (SD card or USB disk). Click OK 
and select an appropriate shape and label for the Function Key. Pressing the Function Key on the HMI during runtime 
will log-in the designated user account on the USB flash drive or SD card connected to the HMI. 
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e-Mail SMTP Server Settings 

 

Selecting e-Mail SMTP Server Settings allows the e-Mail server settings to be changed in the HMI during runtime 
without having to change the project in EZwarePlus and download it to the HMI. Enter the SMTP Server settings that 
you want to import into the HMI. 

Select Save to USB to save the e-Mail SMTP Server Settings data to the USB flash drive or SD card.  Navigate to the 
USB flash drive or SD card connected to your PC and click Create. 
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To update the HMI, you must have a Function Key configured to Use [USB Security Key] to Login. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the Settings button. 
Select Import e-Mail settings and contacts under Function mode. Select the Data position (SD card or USB disk). Click 
OK and select an appropriate shape and label for the Function Key. Pressing the Function Key on the HMI during 
runtime will import the new e-mail SMTP settings to the HMI. 
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e-Mail Contacts 

 

Selecting e-Mail Contacts allows the e-Mail contacts in the HMI to be changed without having to change the project 
in EZwarePlus and download it to the HMI. 

Click the Add button to add a Contact Name and Mail Address to the list of contacts. Up to 256 contacts can be 
created. 

Select the No. of groups to use for the assigned e-Mail recipients. Up to 16 groups can be created. 

Select a group under Current group to add contacts to the group. Select the contact under Contacts and click the 
right-arrow button to add that contact to the selected group. 

Click the Export button to save the e-Mail Contacts in a CSV file. Click the Import button to import a list of e-Mail 
Contacts from a CSV file. 

Select Save to USB to save the e-Mail Contact data to the USB flash drive or SD card.  Navigate to the USB flash drive 
or SD card connected to your PC and click Create. 
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To update the HMI, you must have a Function Key configured to Import e-mail settings and contacts. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the Settings button. 
Select Import e-mail settings and contacts under Function mode. Select the Data position (SD card or USB disk). Click 
OK and select an appropriate shape and label for the Function Key. Pressing the Function Key on the HMI during 
runtime will import the new e-mail contacts to the HMI.
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Chapter 15 – Recipes 
EZwarePlus supports creating and using recipes in the HMI5000P Series. EasyBuilder-5000 supports a method using 
the RW memory in the HMI for storing the recipe data and using a recipe index register (LW-9000) to select blocks of 
RW memory to display and edit the recipe data on the HMI screen. EZwarePlus also supports this method so that 
projects created in EasyBuilder-5000 can be opened in EZwarePlus without having to modify the recipe structure. 

EZwarePlus also supports a new method of creating and using recipes, which stores the recipe data in the MTP/XOB 
file itself or creates a separate recipe database file that can be uploaded or downloaded to the HMI using the Utility 
Manager. 

This chapter will focus on the new method of creating and using recipes. Please refer to the EZwarePlus Help file for 
information on creating and using recipes with the RW memory in the HMI and the Recipe/Extended Memory Editor 
(Help > Help Topics > How Do I…Use Recipes?). 

Creating a Recipe 
Recipes are created in the Recipes tab of the System Parameters in EZwarePlus (Edit > System Parameters > Recipes 
tab).  

 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  215 

Click the “Add new recipe” button  to create a new recipe in the Recipes list. 

Click the New button to add an item to the recipe. An item represents an ingredient or variable in the recipe that may 
change from one recipe record to another. Each item has the following parameters that can be configured 
independently. 

Item name: This is the name that appears at the top of the column in the Recipe View that describes the particular 
ingredient or variable for each item in the recipe.  Usually, this is alphanumeric. 

Data type: If the data in the column is alphanumeric, choose ASCII as the data type. If the data is numerical, you can 
select from a variety of numeric formats (16-bit signed or unsigned, 32-bit signed or unsigned, 32-bit float, etc.). 

Size: Choose how many characters wide the column requires. 

Decimal Pt.: Determines how many digits to the right of the decimal point is displayed. 

Alignment: Align left, center, or right. 

Once the recipe format has been configured, you can select Export definition file of recipes to save the recipe format 
in a recipe definition file (*.rdef). This is imported by the Recipe Database Editor for editing recipes and saving as a 
recipe database file (*.db) (see “Adding and Editing Data in a Recipe in the Recipe Database Editor” below). 
Otherwise, the recipe can be edited using the Recipe Records Library, which reads the recipe formats directly from 
the System Parameters > Recipes tab. 

Adding and Editing Data in a Recipe in EZwarePlus 
Open the Recipe Records Library (Library > Recipe Records) to edit the recipe data in EZwarePlus. 

 

The recipe formats that were created in the System Parameters > Recipes tab will appear in the Recipes list on the 
left side of the Recipe Records dialog. Select a recipe in the Recipes list to edit the data. The Item names that were 
created for the recipe in the System Parameters appear along the top of the Recipe Records dialog. 

Click the Add button to add records to the recipe. Enter the data for each column. In this example, the first column is 
the name of the recipe record and subsequent columns represent the ingredients used, with the data entered 
representing the amount of each ingredient. 

You can use the up/down arrow buttons to move a selected recipe record up and down in the list. When all the 
recipe records have been created and the data entered, click the OK button to close the Recipe Records dialog. 
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When changes have been made, a popup window will ask if you want to apply the changes to the recipe database. If 
you select Yes, the recipe database file will be updated with the changes. This is stored as recipe.db in the EZPlus > 
HMI_memory > Recipe folder. If you select No, the database file will not be updated but the data is stored in the MTP 
file (and the XOB file when compiled). 

 

Adding and Editing Data in a Recipe in the Recipe Database Editor 
The Recipe Database Editor can be used to enter data in a recipe. To open the Recipe Database Editor, click on the 
Tools menu in EZwarePlus and select Recipe Database Editor. 

 

Click the Import button to import a recipe definition file (*.rdef) saved from the System Parameters > Recipes tab. 
The Item names that were created for the recipe in the System Parameters > Recipes tab appear along the top of the 
Recipe Database Editor. 
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Click the Add button to add records to the recipe. Enter the data for each column. In this example, the first column is 
the name of the recipe record and subsequent columns represent the ingredients used, with the data entered 
representing the amount of each ingredient. 

You can use the up/down arrow buttons to move a selected recipe record up and down in the list. When all the 
recipe records have been created and the data entered, click the Export button to save the recipe database file 
(*.db). 

If a recipe database file has already been created (for example, by saving it from the Recipe Records dialog), it can be 
opened in the Recipe Database Editor, edited, and saved.  

Important: Once the data has been edited in the Recipe Database Editor and saved to the database file, you must 
download the database file (*.db) to the HMI using Utility Manager. The database file is not included in the XOB file 
that is downloaded to the HMI and any changes are not reflected in the Recipe Records Library. 

Adding and Editing Data in the Recipe Database File in the HMI 
You can view the recipe data on the HMI screen using the Recipe View object. You cannot edit the recipe data in the 
Recipe View object directly. However, you can select individual recipe records within the Recipe View and display and 
edit the data using Numeric and ASCII Input objects. 
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Create a new Numeric Input or ASCII Input object and select Recipe for the Device type. 

 A recipe must be created in the System Parameters > Recipes tab for the Recipe Device type to be available. 

 

Select the individual item in the Address field. If the item is ASCII, it will only be available in the ASCII Input object. If 
the item is numeric, it will only be available in the Numeric Input object. 

 

When a recipe record is selected (highlighted) in the Recipe View object on the HMI or when running the Simulator, 
the data for the selected recipe record will appear in the various ASCII and Numeric Input objects on the screen. 

There are four additional choices in the Address field for the Recipe Device type in a Numeric Input object. 

Selection: This displays the zero-based index of the selected record. Writing a value into this field will set the Recipe 
View to that record. 

Count: Displays the number of records in the selected recipe. 

 

1010-1015, Rev. 03 



EZwarePlus Programming Manual  219 

Command: Performs an action on the recipe based on the value entered. 

1. Add a new record. The selected record is duplicated and added to the end of the list where it can be edited. 

2. Update the selected record with new data. 

3. Delete the selected record. 

Result: Displays the result of the action performed with the Command field. 

1. Success 

2. The selected record does not exist. 

3. Unknown command. 

4. The recipe has reached the limit of 10,000 records. No new records can be added. 

 

 

In this example, the selected record is highlighted in yellow (Tea_25ml). The Recipe Record Number in the upper-left 
corner is displaying the index number of the selected record in the list, counting from “0.” Entering a different 
number in this Numeric Input will cause the corresponding recipe record to be highlighted. 

The Recipe Tag section displays the selected record’s name with an ASCII Input object and the item data with 
Numeric Input objects.  

Clicking the New button writes a “1” to the Recipe Command register and creates a new recipe record at the end of 
the list. When data is changed in the selected record using the Numeric Input objects, clicking the Update button 
writes a “2” to the Recipe Command register and updates the recipe database file in the HMI and updates the Recipe 
View. Clicking the Delete button writes a “3” to the Recipe Command register and deletes the selected record. 
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The Upload from PLC and Download to PLC buttons are Data Transfer (Trigger-based) objects that transfer the recipe 
data to and from the PLC. For Download to PLC, select the recipe in the Source address and select the PLC in the 
Destination address (this is the beginning address where the recipe data will be written). 

 

Important: When the recipe data has been edited in the Simulator, the changes are stored in the database file on the 
PC (EZPlus > HMI_memory > Recipe > recipe.db). This database file must be downloaded to the HMI using Utility 
Manager in order for the HMI to reflect the changes made in the recipe.  

When the recipe data is edited in the HMI, the changes are stored in the database file in the HMI. The database file 
must be uploaded from the HMI using Utility Manager and stored in the Recipe folder on the PC in order for the 
EZwarePlus project to reflect the changes made in the recipe. The changes are reflected in the Recipe View object 
when running the Simulator but not in the Recipe Records Library.
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Chapter 16 – Operation Log 
The Operation Log is a mechanism that records operator actions to an SQLite database file.  Only user-triggered 
actions can be logged, such as a Set Bit, Function Key, Numeric Input, etc.  The Operation Log consists of two parts – 
Configuration and View. 

 The L and HD Series do not support the Operation Log. 

Configuration Settings 
Click the  button or, from the Objects menu, select Operation Log, Operation Log Settings. 

 

The text in the Comment column is recorded in the log, along with date/time, value, and certain other information.  
The Comment text is the same text as that which appears as the Comment in the object’s Properties dialog. 
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1. Check the Enable Operation Log Function checkbox.  The object list displays all objects available for 
recording in the Operation log.  Use the filter button  to select the type of object(s) that appear in the list. 

2. Check the Enable box for each object to be recorded.  Click the Select All / Discard All buttons to select or 
deselect all objects shown in the list. 

3. Use the Storage Settings section to determine how much data is stored in HMI internal memory, and when 
to archive data to an SD or USB device. 

Maximum Record No. in HMI Memory Select the maximum number of records to store in 
HMI memory.  This memory is shared with Data 
Sampling and Alarm/Event logging.  This is not the 
maximum amount of data to log. 

External Devices for Synchronization/Backup Select whether to archive to an SD or USB device. 

Behavior when HMI Space is Insufficient • Stop Saving Operation Log:  No more data is saved, 
and no archiving is done. 

• Synchronize to External Device: The data is 
archived to the SD or USB device.  If previous data 
exists on the SD/USB device, the new data is 
merged with the existing data.  If there is sufficient 
storage space in the HMI, half of the data in the 
log is erased to make room for more data.  If there 
is insufficient storage space in the HMI, all of the 
data in the log is erased. 

Note: If the specified SD or USB device does not 
exist, old data is erased from the log to make 
room for new data. 

Control Address Specifies the first of two addresses that allow 
commands to be sent to the Operation Log: 

[Specified Address] : Command 

1 – Clear all records 
2 – Copy all records to the USB device 
3 - Copy all records to the SD device. 
4 - Copy all records to the USB device, and clear all 
records from the log. 
5 - Copy all records to the SD device, and clear all 
records from the log. 

[Specified Address + 1] : Command 

0 – Processing the command 
1 – Command Successful 
2- The device does not exist 
3 -The records does not exist 
4 – Unknown error. 
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View Settings 
The Operation Log View displays data recorded by the Operation Log object in a spreadsheet-like format..  The 
Operation Log View will display data from the current database file, plus any data archived to the SD or USB device.  

Click the  button or, from the Objects menu, select Operation Log, Operation Log View. 

General Tab 
The General tab sets up the basic appearance of the Operation Log View. 

 

1. Comment: Enter a text description of the object (optional). 

2. Title: Specify how the title of the object is to appear.  The title is the header that appears above each column 
in the view.  Click the Transparent checkbox to have the background of the title be the same as the color of 
the window.  If the Transparent box is unchecked, select a background color for the title.  The foreground 
color of the title text is the same as that selected for the data. 
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3. Profile: Specify the background color of the view.  If the Transparent box is checked, the background color is 
the same as the color of the window.  If the Transparent box is unchecked, select a background color for the 
view 

4. Grid: Check the Enable box to display gridlines on the view.  If checked, specify a color for the gridlines. 

5. Selection Control: Specify a highlight color for the selected row. 

6. Font: Specify a Color, Style, and Size for the font used in the view.  The title row and data rows all use the 
same font. 
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Title Tab 
The Title tab sets up which fields are displayed in the Operation Log View. 

 

1. In the top section, enter the text to display in the Title row for each field.  The default text is the field name.  
If a label database exists in the EasyBuilder project, the Label Library checkbox may be checked and a Label 
Tag may be selected.  The Label Library and Label Tag columns are visible only if a label database exists in the 
EasyBuilder project. 

2. Sort: Select whether the view is to sort the data in Ascending or Descending chronological order. 

3. Order & Characters: Specify which database fields are to be displayed, the character length of each field, and 
the order in which to display the contents of each field.  In the Display Order box, click on a field name and 
use the up/down buttons to change its position.  The field at the top of the list is displayed left-most in the 
view. 

4. Select the format in which to display the Date and Time. 
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Chapter 17 – EasyDiagnoser and Easy Watch 
EasyDiagnoser is a diagnostic utility that monitors the read and write commands between the HMI and the PLC and 
indicates when an error occurs in the communication. 

EasyWatch provides a method of displaying and editing registers in the HMI and PLC in a tabular format. An existing 
macro in an HMI can also be triggered with EasyWatch for troubleshooting and debugging purposes. 

 EasyDiagnoser and EasyWatch require an Ethernet connection between the PC and HMI. 

EasyDiagnoser 
Open EasyDiagnoser from Utility Manager. You can also open it from the Online Simulator by right-clicking on the 
simulator window and selecting Run EasyDiagnoser. 
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Enter the IP address of the HMI that you want to monitor. 

 

EasyDiagnoser will open and attempt to connect to the HMI through the Ethernet port on the PC. The Logger window 
will display “Connection established with the target HMI” when the connection is made. 
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Main Window 
The main window in EasyDiagnoser is where you set the parameters for monitoring the communications and see the 
results. 

To begin monitoring communications: 

 

1. From the Command drop-down list, select whether to monitor Read and Write commands, Read commands 
only, or Write commands only. The default is Read + Write commands. 

2. In the Device drop-down list, select which device to monitor. Local HMI will always be an option, along with 
the other controllers and protocols configured in the HMI project. The default is All. 

3. If Device is set to something other than All, a unique Station Number can be selected. If enabled, 
EasyDiagnoser will monitor communications to the controller with the specified station number only. 

4. Select which Address Type to monitor. If All is selected, communications to every address used in the 
project will be monitored. The drop-down list will present every available address type, based on the 
selection in the Device drop-down list. The default is All. This option is available only when the Device 
selection is something other than All. 

5. If Address Type is set to something other than All, a range of addresses to monitor can be selected. If 
enabled, communications are monitored only for the selected Address Type and Range. 

6. Click the Capture button to start monitoring communications. Click the Capture button again to stop. 

Interpreting the Communication Status: 

• Each line in the table represents a data read or write command. 

• Any line in red indicates a communications error. The Error column indicates the type of error (see below). 

• The No column is a sequential number for that read or write command. 

• The Cmd column is R for Read, W for Write. 
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• The PID column is the Package ID number for the Polling Package containing the object’s address. Look for 
that number in the Package ID column in the Polling Packages window to see the details for that Polling 
Package. Double-clicking an object in the Polling Package window will highlight the object in the HMI or 
simulator. 

• The St. column represents the Station Number of the PLC that the Polling Package is associated with. 

• The Index. column represents the index of the Polling Package. 

• The Address / Length column indicates the starting address of the Polling Package, and how many addresses 
are in the Polling Package. 

• The Time column indicates how long the HMI took to respond to the request (in milliseconds). 

• The Error column indicates if any errors occurred. 
 0 = No Error 
1 = Time Out 
2 = Fail 
12 = Ignore 

Polling Packages 

 

 

The Package ID column lists the numbers assigned to each Polling Package. The number in parenthesis represents the 
number of objects contained in the Polling Package. Click on the “+” in front of the Polling Package to see the objects 
within it. Double-click on an object to highlight it in the HMI or Simulator. 

 

The Device column lists which device the Polling Package is assigned to, either Local HMI or the PLC device name.  
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The Station column lists the Station Number assigned to the Device (if applicable). When the objects within a Polling 
Package are displayed, it shows the window number where the object is located. 

The Index column shows the Index number assigned to the Polling Package. When the objects within a Polling 
Package are displayed, it shows the Object ID assigned to the individual objects by EasyDiagnoser. These can be 
viewed on the HMI or Simulator by selecting Show Object ID (HMI) under the Options menu. 

The Address / Length column lists the addresses assigned to the Polling Packages and the length of each address in 
words. 

Devices 

 

Shows the devices that the HMI is communicating with, including the Local HMI. 

Output 

 

The Output window displays messages generated with the macro TRACE command. The macro TRACE command uses 
a syntax like the c printf statement to display text and values in EasyDiagnoser. The macro ID number and the line in 
the macro where the TRACE command resides is shown in brackets. This example was generated with the following 
command: 
TRACE (“Value is %d”, value) 
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Logger 

 

The Logger window show events that occur in EasyDiagnoser. 

 EasyDiagnoser does not support monitoring PLCs using the tag import feature such as Siemens S7-1200 and Allen-
Bradley CompactLogix/ControlLogix – Free Tags. 

 

EasyWatch 
EasyWatch is a utility that allows you to display and edit registers in the HMI and PLC in a spreadsheet-style format. It 
also provides a method of triggering an existing macro in the HMI for troubleshooting and debugging purposes. 

Open EasyWatch from the Tools menu (Tools > EasyWatch). You can also open it from the Project Toolbar by clicking 
on the EasyWatch icon. 

 

 

The first step in creating an EasyWatch project is to add one or more HMIs to the HMI Manager list.  
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To add an HMI to the project: 

1. Open the HMI Manager by clicking on the Objects menu and selecting HMI Manager, or by clicking on the 
HMI Manager icon in the toolbar. 

 

  

2. Click the Add button. Enter the IP address and Port No. of the HMI. The IP address of the HMI is configured 
in the System Settings window in the HMI. The Port No. is configured in the EZwarePlus project’s System 
Parameters > Model tab. 

 

Check Use Local HMI to connect to an Online or Offline Simulator running on the PC. It will appear as Local 
Host in the HMI Manager list. Click OK to add the HMI to the HMI Manager list. 

3. Repeat to add more HMIs to the list. Click Exit when completed. 
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The next step is to add address monitors in the EasyWatch window to view registers in an HMI and PLC. 

To add a Monitor object to the project: 

1. Open the Monitor Settings window by clicking on the Objects menu and selecting Add Object > Add 
Monitor, or by clicking on the Add New Address Monitor icon in the toolbar. 

2. Enter a name for the Monitor object or use the default. 

 

3. Uncheck the Read only checkbox if you want to modify the value in the register using EasyWatch. 

4. Select the HMI to connect through. All of the HMIs configured in the HMI Manager are available in the drop-
down list. 
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5. Select the PLC to monitor. If you want to monitor a register in the HMI, select HMI5000 Series HMI. If you 
want to monitor a register in a PLC connected to the HMI, select the PLC type from the drop-down list and 
enter the appropriate communication settings. 

 

6. Select the Address you wish to monitor and the appropriate Address Type. 

7. Select the Update Cycle. This determines how often the monitor is updated in EasyWatch, with a range from 
500 ms to 5000 ms. 

8. Click OK and repeat for each register you want to monitor. 

 

You can create multiple pages in EasyWatch. Click the “+” tab at the top of EasyWatch to create additional pages. 
Double-click on the tab name to rename it. In this example, three pages have been created to monitor a Modbus TCP 
device, the local HMI, and a Simulator running on the PC. 
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To begin monitoring data: 

1. Select one or more monitor objects in the list (hold the shift key to select multiple objects) and click the Run 
button in the toolbar. The status indicator for each selected monitor object will change from Stop to 
Connected and the Value column will display a number or state. 
If the red Address Error is displayed under the Status column, check the communication settings, address 
syntax, and physical connection to the device. 

 

To add a Macro object to the project: 

1. Open the Macro Settings window by clicking on the Objects menu and selecting Add Object > Add Macro, or 
by clicking on the Add New Macro icon in the toolbar. 

2. Enter a name for the Macro object or use the default. 

 

3. Select the HMI on which the macro resides. 
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4. Select the Macro Type by clicking the Active Type button. 
Direct Active: The selected macro object is triggered by a button in EasyWatch. An Active button appears in 
the Value column, which is used to trigger the macro object manually. 
Cycle Active: The selected macro object is triggered periodically. Click the Active Type button again to select 
the time period to wait before running the macro object again (range is 1 – 255 seconds).  

5. Select the macro to run by selecting the Macro ID number. Each macro in the HMI project has a unique ID 
number to identify it in addition to the name of the macro. Select the Macro ID number and click the Add 
button to add it to the list of macros. More than one macro can be run sequentially by adding them to the 
list. 

6. Select the Sleep button and Sleep Time to insert a delay between each macro (range 500 ms to 5000 ms). 

7. Click the Up and Down buttons to move an item up and down in the list. 

8. Click OK when finished. 

 

9. For macro objects configured for Cycle Active, select the macro object and click the Run button  in the 
toolbar to start running the macro object periodically. For macro objects configured for Direct Active, click 
the Active button to run the macro object once. 

An EasyWatch project can be saved by clicking File > Save As at the top of EasyWatch. The project is saved with a 
*.EWT extension, which allows it to be opened again at any time. 
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Chapter 18 – Using the Modbus Gateway 
The Modbus Gateway allows any ModbusTCP Master to request HMI data using standard Modbus commands.  The 
HMI uses the ModbusRTU/TCP Slave protocol to pass Modbus requests to any non-tag-based PLC or controller 
connected to the HMI, or the HMIs internal storage. 

 Tag-based PLCs are those that use named tags instead of addresses, such Allen Bradley Compact and 
Control Logix , Siemens S7-1200, and BACnet. 

For example, the Modbus Gateway would allow a SCADA system to obtain data from a device that is not supported 
by the SCADA system, but is supported by the HMI.  The Modbus Gateway also allows serial-connected devices access 
to the SCADA system. 

The Modbus Gateway support the following Modbus function codes (decimal): 

Code Definition 

1 Read Coil Status 

2 Read Input Status 

3 Read Holding Registers 

4 Read Input Registers 

5 Force Single Coil 

6 Preset Single Register 

15 Force Multiple Coils (LB addresses in the HMI only, not compatible with bits in a PLC) 

16 Preset Multiple Registers 

 

HMI Local Word LW9288 indicates Modbus communication errors: 

Value Error 

0 No error 

1 Attempt to read/write an undefined register 

2 Illegal Data Value 

3 Bad Command Format 

4 Attempt to write to a Read-only register 

5 Attempt to read to a Write-only register 

6 Timeout 

7 Invalid Function Code 
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Configuring the Modbus Gateway 
1. Configure the PLC to which Modbus registers will be mapped.  Refer to the System Parameter Settings 

section at the end of Chapter 6. 
2. On the Model tab of the System Parameter dialog, change the HMI Station Number to the Modbus Unit 

Number desired for the HMI. 
3. Change the Port Number to the port used by the ModbusTCP Master.  Typically, port 502 is used. 

 
 

Add the Modbus RTU/TCP Slave protocol to the project, and set the PLC I/F to Ethernet. Refer to the System 
Parameter Settings section at the end of Chapter 6. 

1. Check the Enable checkbox in the MODBUS TCP/IP Gateway section 
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This example will show how to use the Modbus Gateway to obtain data from an Animatics Smartmotor. 

1. Click the Address Mapping Tables button. 

 
By default, Modbus registers are mapped to HMI local storage. 

2. Click the Delete button to remove the selected entry. 
3. Click the Add button to map a Modbus register. 

 
  1010-1015, Rev. 03 



240  EZwarePlus Programming Manual 

In this example, Modbus registers are being mapped to array elements in an Animatics Smartmotor 
controller. 
Description: Enter a text description for this mapping. 
Device Type: Select whether the mapped data is a Bit or Word address. 
Mode: Configure the access privileges. 
MODBUS address: Specify the Modbus address. 
Mapped PLC address: Specify the PLC and address to which the Modbus address will be mapped.  In this 
example, Modbus registers are being mapped to the AL[] array in the Animatics Smartmotor. 
Table size: Specify how many words or bits are to be mapped.  The table starts with the addresses 
configured above.  In this example, 10 Modbus addresses are being mapped. 
Conversion: AB -> BA swaps the byte order during the mapping, ABCD -> CDAB swaps the word order. 

4. Click the OK button. 
5. Repeat for each address type to be mapped. 

 

Configuring the ModbusTCP Master 
The ModbusTCP Master must be configured to communicate with the HMI. 

In general, there will be a one-to-one matching of the Modbus address and the address mapped in the PLC.  If 32-bit 
types are used on one side, and 16-bit types are used on the other, addresses may be skipped. 

When the ModbusTCP Master requests data, the HMI will send the request to the mapped device, and return the 
data to the ModbusTCP Master.  In the Animatics example, when the ModbusTCP Master requests register 4x1, the 
HMI will request the data from Animatics register ArrayAL[0], and return the data to the ModbusTCP Master. 
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Appendix A – Reserved Local Memory 
EZwarePlus reserves some Local Words (LW) and Local Bits (LB) in the HMI for system use. These can be accessed 
with objects in EZwarePlus by selecting the System Tag checkbox in the Address window. 

 

They can also be accessed from the Tag Library by selecting the System radio button. 
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Here is a list of the current system tags in EZwarePlus. As new versions of EZwarePlus are released, these may 
change. You can export a list of the System Tags by selecting the Export EXCEL button in the Tag Library with the 
System Tags selected. 

Reserved Local Bits 

LB-9000 : initialized as ON 
LB-9001 : initialized as ON 
LB-9002 : initialized as ON 
LB-9003 : initialized as ON 
LB-9004 : initialized as ON 
LB-9005 : initialized as ON 
LB-9006 : initialized as ON 
LB-9007 : initialized as ON 
LB-9008 : initialized as ON 
LB-9009 : initialized as ON 
LB-9010 : data download indicator 
LB-9011 : data upload indicator 
LB-9012 : data download/upload indicator 
LB-9013 : FS window control[hide(ON)/show(OFF)] 
LB-9014 : FS button control[hide(ON)/show(OFF)] 
LB-9015 : FS window/button control[hide(ON)/show(OFF)] 
LB-9016 : status is on when a client connects to this HMI 
LB-9017 : disable write-back in PLC control's [change window] 
LB-9018 : disable mouse cursor (set ON) 
LB-9019 : disable/enable buzzer 
LB-9020 : show (set ON)/ hide (set OFF) system setting bar 
LB-9021 : reset current event log (set ON) 
LB-9022 : delete the earliest event log file on HMI memory (set ON) 
LB-9023 : delete all event log files on HMI  memory (set ON) 
LB-9024 : refresh event log information on HMI  memory (set ON) 
LB-9025 : delete the earliest data sampling file on HMI  memory (set ON) 
LB-9026 : delete all data sampling files on HMI  memory (set ON) 
LB-9027 : refresh data sampling information on HMI  memory (set ON) 
LB-9028 : reset all recipe data (set ON) 
LB-9029 : save all recipe data to machine (set ON) 
LB-9030 : update COM 1 communication parameters (set ON) 
LB-9031 : update COM 2 communication parameters (set ON) 
LB-9032 : update COM 3 communication parameters (set ON) 
LB-9033 : disable(when on)/enable (when off) HMI upload function 
LB-9034 : save event/data sampling to HMI, USB disk, SD card (set ON) 
LB-9035 : HMI free space insufficiency alarm (when ON) 
LB-9036 : SD card free space insufficiency alarm (when ON) 
LB-9037 : USB disk free space insufficiency alarm (when ON) 
LB-9038 : reserved 
LB-9039 : status of file backup activity (backup in process if ON) 
LB-9040 : backlight up (set ON) 
LB-9041 : backlight down (set ON) 
LB-9042 : acknowledge all alarm events (set ON) 
LB-9043 : unacknowledged events exist (when ON) 
LB-9044 : disable remote control (when ON) 
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LB-9045 : memory-map communication fails (when ON) 
LB-9046 : project key is different from HMI key (when ON) 
LB-9047 : reboot HMI (set ON when LB9048 is on) 
LB-9048 : reboot-HMI protection 
LB-9049 : enable (set ON)/disable (set OFF) watch dog 
LB-9050 : user logout 
LB-9051 : disconnect (set OFF)/connect (set ON) EasyAccess server  
LB-9052 : status of connecting to EasyAccess server 
LB-9053 : prohibit  password remote-read operation (when ON) 
LB-9054 : prohibit  password remote-write operation (when ON) 
LB-9055 : MODBUS server (COM 1) receives a request (when ON) 
LB-9056 : MODBUS server (COM 2) receives a request (when ON) 
LB-9057 : MODBUS server (COM 3) receives a request (when ON) 
LB-9058 : MODBUS server (Ethernet) receives a request (when ON) 
LB-9059 : disable MACRO TRACE function (when ON) 
LB-9060 : password error 
LB-9061 : update password (set ON) 
LB-9062 : open hardware setting dialog (set ON) 
LB-9063 : disable(set ON)/enable(set OFF) popup information dialog while finding an USB disk 
LB-9064 : enable USB barcode device (disable keyboard) (when ON) 
LB-9065 : disable/enable COM1 broadcast station no. 
LB-9066 : disable/enable COM2 broadcast station no. 
LB-9067 : disable/enable COM3 broadcast station no. 
LB-9068 : auto. connection for remote HMI 1 (when ON) 
LB-9069 : auto. connection for remote HMI 2 (when ON) 
LB-9070 : auto. connection for remote HMI 3 (when ON) 
LB-9071 : auto. connection for remote HMI 4 (when ON) 
LB-9072 : auto. connection for remote HMI 5 (when ON) 
LB-9073 : auto. connection for remote HMI 6 (when ON) 
LB-9074 : auto. connection for remote HMI 7 (when ON) 
LB-9075 : auto. connection for remote HMI 8 (when ON) 
LB-9100 : remote HMI 1 status (set on to retry connection) 
LB-9101 : remote HMI 2 status (set on to retry connection) 
LB-9102 : remote HMI 3 status (set on to retry connection) 
LB-9103 : remote HMI 4 status (set on to retry connection) 
LB-9104 : remote HMI 5 status (set on to retry connection) 
LB-9105 : remote HMI 6 status (set on to retry connection) 
LB-9106 : remote HMI 7 status (set on to retry connection) 
LB-9107 : remote HMI 8 status (set on to retry connection) 
LB-9149 : forced to reconnect remote HMI when IP changed on-line (set ON) 
LB-9150 : auto. connection for PLC 1 (COM1) (when ON) 
LB-9151 : auto. connection for PLC 2 (COM2) (when ON) 
LB-9152 : auto. connection for PLC 3 (COM3) (when ON) 
LB-9153 : auto. connection for PLC 4 (Ethernet) (when ON) 
LB-9154 : auto. connection for PLC 5 (Ethernet) (when ON) 
LB-9155 : auto. connection for PLC 6 (Ethernet) (when ON) 
LB-9156 : auto. connection for PLC 7 (Ethernet) (when ON) 
LB-9157 : auto. connection for PLC 8 (Ethernet) (when ON) 
LB-9158 : auto. connection for PLC 9 (Ethernet) (when ON) 
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LB-9190 : auto. connection for PLC (USB) (when ON) 
LB-9191 : PLC status (USB), set on to retry connection 
LB-9192 : disable USB  PLC's "PLC No Response" dialog (when ON) 
LB-9193 : reserved 
LB-9194 : reserved 
LB-9195 : reserved 
LB-9196 : local HMI supports monitor function only (when ON) 
LB-9197 : support monitor function only for remote HMIs (when ON) 
LB-9198 : disable local HMI to trigger a MACRO (when ON) 
LB-9199 : disable remote HMI to trigger a MACRO (when ON) 
LB-9200 : PLC 1 status (SN0, COM1), set on to retry connection 
LB-9201 : PLC 1 status (SN1, COM1), set on to retry connection 
LB-9202 : PLC 1 status (SN2, COM1), set on to retry connection 
LB-9203 : PLC 1 status (SN3, COM1), set on to retry connection 
LB-9204 : PLC 1 status (SN4, COM1), set on to retry connection 
LB-9205 : PLC 1 status (SN5, COM1), set on to retry connection 
LB-9206 : PLC 1 status (SN6, COM1), set on to retry connection 
LB-9207 : PLC 1 status (SN7, COM1), set on to retry connection 
LB-9460 : EM0's storage device (SD card) does not exist (when ON) 
LB-9461 : EM1's storage device (SD card) does not exist (when ON) 
LB-9462 : EM2's storage device (SD card) does not exist (when ON) 
LB-9463 : EM3's storage device (SD card) does not exist (when ON) 
LB-9464 : EM4's storage device (SD card) does not exist (when ON) 
LB-9465 : EM5's storage device (SD card) does not exist (when ON) 
LB-9466 : EM6's storage device (SD card) does not exist (when ON) 
LB-9467 : EM7's storage device (SD card) does not exist (when ON) 
LB-9468 : EM8's storage device (SD card) does not exist (when ON) 
LB-9469 : EM9's storage device (SD card) does not exist (when ON) 
LB-9470 : EM0's storage device (USB1 disk) does not exist (when ON) 
LB-9471 : EM1's storage device (USB1 disk) does not exist (when ON) 
LB-9472 : EM2's storage device (USB1 disk) does not exist (when ON) 
LB-9473 : EM3's storage device (USB1 disk) does not exist (when ON) 
LB-9474 : EM4's storage device (USB1 disk) does not exist (when ON) 
LB-9475 : EM5's storage device (USB1 disk) does not exist (when ON) 
LB-9476 : EM6's storage device (USB1 disk) does not exist (when ON) 
LB-9477 : EM7's storage device (USB1 disk) does not exist (when ON) 
LB-9478 : EM8's storage device (USB1 disk) does not exist (when ON) 
LB-9479 : EM9's storage device (USB1 disk) does not exist (when ON) 
LB-9480 : EM0's storage device (USB2 disk) does not exist (when ON) 
LB-9481 : EM1's storage device (USB2 disk) does not exist (when ON) 
LB-9482 : EM2's storage device (USB2 disk) does not exist (when ON) 
LB-9483 : EM3's storage device (USB2 disk) does not exist (when ON) 
LB-9484 : EM4's storage device (USB2 disk) does not exist (when ON) 
LB-9485 : EM5's storage device (USB2 disk) does not exist (when ON) 
LB-9486 : EM6's storage device (USB2 disk) does not exist (when ON) 
LB-9487 : EM7's storage device (USB2 disk) does not exist (when ON) 
LB-9488 : EM8's storage device (USB2 disk) does not exist (when ON) 
LB-9489 : EM9's storage device (USB2 disk) does not exist (when ON) 
LB-9500 : PLC 2 status (SN0, COM2), set on to retry connection 
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LB-9501 : PLC 2 status (SN1, COM2), set on to retry connection 
LB-9502 : PLC 2 status (SN2, COM2), set on to retry connection 
LB-9503 : PLC 2 status (SN3, COM2), set on to retry connection 
LB-9504 : PLC 2 status (SN4, COM2), set on to retry connection 
LB-9505 : PLC 2 status (SN5, COM2), set on to retry connection 
LB-9506 : PLC 2 status (SN6, COM2), set on to retry connection 
LB-9507 : PLC 2 status (SN7, COM2), set on to retry connection 
LB-9800 : PLC 3 status (SN0, COM3), set on to retry connection 
LB-9801 : PLC 3 status (SN1, COM3), set on to retry connection 
LB-9802 : PLC 3 status (SN2, COM3), set on to retry connection 
LB-9803 : PLC 3 status (SN3, COM3), set on to retry connection 
LB-9804 : PLC 3 status (SN4, COM3), set on to retry connection 
LB-9805 : PLC 3 status (SN5, COM3), set on to retry connection 
LB-9806 : PLC 3 status (SN6, COM3), set on to retry connection 
LB-9807 : PLC 3 status (SN7, COM3), set on to retry connection 
LB-10069 : forced to reconnect remote printer/backup server when IP changed on-line (set ON) 
LB-10070 : forced to reconnect PLC 4 (Ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10071 : forced to reconnect PLC 5 (Ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10072 : forced to reconnect PLC 6 (Ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10073 : forced to reconnect PLC 7 (Ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10074 : forced to reconnect PLC 8 (Ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10075 : forced to reconnect PLC 9 (Ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10100 : PLC 4 status (Ethernet), set on to retry connection 
LB-10400 : PLC 5 status (Ethernet), set on to retry connection 
LB-10700 : PLC 6 status (Ethernet), set on to retry connection 
LB-11000 : PLC 7 status (Ethernet), set on to retry connection 
LB-11300 : PLC 8 status (Ethernet), set on to retry connection 
LB-11600 : PLC 9 status (Ethernet), set on to retry connection 
LB-11900 : PLC 10 status (Ethernet), set on to retry connection 
LB-11901 : PLC 11 status (Ethernet), set on to retry connection 
LB-11902 : PLC 12 status (Ethernet), set on to retry connection 
LB-11903 : PLC 13 status (Ethernet), set on to retry connection 
LB-11904 : PLC 14 status (Ethernet), set on to retry connection 
LB-11905 : PLC 15 status (Ethernet), set on to retry connection 
LB-11906 : PLC 16 status (Ethernet), set on to retry connection 
LB-11940 : delete the earliest event log file on SD card (set ON) 
LB-11941 : delete all event log files on SD card (set ON) 
LB-11942 : refresh event log information on SD card (set ON) 
LB-11943 : delete the earliest event log file on USB disk (set ON) 
LB-11944 : delete all event log files on USB disk (set ON) 
LB-11945 : refresh event log information on USB disk (set ON) 
LB-11946 : reserved 
LB-11947 : reserved 
LB-11948 : reserved 
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LB-11949 : delete the earliest data sampling file on SD card (set ON) 
LB-11950 : delete all data sampling files on SD card (set ON) 
LB-11951 : refresh data sampling information on SD card (set ON) 
LB-11952 : delete the earliest data sampling file on USB disk (set ON) 
LB-11953 : delete all data sampling files on USB disk (set ON) 
LB-11954 : refresh data sampling information on USB disk (set ON) 
LB-11955 : reserved 
LB-11956 : reserved 
LB-11957 : reserved 
LB-11960 : disable PLC 1's "PLC No Response" dialog (when ON) 
LB-11961 : disable PLC 2's "PLC No Response" dialog (when ON) 
LB-11962 : disable PLC 3's "PLC No Response" dialog (when ON) 
LB-11963 : disable PLC 4's "PLC No Response" dialog (when ON) 
LB-11964 : disable PLC 5's "PLC No Response" dialog (when ON) 
LB-11965 : disable PLC 6's "PLC No Response" dialog (when ON) 
LB-11966 : disable PLC 7's "PLC No Response" dialog (when ON) 
LB-11967 : disable PLC 8's "PLC No Response" dialog (when ON) 
LB-12080 : auto. connection for PLC (CAN Bus) (when ON) 
LB-12081 : PLC status (CAN Bus), set on to retry connection 
LB-12082 : disable CAN Bus device's "PLC No Response" dialog (when ON) 

 

 

Reserved Local Words 

LW-9002 (32bit-float) : input high limit 
LW-9004 (32bit-float) : input low limit 
LW-9006 (16bit) : connected client no.  
LW-9008 (32bit-float) : battery voltage 
LW-9010 (16bit-BCD) : local second 
LW-9011 (16bit-BCD) : local minute 
LW-9012 (16bit-BCD) : local hour 
LW-9013 (16bit-BCD) : local day 
LW-9014 (16bit-BCD) : local month 
LW-9015 (16bit-BCD) : local year 
LW-9016 (16bit-BCD) : local week 
LW-9017 (16bit) : local second 
LW-9018 (16bit) : local minute 
LW-9019 (16bit) : local hour 
LW-9020 (16bit) : local day 
LW-9021 (16bit) : local month 
LW-9022 (16bit) : local year 
LW-9023 (16bit) : local week 
LW-9024 (16bit) : memory link system register 
LW-9025 (16bit) : CPU loading (x 100%) 
LW-9026 (16bit) : OS version (year) 
LW-9027 (16bit) : OS version (month) 
LW-9028 (16bit) : OS version (day) 
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LW-9030 (32bit) : system time (unit : 0.1 second) 
LW-9032 (8 words) : folder name of backup history files to SD, USB memory 
LW-9040 (16bit) : backlight index 
LW-9041 (16bit) : touch status word(bit 0 on = user is touching the screen) 
LW-9042 (16bit) : touch x position 
LW-9043 (16bit) : touch y position 
LW-9044 (16bit) : leave x position 
LW-9045 (16bit) : leave y position 
LW-9046 (32bit) : HMI key 
LW-9048 (16bit) : time (0 : AM, 1 : PM) 
LW-9049 (16bit) : local hour (12-hour format) 
LW-9050 (16bit) : current base window ID 
LW-9052 (32bit-float) : the previous input value of the numeric input object 
LW-9060 (16bit) : no. of event log files on HMI memory 
LW-9061 (32bit) : size of event log files on HMI memory 
LW-9063 (16bit) : no. of data sampling files on HMI memory 
LW-9064 (32bit) : size of data sampling files on HMI memory 
LW-9070 (16bit) : free space insufficiency warning (Megabytes) 
LW-9071 (16bit) : reserved free space size (Megabytes) 
LW-9072 (32bit) : HMI current free space (K bytes) 
LW-9074 (32bit) : SD current free space (K bytes) 
LW-9076 (32bit) : USB disk current free space (K bytes) 
LW-9078 reserved 
LW-9080 (16bit) : backlight saver time (unit : minute) 
LW-9081 (16bit) : screen saver time (unit : minute) 
LW-9100 (16bit) : project name (16 words) 
LW-9116 (32bit) : project size in bytes 
LW-9118 (32bit) : project size in K bytes 
LW-9120 (32bit) : compiler version 
LW-9122 (16bit) : project compiled date [year] 
LW-9123 (16bit) : project compiled date [month] 
LW-9124 (16bit) : project compiled date [day] 
LW-9125 (16bit) : HMI Ethernet gateway 0 (machine used only) 
LW-9126 (16bit) : HMI Ethernet gateway 1 (machine used only) 
LW-9127 (16bit) : HMI Ethernet gateway 2 (machine used only) 
LW-9128 (16bit) : HMI Ethernet gateway 3 (machine used only) 
LW-9129 (16bit) : HMI Ethernet IP 0 (machine used only) 
LW-9130 (16bit) : HMI Ethernet IP 1 (machine used only) 
LW-9131 (16bit) : HMI Ethernet IP 2 (machine used only) 
LW-9132 (16bit) : HMI Ethernet IP 3 (machine used only) 
LW-9133 (16bit) : Ethernet port no. 
LW-9134 (16bit) : language mode 
LW-9135 (16bit) : media access control (MAC) address 0 
LW-9136 (16bit) : media access control (MAC) address 1 
LW-9137 (16bit) : media access control (MAC) address 2 
LW-9138 (16bit) : media access control (MAC) address 3 
LW-9139 (16bit) : media access control (MAC) address 4 
LW-9140 (16bit) : media access control (MAC) address 5 
LW-9141 (16bit) : HMI station no. 
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LW-9150 (32 words) : keyboard's input data (ASCII) 
LW-9200 (16bit) : address index 0 
LW-9201 (16bit) : address index 1 
LW-9202 (16bit) : address index 2 
LW-9203 (16bit) : address index 3 
LW-9204 (16bit) : address index 4 
LW-9205 (16bit) : address index 5 
LW-9206 (16bit) : address index 6 
LW-9207 (16bit) : address index 7 
LW-9208 (16bit) : address index 8 
LW-9209 (16bit) : address index 9 
LW-9210 (16bit) : address index 10 
LW-9211 (16bit) : address index 11 
LW-9212 (16bit) : address index 12 
LW-9213 (16bit) : address index 13 
LW-9214 (16bit) : address index 14 
LW-9215 (16bit) : address index 15 
LW-9216 (16bit) : the result of importing email data 
LW-9219 (16bit) : user no. (1~12) 
LW-9220 (32bit) : password 
LW-9222 (16bit) : classes can be operated for current user (bit 0:A, bit 1:B,bit 2:C, ...) 
LW-9230 (32bit) : address index 16 
LW-9232 (32bit) : address index 17 
LW-9234 (32bit) : address index 18 
LW-9236 (32bit) : address index 19 
LW-9238 (32bit) : address index 20 
LW-9240 (32bit) : address index 21 
LW-9242 (32bit) : address index 22 
LW-9244 (32bit) : address index 23 
LW-9246 (32bit) : address index 24 
LW-9248 (32bit) : address index 25 
LW-9250 (32bit) : address index 26 
LW-9252 (32bit) : address index 27 
LW-9254 (32bit) : address index 28 
LW-9256 (32bit) : address index 29 
LW-9258 (32bit) : address index 30 
LW-9260 (32bit) : address index 31 
LW-9270 (16bit) : request's function code - MODBUS server (COM 1) 
LW-9271 (16bit) : request's starting address - MODBUS server (COM 1) 
LW-9272 (16bit) : request's quantity of registers - MODBUS server (COM 1) 
LW-9275 (16bit) : request's function code - MODBUS server (COM 2) 
LW-9276 (16bit) : request's starting address - MODBUS server (COM 2) 
LW-9277 (16bit) : request's quantity of registers - MODBUS server (COM 2) 
LW-9280 (16bit) : request's function code - MODBUS server (COM 3) 
LW-9281 (16bit) : request's starting address - MODBUS server (COM 3) 
LW-9282 (16bit) : request's quantity of registers - MODBUS server (COM 3) 
LW-9285 (16bit) : request's function code - MODBUS server (Ethernet) 
LW-9286 (16bit) : request's starting address - MODBUS server (Ethernet) 
LW-9287 (16bit) : request's quantity of registers - MODBUS server (Ethernet) 
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LW-9300 (16bit) : driver ID of local PLC 1 
LW-9301 (16bit) : driver ID of local PLC 2 
LW-9302 (16bit) : driver ID of local PLC 3 
LW-9303 (16bit) : driver ID of local PLC 4 
LW-9350 (16bit) : pending command no. in local HMI 
LW-9351 (16bit) : pending command no. in PLC 1 (COM 1) 
LW-9352 (16bit) : pending command no. in PLC 2 (COM 2) 
LW-9353 (16bit) : pending command no. in PLC 3 (COM 3) 
LW-9354 (16bit) : pending command no. in PLC 4 (Ethernet) 
LW-9355 (16bit) : pending command no. in PLC 5 (Ethernet) 
LW-9356 (16bit) : pending command no. in PLC 6 (Ethernet) 
LW-9357 (16bit) : pending command no. in PLC 7 (Ethernet) 
LW-9390 (16bit) : pending command no. in PLC (USB) 
LW-9392 (16bit) : pending command no. in PLC (CAN Bus) 
LW-9400 (16bit) : error code for PLC 1 
LW-9401 (16bit) : error code for PLC 2 
LW-9402 (16bit) : error code for PLC 3 
LW-9403 (16bit) : error code for PLC 4 
LW-9404 (16bit) : error code for PLC 5 
LW-9405 (16bit) : error code for PLC 6 
LW-9406 (16bit) : error code for PLC 7 
LW-9407 (16bit) : error code for PLC 8 
LW-9450 (16bit) : time tag of event log – second 
LW-9451 (16bit) : time tag of event log – minute 
LW-9452 (16bit) : time tag of event log – hour 
LW-9453 (16bit) : time tag of event log – day 
LW-9454 (16bit) : time tag of event log – month 
LW-9455 (16bit) : time tag of event log – year 
LW-9490 (16bit) : error code for USB PLC 
LW-9500 (32bit) : user 1's password 
LW-9502 (32bit) : user 2's password 
LW-9504 (32bit) : user 3's password 
LW-9506 (32bit) : user 4's password 
LW-9508 (32bit) : user 5's password 
LW-9510 (32bit) : user 6's password 
LW-9512 (32bit) : user 7's password 
LW-9514 (32bit) : user 8's password 
LW-9516 (32bit) : user 9's password 
LW-9518 (32bit) : user 10's password 
LW-9520 (32bit) : user 11's password 
LW-9522 (32bit) : user 12's password 
LW-9530 (8 words) : VNC server password 
LW-9540 (16bit) : reserved for caps lock 
LW-9541 (16bit) : MODBUS/ASCII server station no. (COM 1) 
LW-9542 (16bit) : MODBUS/ASCII server station no. (COM 2) 
LW-9543 (16bit) : MODBUS/ASCII server station no. (COM 3) 
LW-9544 (16bit) : MODBUS/ASCII server station no. (Ethernet) 
LW-9550 (16bit) : COM 1 mode(0:RS232,1:RS485 2W,2:RS485 4W) 
LW-9551 (16bit) : COM 1 baud rate(7:1200,8:2400,0:4800,1:9600,2:19200,3:38400,4:57600,..) 
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LW-9552 (16bit) : COM 1 data bits (7 : 7 bits, 8 : 8 bits) 
LW-9553 (16bit) : COM 1 parity (0:none, 1:even, 2:odd, 3:mark, 4:space) 
LW-9554 (16bit) : COM 1 stop bits (1 : 1 bit, 2 : 2 bits) 
LW-9555 (16bit) : COM 2 mode(0:RS232,1:RS485 2W,2:RS485 4W) 
LW-9556 (16bit) : COM 2 baud rate(7:1200,8:2400,0:4800,1:9600,2:19200,3:38400,4:57600,..) 
LW-9557 (16bit) : COM 2 data bits (7 : 7 bits, 8 : 8 bits) 
LW-9558 (16bit) : COM 2 parity (0:none, 1:even, 2:odd, 3:mark, 4:space) 
LW-9559 (16bit) : COM 2 stop bits (1 : 1 bit, 2 : 2 bits) 
LW-9560 (16bit) : COM 3 mode(0:RS232,1:RS485 2W) 
LW-9561 (16bit) : COM 3 baud rate(7:1200,8:2400,0:4800,1:9600,2:19200,3:38400,4:57600,..) 
LW-9562 (16bit) : COM 3 data bits (7 : 7 bits, 8 : 8 bits) 
LW-9563 (16bit) : COM 3 parity (0:none, 1:even, 2:odd, 3:mark, 4:space) 
LW-9564 (16bit) : COM 3 stop bits (1 : 1 bit, 2 : 2 bits) 
LW-9565 (16bit) : COM 1 broadcast station no. 
LW-9566 (16bit) : COM 2 broadcast station no. 
LW-9567 (16bit) : COM 3 broadcast station no. 
LW-9570 (32bit) :  received data count (bytes) (COM 1 MODBUS server) 
LW-9572 (32bit) :  received data count (bytes) (COM 2 MODBUS server) 
LW-9574 (32bit) :  received data count (bytes) (COM 3 MODBUS server) 
LW-9576 (32bit) :  received data count (bytes) (Ethernet MODBUS server) 
LW-9600 (16bit) : PLC 4's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9601 (16bit) : PLC 4's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9602 (16bit) : PLC 4's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9603 (16bit) : PLC 4's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9604 (16bit) : PLC 4's port no. 
LW-9605 (16bit) : PLC 5's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9606 (16bit) : PLC 5's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9607 (16bit) : PLC 5's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9608 (16bit) : PLC 5's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9609 (16bit) : PLC 5's port no. 
LW-9610 (16bit) : PLC 6's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9611 (16bit) : PLC 6's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9612 (16bit) : PLC 6's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9613 (16bit) : PLC 6's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9614 (16bit) : PLC 6's port no. 
LW-9615 (16bit) : PLC 7's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9616 (16bit) : PLC 7's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9617 (16bit) : PLC 7's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9618 (16bit) : PLC 7's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9619 (16bit) : PLC 7's port no. 
LW-9620 (16bit) : PLC 8's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9621 (16bit) : PLC 8's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9622 (16bit) : PLC 8's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9623 (16bit) : PLC 8's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9624 (16bit) : PLC 8's port no. 
LW-9625 (16bit) : PLC 9's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9626 (16bit) : PLC 9's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9627 (16bit) : PLC 9's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9628 (16bit) : PLC 9's IP3  (IP address = IP0:IP1:IP2:IP3) 
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LW-9629 (16bit) : PLC 9's port no. 
LW-9770 (16bit) : remote printer/backup server IP0 (IP0:IP1:IP2:IP3) 
LW-9771 (16bit) : remote printer/backup server IP1 (IP0:IP1:IP2:IP3) 
LW-9772 (16bit) : remote printer/backup server IP2 (IP0:IP1:IP2:IP3) 
LW-9773 (16bit) : remote printer/backup server IP3 (IP0:IP1:IP2:IP3) 
LW-9774 (6 words) : remote printer/backup server user name 
LW-9780 (6 words) : remote printer/backup server password 
LW-9800 (16bit) : remote HMI 1's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9801 (16bit) : remote HMI 1's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9802 (16bit) : remote HMI 1's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9803 (16bit) : remote HMI 1's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9804 (16bit) : remote HMI 1's port no. 
LW-9805 (16bit) : remote HMI 2's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9806 (16bit) : remote HMI 2's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9807 (16bit) : remote HMI 2's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9808 (16bit) : remote HMI 2's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9809 (16bit) : remote HMI 2's port no. 
LW-9810 (16bit) : remote HMI 3's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9811 (16bit) : remote HMI 3's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9812 (16bit) : remote HMI 3's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9813 (16bit) : remote HMI 3's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9814 (16bit) : remote HMI 3's port no. 
LW-9815 (16bit) : remote HMI 4's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9816 (16bit) : remote HMI 4's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9817 (16bit) : remote HMI 4's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9818 (16bit) : remote HMI 4's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9819 (16bit) : remote HMI 4's port no. 
LW-9820 (16bit) : remote HMI 5's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9821 (16bit) : remote HMI 5's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9822 (16bit) : remote HMI 5's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9823 (16bit) : remote HMI 5's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9824 (16bit) : remote HMI 5's port no. 
LW-9825 (16bit) : remote HMI 6's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9826 (16bit) : remote HMI 6's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9827 (16bit) : remote HMI 6's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9828 (16bit) : remote HMI 6's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9829 (16bit) : remote HMI 6's port no. 
LW-9830 (16bit) : remote HMI 7's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9831 (16bit) : remote HMI 7's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9832 (16bit) : remote HMI 7's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9833 (16bit) : remote HMI 7's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9834 (16bit) : remote HMI 7's port no. 
LW-9835 (16bit) : remote HMI 8's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9836 (16bit) : remote HMI 8's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9837 (16bit) : remote HMI 8's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9838 (16bit) : remote HMI 8's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9839 (16bit) : remote HMI 8's port no. 
LW-9900 (16bit) : HMI run mode (0 : normal mode, 1~3 : test mode (COM 1~COM 3) 
LW-9901 (16bit) : pass-through source COM port (1~3 : COM 1~COM 3) 
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LW-9902 (16bit) : pass-through destination COM port (1~3 : COM 1~COM 3) 
LW-9905 (16bit) : remote HMI 21's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9906 (16bit) : remote HMI 21's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9907 (16bit) : remote HMI 21's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9908 (16bit) : remote HMI 21's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9909 (16bit) : remote HMI 21's port no. 
LW-9910 (16bit) : remote HMI 22's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9911 (16bit) : remote HMI 22's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9912 (16bit) : remote HMI 22's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9913 (16bit) : remote HMI 22's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9914 (16bit) : remote HMI 22's port no. 
LW-9915 (16bit) : remote HMI 23's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9916 (16bit) : remote HMI 23's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9917 (16bit) : remote HMI 23's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9918 (16bit) : remote HMI 23's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9919 (16bit) : remote HMI 23's port no. 
LW-9920 (16bit) : remote HMI 24's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9921 (16bit) : remote HMI 24's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9922 (16bit) : remote HMI 24's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9923 (16bit) : remote HMI 24's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9924 (16bit) : remote HMI 24's port no. 
LW-9925 (16bit) : remote HMI 25's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9926 (16bit) : remote HMI 25's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9927 (16bit) : remote HMI 25's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9928 (16bit) : remote HMI 25's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9929 (16bit) : remote HMI 25's port no. 
LW-9930 (16bit) : remote HMI 26's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9931 (16bit) : remote HMI 26's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9932 (16bit) : remote HMI 26's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9933 (16bit) : remote HMI 26's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9934 (16bit) : remote HMI 26's port no. 
LW-9935 (16bit) : remote HMI 27's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9936 (16bit) : remote HMI 27's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9937 (16bit) : remote HMI 27's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9938 (16bit) : remote HMI 27's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9939 (16bit) : remote HMI 27's port no. 
LW-9940 (16bit) : remote HMI 28's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9941 (16bit) : remote HMI 28's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9942 (16bit) : remote HMI 28's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9943 (16bit) : remote HMI 28's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9944 (16bit) : remote HMI 28's port no. 
LW-9945 (16bit) : remote HMI 29's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9946 (16bit) : remote HMI 29's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9947 (16bit) : remote HMI 29's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9948 (16bit) : remote HMI 29's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9949 (16bit) : remote HMI 29's port no. 
LW-9950 (16bit) : remote HMI 30's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9951 (16bit) : remote HMI 30's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9952 (16bit) : remote HMI 30's IP2  (IP address = IP0:IP1:IP2:IP3) 
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LW-9953 (16bit) : remote HMI 30's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9954 (16bit) : remote HMI 30's port no. 
LW-9955 (16bit) : remote HMI 31's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9956 (16bit) : remote HMI 31's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9957 (16bit) : remote HMI 31's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9958 (16bit) : remote HMI 31's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9959 (16bit) : remote HMI 31's port no. 
LW-9960 (16bit) : remote HMI 32's IP0  (IP address = IP0:IP1:IP2:IP3) 
LW-9961 (16bit) : remote HMI 32's IP1  (IP address = IP0:IP1:IP2:IP3) 
LW-9962 (16bit) : remote HMI 32's IP2  (IP address = IP0:IP1:IP2:IP3) 
LW-9963 (16bit) : remote HMI 32's IP3  (IP address = IP0:IP1:IP2:IP3) 
LW-9964 (16bit) : remote HMI 32's port no. 
LW-10000 (16bit) : var0 - station no variable  (usage : var0#address) 
LW-10001 (16bit) : var1 - station no variable  (usage : var1#address) 
LW-10002 (16bit) : var2 - station no variable  (usage : var2#address) 
LW-10003 (16bit) : var3 - station no variable  (usage : var3#address) 
LW-10004 (16bit) : var4 - station no variable  (usage : var4#address) 
LW-10005 (16bit) : var5 - station no variable  (usage : var5#address) 
LW-10006 (16bit) : var6 - station no variable  (usage : var6#address) 
LW-10007 (16bit) : var7 - station no variable  (usage : var7#address) 
LW-10008 (16bit) : var8 - station no variable  (usage : var8#address) 
LW-10009 (16bit) : var9 - station no variable  (usage : var9#address) 
LW-10010 (16bit) : var10 - station no variable  (usage : var10#address) 
LW-10011 (16bit) : var11 - station no variable  (usage : var11#address) 
LW-10012 (16bit) : var12 - station no variable  (usage : var12#address) 
LW-10013 (16bit) : var13 - station no variable  (usage : var13#address) 
LW-10014 (16bit) : var14 - station no variable  (usage : var14#address) 
LW-10015 (16bit) : var15 - station no variable  (usage : var15#address) 
LW-10050 (16bit) : IP0 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10051 (16bit) : IP1 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10052 (16bit) : IP2 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10053 (16bit) : IP3 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10054 (16bit) : port no. of  the HMI connecting to remote PLC 1 
LW-10055 (16bit) : IP0 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10056 (16bit) : IP1 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10057 (16bit) : IP2 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10058 (16bit) : IP3 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10059 (16bit) : port no. of  the HMI connecting to remote PLC 2 
LW-10060 (16bit) : IP0 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10061 (16bit) : IP1 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10062 (16bit) : IP2 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10063 (16bit) : IP3 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10064 (16bit) : port no. of the HMI connecting to remote PLC 3 
LW-10065 (16bit) : IP0 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10066 (16bit) : IP1 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10067 (16bit) : IP2 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10068 (16bit) : IP3 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10069 (16bit) : port no. of the HMI connecting to remote PLC 4 
LW-10300 (16bit) : remote PLC 1's IP0 (IP address = IP0:IP1:IP2:IP3) 
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LW-10301 (16bit) : remote PLC 1's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10302 (16bit) : remote PLC 1's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10303 (16bit) : remote PLC 1's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10304 (16bit) : remote PLC 1's port no. 
LW-10305 (16bit) : remote PLC 2's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10306 (16bit) : remote PLC 2's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10307 (16bit) : remote PLC 2's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10308 (16bit) : remote PLC 2's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10309 (16bit) : remote PLC 2's port no. 
LW-10310 (16bit) : remote PLC 3's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10311 (16bit) : remote PLC 3's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10312 (16bit) : remote PLC 3's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10313 (16bit) : remote PLC 3's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10314 (16bit) : remote PLC 3's port no. 
LW-10315 (16bit) : remote PLC 4's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10316 (16bit) : remote PLC 4's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10317 (16bit) : remote PLC 4's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10318 (16bit) : remote PLC 4's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10319 (16bit) : remote PLC 4's port no. 
LW-10480 (16bit) : no. of event log files on SD card 
LW-10481 (32bit) : size of event log files on SD card 
LW-10483 (16bit) : no. of event log files on USB disk 
LW-10484 (32bit) : size of event log files on USB disk 
LW-10486 reserved 
LW-10487 reserved 
LW-10489 (16bit) : no. of data sampling files on SD card 
LW-10490 (32bit) : size of data sampling files on SD card 
LW-10492 (16bit) : no. of data sampling files on USB disk 
LW-10493 (32bit) : size of data sampling files on USB disk 
LW-10495 reserved 
LW-10496 reserved 
LW-10495 reserved 
LW-10496 reserved 
LW-10500 (16bit) : PLC 1 timeout (unit : 100ms) 
LW-10501 (16bit) : PLC 1 turn around delay (unit : ms) 
LW-10502 (16bit) : PLC 1 send ACK delay (unit : ms) 
LW-10503 (16bit) : PLC 1 parameter 1  
LW-10504 (16bit) : PLC 1 parameter 2 
LW-10505 (16bit) : PLC 2 timeout (unit : 100ms) 
LW-10506 (16bit) : PLC 2 turn around delay (unit : ms) 
LW-10507 (16bit) : PLC 2 send ACK delay (unit : ms) 
LW-10508 (16bit) : PLC 2 parameter 1 
LW-10509 (16bit) : PLC 2 parameter 2 
LW-10510 (16bit) : PLC 3 timeout (unit : 100ms) 
LW-10511 (16bit) : PLC 3 turn around delay (unit : ms) 
LW-10512 (16bit) : PLC 3 send ACK delay (unit : ms) 
LW-10513 (16bit) : PLC 3 parameter 1 
LW-10514 (16bit) : PLC 3 parameter 2 
LW-10515 (16bit) : PLC 4 timeout (unit : 100ms) 
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LW-10516 (16bit) : PLC 4 turn around delay (unit : ms) 
LW-10517 (16bit) : PLC 4 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10518 (16bit) : PLC 4 parameter 1 (SIEMENS S7/400 rack) 
LW-10519 (16bit) : PLC 4 parameter 2  (SIEMENS S7/400 CPU slot) 
LW-10520 (16bit) : PLC 5 timeout (unit : 100ms) 
LW-10521 (16bit) : PLC 5 turn around delay (unit : ms) 
LW-10522 (16bit) : PLC 5 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10523 (16bit) : PLC 5 parameter 1 (SIEMENS S7/400 rack) 
LW-10524 (16bit) : PLC 5 parameter 2  (SIEMENS S7/400 CPU slot) 
LW-10525 (16bit) : PLC 6 timeout (unit : 100ms) 
LW-10526 (16bit) : PLC 6 turn around delay (unit : ms) 
LW-10527 (16bit) : PLC 6 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10528 (16bit) : PLC 6 parameter 1 (SIEMENS S7/400 rack) 
LW-10529 (16bit) : PLC 6 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10530 (16bit) : PLC 7 timeout (unit : 100ms) 
LW-10531 (16bit) : PLC 7 turn around delay (unit : ms) 
LW-10532 (16bit) : PLC 7 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10533 (16bit) : PLC 7 parameter 1 (SIEMENS S7/400 rack) 
LW-10534 (16bit) : PLC 7 parameter 2  (SIEMENS S7/400 CPU slot) 
LW-10535 (16bit) : PLC 8 timeout (unit : 100ms) 
LW-10536 (16bit) : PLC 8 turn around delay (unit : ms) 
LW-10537 (16bit) : PLC 8 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10538 (16bit) : PLC 8 parameter 1 (SIEMENS S7/400 rack) 
LW-10539 (16bit) : PLC 8 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10700 (4 words) : DLT_645 operator (COM 1) 
LW-10704 (4 words) : DLT_645 password (COM 1) 
LW-10708 (6 words) : DLT_645 address (COM 1) 
LW-10715 (4 words) : DLT_645 operator (COM 2) 
LW-10719 (4 words) : DLT_645 password (COM 2) 
LW-10723 (6 words) : DLT_645 address (COM 2) 
LW-10730 (4 words) : DLT_645 operator (COM 3) 
LW-10734 (4 words) : DLT_645 password (COM 3) 
LW-10738 (6 words) : DLT_645 address (COM 3) 
LW-10750 (16bit) : HMI Ethernet Mask 0 (machine used only) 
LW-10751 (16bit) : HMI Ethernet Mask 1 (machine used only) 
LW-10752 (16bit) : HMI Ethernet Mask 2 (machine used only) 
LW-10753 (16bit) : HMI Ethernet Mask 3 (machine used only) 
LW-10754 (8 words) : current user name 
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Website: www.watlow.com

Watlow Electric Manufacturing Company (Shanghai) Co. Ltd.
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290 Songhu Road, Yangpu District
Shanghai, China 200433
China
Phone: 
Local: 4006 Watlow (4006 928569)
International: +86 21 3381 0188 
Fax: +86 21 6106 1423
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Website: www.watlow.cn

ワトロー・ジャパン株式会社 
〒101-0047 東京都千代田区内神田1-14-4 
四国ビル別館9階
Tel: 03-3518-6630	 Fax: 03-3518-6632
Email: infoj@watlow.com	 Website: www.watlow.co.jp

Watlow Japan Ltd.
1-14-4 Uchikanda, Chiyoda-Ku
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Tel: +81-3-3518-6630	 Fax: +81-3-3518-6632
Email: infoj@watlow.com	 Website: www.watlow.co.jp

Watlow Korea Co., Ltd.
#1406, E&C Dream Tower, 46, Yangpyeongdong-3ga
Yeongdeungpo-gu, Seoul 150-103
Republic of Korea
Tel: +82 (2) 2628-5770	 Fax: +82 (2) 2628-5771
Website: www.watlow.co.kr

Watlow Malaysia Sdn Bhd
1F-17, IOI Business Park
No.1, Persiaran Puchong Jaya Selatan
Bandar Puchong Jaya
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Malaysia
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瓦特龍電機股份有限公司
80143 高雄市前金區七賢二路189號 10樓之一
電話: 07-2885168	 傳真: 07-2885568

Watlow Electric Taiwan Corporation
10F-1 No.189 Chi-Shen 2nd Road Kaohsiung 80143 
Taiwan
Tel: +886-7-2885168	 Fax: +886-7-2885568
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